Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: W7: DHCP works fine, but NO Static IP


30 Jun 2010   #1

W7
 
 
W7: DHCP works fine, but NO Static IP

I got a little problem getting the static ip configuration to work on one of the Windows 7 machine, DHCP works but i need to be static. Here is the layout of my network:

1. Modem conected to:

2. 4 port wireless router conected to:

3. 8 port SMC giga switch conected to:
3a. Windows 7 computer - static ip
3b. WinXP computer - static ip
3c. Network printer - static ip
3d. Network camera - static ip
3e. 5 port SMC giga switch

3e. The 5 port SMC giga switch conected to:
3ei: WinXP computer - static ip
3eii. Windows 7 computer - with two lan cards
Lan card 1: its a 10/100 card that works both in DHCP and static form. (its disabled right now)
Lan card 2: ITs a 10/100/1000 card that only seems to work in DHCP form. Once i set it up as static, the computer wont see the network (without connection).

Notes:
1. Both Windows 7 boxes are configured the same way except the ip number of course.
2. The ip range on the network is in the 192.168.1.xxx
3. Gateway and Primary DNS: 192.168.1.1
4. Subnet: 255.255.255.0
5. I have disabled IPv6 (read in forums that might help) still doesnt work.

I have ran out of ideas.. :s

My System SpecsSystem Spec
.

30 Jun 2010   #2

Windows 7 Enterprise x64 SP1
 
 

I assume you tried various static ip addresses within that subnet and are keeping track of which ones you are using. Have you tried connecting the pc directly to your router?

Also, consider disabling dhcp on your router.

Does your adapter ip settings look similar to this?

Name:  Untitled3.png
Views: 12
Size:  68.3 KB

Out of curiosity, what is the make of the LAN card and what drivers are you using? Windows or OEM?


My System SpecsSystem Spec
01 Jul 2010   #3

W7
 
 

Hi merkat106, thanks for your reply

The adapter settings look like the one you posted, i do keep track of the ips used and there are no conflicts in that regard.

I got all the other machines configured and working properly. I havent hooked this one up directly to the router, i would be inclined to do it if there was a recurring problem with other systems but its just this one. Im sure i end up doing it if dotn fix it the way it is now.

The nic card used on this system is:
Brand: Intellinet
model: gigabit pci express
Drivers: windows installed them automatically but i will try the oem ones, thanks for the hint
My System SpecsSystem Spec
.


01 Jul 2010   #4

Vista 64 Ultimate, Windows 7 64 Ultimate, Ubuntu 9.10
 
 

kameleon,
I can recall having to add the static IP to the routers Client Reserved IP List and the problem you cite was no longer an issue, I think the problem you are experiencing is with the NIC, it might be a good idea to see if there is a firmware update for the NIC.
My System SpecsSystem Spec
01 Jul 2010   #5

W7
 
 

i just updated the driver with the oem one. The controler is a realtek rtl8168b/8111b

same result, i can ping all other computers but i cant surf the web.

I will check for a firmware update also, thanks fishnbanjo
My System SpecsSystem Spec
Reply

 W7: DHCP works fine, but NO Static IP




Thread Tools



Similar help and support threads for2: W7: DHCP works fine, but NO Static IP
Thread Forum
DHCP and static ip simultaneously, one nic ? Network & Sharing
Assign DHCP & Static IP of other subnet to the same NIC ? Network & Sharing
Internet Only Works w/ Proxy Server (Works fine everywhere else though Network & Sharing
dual net config dhcp or static ip Network & Sharing
W7: DHCP works fine, but NO Static IP Network & Sharing
How to enable DHCP and Static IP adress on the same NIC ? Network & Sharing
Switch from DHCP to Static IP Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 10:30 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33