Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Very Odd Internet Issue

12 May 2009   #1

Windows 7 RC 7100
Very Odd Internet Issue

Okay, here it goes:

I'm running the newest RC 7100 for Windows 7 and I am having issues connecting to most webpages. This site, Google and Yahoo work fine but most forums, blogs just fail. I can't even run a speed test! Here is where it gets weird. This only happens at college! People next to me are running Vista just fine and their net is moving really fast so the network is fine. At home, it runs really fast and smooth for IE8 and I don't have issues. It seems to be only here. I can't think of anything that could be the root of this issue. I tried compatibility mode but no dice on that either.

Any help?

Edit: My connection isn't dropping either

My System SpecsSystem Spec
12 May 2009   #2

Windows 7 7265 x64

Sounds like DNS issues with the campus wifi. might check with the school IT folk.
My System SpecsSystem Spec

 Very Odd Internet Issue

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar help and support threads
Thread Forum
Desktop WIFI Internet Issue - Connected, but Slow/Dropped Internet
I've been battling this particular issue for a couple of weeks now without much success. I have a custom built desktop where my WIFI connection will deteriorate to the point where internet (and gaming over Steam, etc...) will be either painfully slow or unable to load pages at all. Windows claims...
Network & Sharing
Internet Issue
Hi, I am faciing Issue at the time of Internet Dial up. When i have downloaded Hotfix for Windows (KB947821) after restarting system, it prompting below error: Cannot Load the Remote Access Service Manager Service. Error: 711: The operation could not finish because it could not...
Network & Sharing
Another issue with Internet connection.
Hello. I had been having earlier problems, but after a full sustem restore, I had finally got my system up and running.. except for the fact that the Internet connection had the classic Windows 'i' Icon. I have been having this problem for days after the malware removal. I had already tried...
Network & Sharing
Internet Issue
After about 4 hours of being online. My internet wont display, I have a connection it goes this page can't be displayed and i have to restart my laptop. I havent installed anything. Windows 7 home premium x32 bit Acer
Network & Sharing
W7 internet issue
Hello-- I have a relatively new dell with W7. I have seen tons of similar forums, and I always see the same fix suggestions. Things I've tried reinstalling windows running netsh in cmd removing firewall rebooting router configuring advanced wireless settings
Network & Sharing
Multiboot and internet issue
Hi all, I loaded win7 build 7000 the other night onto my system drive (2x 36gig raptor,raid0 on rocket raid3510 pcie) I have the drive partitioned as follows: 20g XP32 20g XP64 28g win7 Install went flawlessly! Installed all drivers booted up quick and patched itself really fast, incl some...
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 20:39.

Twitter Facebook Google+

Windows 7 Forums

Seven Forums Android App Seven Forums IOS App