Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: "Wireless Network Connection" doesn't have a valid IP configuration

16 Jul 2010   #1
therealman

 
 
"Wireless Network Connection" doesn't have a valid IP configuration

RESOLVED!!

I was wondering if someone could help me,
I recently switched to a new internet provider and now my Windows 7 Laptop will no longer connect to the internet.
The error message says: "Wireless Network Connection" doesn't have a valid IP configuration

if someone can help to explain why this is it would be great, there is also another computer in the house running Windows XP which works fine.

The router is a:
Quote:
NetComm NB6PLUS4W Wireless ADSL2+ Router
The IP configuration for the working XP laptop is:
Quote:
Windows IP Configuration
Host Name . . . . . . . . . . . . : Familycomputer
Primary Dns Suffix . . . . . . . :
Node Type . . . . . . . . . . . . : Hybrid
IP Routing Enabled. . . . . . . . : No
WINS Proxy Enabled. . . . . . . . : No
DNS Suffix Search List. . . . . . : home
Ethernet adapter {EE9739C7-EF60-4296-B389-B49F320086AB}:
Media State . . . . . . . . . . . : Media disconnected
Description . . . . . . . . . . . : Anchorfree HSS Adapter - Packet Sche
duler Miniport
Physical Address. . . . . . . . . : 00-FF-EE-97-39-C7
Ethernet adapter Local Area Connection:
Connection-specific DNS Suffix . : home
Description . . . . . . . . . . . : Broadcom 440x 10/100 Integrated Cont
roller
Physical Address. . . . . . . . . : 00-C0-9F-74-8B-64
Dhcp Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
IP Address. . . . . . . . . . . . : 192.168.1.4
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Default Gateway . . . . . . . . . : 192.168.1.1
DHCP Server . . . . . . . . . . . : 192.168.1.1
DNS Servers . . . . . . . . . . . : 192.168.1.1
Lease Obtained. . . . . . . . . . : Friday, 16 July 2010 7:14:40 p.m.
Lease Expires . . . . . . . . . . : Saturday, 17 July 2010 7:14:40 p.m.
While the IP Configuration for my Win7 not working latop is:
Quote:
C:\Users\Daniel>ipconfig/all
Windows IP Configuration
Host Name . . . . . . . . . . . . : Daniel-PC
Primary Dns Suffix . . . . . . . :
Node Type . . . . . . . . . . . . : Hybrid
IP Routing Enabled. . . . . . . . : No
WINS Proxy Enabled. . . . . . . . : No
Ethernet adapter Local Area Connection* 11:
Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Anchorfree HSS Adapter
Physical Address. . . . . . . . . : 00-FF-12-50-7B-C9
DHCP Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
Ethernet adapter Local Area Connection:
Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . : home
Description . . . . . . . . . . . : Broadcom NetLink (TM) Gigabit Ethernet
Physical Address. . . . . . . . . : 00-26-2D-5F-BB-7E
DHCP Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
Wireless LAN adapter Wireless Network Connection:
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Atheros AR5B93 Wireless Network Adapter
Physical Address. . . . . . . . . : 0C-EE-E6-C2-0B-B4
DHCP Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
Link-local IPv6 Address . . . . . : fe80::bd73:c425:292e:9d5%11(Preferred)
Default Gateway . . . . . . . . . :
DHCPv6 IAID . . . . . . . . . . . : 185396966
DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-12-85-47-4E-0C-EE-E6-C2-0B-B4
DNS Servers . . . . . . . . . . . : fec0:0:0:ffff::1%1
fec0:0:0:ffff::2%1
fec0:0:0:ffff::3%1
NetBIOS over Tcpip. . . . . . . . : Enabled
Tunnel adapter isatap.{12507BC9-8B45-4276-B509-8D911E6450E6}:
Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Microsoft ISATAP Adapter #2
Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes
Tunnel adapter Local Area Connection* 12:
Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Microsoft 6to4 Adapter
Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes
Tunnel adapter Local Area Connection* 13:
Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Teredo Tunneling Pseudo-Interface
Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes
Tunnel adapter isatap.home:
Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Microsoft ISATAP Adapter #3
Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes
Tunnel adapter isatap.{DFEE66F6-9370-4159-BD91-0ED5885720DB}:
Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Microsoft ISATAP Adapter #4
Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes
Tunnel adapter Reusable ISATAP Interface {E1ED6C55-AFB6-44D5-8E3D-57AD292D7B63}:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Microsoft ISATAP Adapter #5
Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes
Any help would be awesome!


My System SpecsSystem Spec
.
16 Jul 2010   #2
Solarstarshines

Windows 10 Home Premium 64bit sp1
 
 

i had that issue with my wife's cousin laptop he was trying all night to connect and it never would but everything else was on i would love to know the answer if there is one
My System SpecsSystem Spec
27 Mar 2011   #3
boggett2001

Windows 7
 
 

I was getting that gosh-awful message, and so was my husband. Disconnecting and reconnecting to the router didn't help mine, but it did help my husband's. So I went to the network and sharing center. On my active networks (which weren't working) I clicked on "connect or disconnect", highlighted my laptop (with the problem), right-clicked on it, chose properties, then connection tab, and clicked on the box that says "connect even if the network is not broadcasting its name (SSID)". Clicked okay, then disconnected/reconnected the router (removed power cable, then ether cable, wait 10 seconds, replace ether cable, then power cable in that order). Problem solved!
My System SpecsSystem Spec
.

14 Jan 2012   #4
HarveyAlaric

Windows 7 Home Premium 32bit
 
 
Thank you Boggett2001

Thank you so much...this worked for me after more than 2 years of seeking the answer and having to reset my router every morning before I could access the internet.
My System SpecsSystem Spec
Reply

 "Wireless Network Connection" doesn't have a valid IP configuration




Thread Tools




Similar help and support threads
Thread Forum
"Wireless Network Connection" doesn't have a valid IP configuration
the laptop I am typing this from wi-fi works, I have a Gateway MX6920 that originally had Windows XP on it, I wiped that and installed Windows 7. and have very few installed programs on it. Openoffice, firefox, teamviewer, Gimp, and a steam game is all that's on it (and an Antivirus) but it will no...
Network & Sharing
"Local Area Connection" doesn't have a valid IP configuration.
Howdy folks. Just moved back onto campus for the year and already running into some problems. I'm able to connect to the wireless internet in my dorm just fine, but it's just god awful, so I've always used a wired connection. When I try that now though, it always comes up as "Unidentified Network"...
Network & Sharing
"Wireless network connection" doesnt have a valid IP configuration...
hello all, my internet has previously worked without any problems. two days ago, it said i was connected with limited connectivity. i tried disabling/enabling my wireless, unplugging the wireless router, and running troubleshoot. the computer said that my wireless network connection...
Network & Sharing
"wireless network connection" doesn't have a valid IP configuration
Okay, so here is my problem. I frequently bring my laptop to work where the is a public wireless signal. I work at a hospital. There is a secure network but I don't have the password for it, so I use the public one. Up until recently I used an old asus with vista, and while the signal was...
Network & Sharing
Wireless connection "Doesn't have valid IP configuration"
I have spent half a day reading and searching forums and tried many different supposed solutions. CMD commands, Bonjour disabled, winsock resets. The following screen shot is what I get when I type in ipconfig. I am wits end here, I can't remember that last time I have had a problem with a computer...
Network & Sharing
Wireless Network Connection" doesn't have a valid IP configuration
I'm using Windows 7 Ultimate 64 bit and I have a USB adaptor (a belkin on) but for some reason, my internet stopped working on my own computer. It will work on my phone and the computer that the router is connected to, but I get the error stated in the title. I am connected to the network, but the...
Network & Sharing


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 07:12.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App