Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Problem using Stunnel in Windows 7

19 Jul 2010   #1

windows 7
 
 
Problem using Stunnel in Windows 7

Using stunnel with usenet application in Windows 7
I have usenet program(Newsleecher v4.0 beta 20) that I use in conjunction with SSL by using a program called stunnel (which establish and encrypted SSL tunnel). Basically Newsleecher does a loopback to 127.0.0.1 to port 119. Port 119 is redirected to the stunnel app which sets up an encrypted connection to my Usenet server(Newshosting).

When I was using Windows XP I had no problems. However in Windows 7 it does'nt let me establish a a localhost connection to my stunnel application.

stunnel picks up 10 connections but newsleecher times out. I also looked at the firewall rules and allowed stunnel access to all port private/public and all protocols. If use newsleecher with SSL it works fine.

Here are the configuration files...

Newsleecher settings:

Server Address: 127.0.0.1
Port: 119
Encrypted Server Connection (SSL) is checked


stunnel.conf settings:

; Use it for client mode
client = yes

; Service-level configuration

compression = zlib

[nntps]

accept = 127.0.0.1:119

connect = nhxl.newshosting.com:563

My System SpecsSystem Spec
.

04 Aug 2010   #2

windows 7
 
 

To answer my own question...The newest version of newsleecher natively supports SSL. No need for stunnel.
My System SpecsSystem Spec
04 Aug 2010   #3

none
 
 
Problem using Stunnel in Windows 7

I have usenet program(Newsleecher v4.0 beta 20) that I use in conjunction with SSL by using a program called stunnel (which establish and encrypted SSL tunnel). Basically Newsleecher does a loopback to 127.0.0.1 to port 119. Port 119 is redirected to the stunnel app which sets up an encrypted connection to my Usenet server(Newshosting).

When I was using Windows XP I had no problems. However in Windows 7 it does'nt let me establish a a localhost connection to my stunnel application.

stunnel picks up 10 connections but newsleecher times out. I also looked at the firewall rules and allowed stunnel access to all port private/public and all protocols. If use newsleecher with SSL it works fine.
My System SpecsSystem Spec
.


Reply

 Problem using Stunnel in Windows 7




Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 01:17 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33