Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Windows 7 beta testers find critical Windows Installer Bug

20 Jan 2009   #1

Vista X64 ultimate/ 7 X64 Ultimate (7264)
 
 
Windows 7 beta testers find critical Windows Installer Bug

Mary Jo reports that a number of Windows 7 Beta testers have come across a bug that crashes the system randomly whenever they try to start a Windows Update or install anything using Microsoft's MSI installer.





Enthusiast Chris Holmes claims that many users have started experiencing random crashing of explorer and msiexec.exe when trying to start Windows Update or install anything that uses an MSI based installer. Some have gone to the extent of reinstalling the beta.

Rafael has discovered that the fault arises from the Software Quality Management (SQM) Client which is a part of the Customer Experience Improvement Program (CEIP). It seems that any process that calls WinSqmStartSession in ntdll.dll will start crashing when machine throttling is enabled in the registry and when CEIP is running.

The suggested workarounds are as follows:

1) Deleting the string values other than Default value in HKLM\Software\Microsoft\SQMClient\Windows\DisabledSessions in the Windows Registry [Or] renaming MachineThrottling to _MachineThrottling in the same node.



2) Turn Off Windows Customer Experience Improvement Program which can be done by traversing through the nodes - Computer Configuration->Administrative Templates->System->Internet Communication Management->Internet Communication settings in the Local Group Policy Editor.



If you are a Windows 7 Beta tester, please make sure that you report any bugs to Microsoft using the new Send Feedback tool


source: neowin.net


My System SpecsSystem Spec
.

20 Jan 2009   #2
Microsoft MVP

64-bit Windows 8.1 Enterprise
 
 

I just got this from the Action Center messages today:

Quote:
Solve a problem with Windows 7 beta

An issue with the Customer Experience Improvement Program (CEIP) client in Windows 7 beta is causing Explorer and some MSI-based installers to stop working properly.

To solve this problem, follow these steps:
  1. Click the Start button , click All Programs, and then click Accessories.
  2. Right-click Command Prompt, and then click Run as administrator. In the User Account Control window, verify that Program name is Windows Command Processor, and then click Yes.
  3. In the Administrator: Command Prompt window, type or paste the following text at the prompt:
    reg delete HKLM\SOFTWARE\Microsoft\SQMClient\Windows\DisabledSessions /va /f
  4. Press Enter to install the solution.
  5. If The operation completed successfully displays, close the Administrator: Command Prompt window to complete this procedure. If "ERROR: Access is denied" displays, repeat this procedure from the top, making sure you clicked Run as administrator in step two.
My System SpecsSystem Spec
20 Jan 2009   #3

Win7 x64 Ultimate RTM
 
 

My System SpecsSystem Spec
.


20 Jan 2009   #4

Windows 7 Ultimate
 
 

Very timely. Just happened to me for the first time last night. Was able to get update going by running as administrator after several attempts.
Fix installed.
Thanks
My System SpecsSystem Spec
20 Jan 2009   #5

Vista Ult SP2/Win 7 Ult SP1/Win 8.1 Pro w/MC (all x64)
 
 

Thanks for this. It just started for me this morning. I thought that an update had taken care of it, obviously not.
My System SpecsSystem Spec
20 Jan 2009   #6

Windows 7 7100 build
 
 

I had this problem and was able to fix it
My System SpecsSystem Spec
21 Jan 2009   #7

Windows 7 x64
 
 

I received the solution last night and applied it. but some minutes afterwards explorer.exe crashed again. this time I didn't do anything in particular. dunno if I had to restart for the fix to work and I haven't restarted ever since. :S
My System SpecsSystem Spec
21 Jan 2009   #8

Vista Ult SP2/Win 7 Ult SP1/Win 8.1 Pro w/MC (all x64)
 
 

Try a restart.
My System SpecsSystem Spec
21 Jan 2009   #9

Windows 7 Home Premium
 
 

OMG! This fixes ALL the install issues I was having on my x64 box. This thread should be stickied for EVERYONE to ensure that they perform this.
My System SpecsSystem Spec
21 Jan 2009   #10

Vista Ult 64 bit Seven Ult RTM x64
 
 

When I tried to uninstall a program this morning, I got the windows is looking for a solution box and for the first time in Vista or Windows 7, windows actually found a solution and this registry fix was it.

Gary
My System SpecsSystem Spec
Reply

 Windows 7 beta testers find critical Windows Installer Bug




Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 06:57 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33