Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Show Us Your Rig [5]

14 Jun 2013   #721
essenbe

Windows 7 Enterprise X64/Windows 10 Enterprise X64/Windows 10 Pro X64/Linux Mint
 
 

Non, for some reason I can't connect right now ( lousy ISP and internet speed) but, I believe I have seen the pcie covers at frozen CPU (www.frozencpu.com) If I m not mistaken they also come as a set with ram covers and all of them in almost any color you want.


My System SpecsSystem Spec
.
14 Jun 2013   #722
essenbe

Windows 7 Enterprise X64/Windows 10 Enterprise X64/Windows 10 Pro X64/Linux Mint
 
 

My System SpecsSystem Spec
14 Jun 2013   #723
linnemeyerhere

Microsoft Community Contributor Award Recipient

Windows 7 Ultimate 64
 
 

My System SpecsSystem Spec
.

14 Jun 2013   #724
NoN

Windows 7 Professional SP1 - x64 [Non-UEFI Boot]
 
 

Quote   Quote: Originally Posted by essenbe View Post
Thanks...but the page doesn't load.

Edit: it tooks time to but they charge me Usps priority mail international: $32,50


Quote   Quote: Originally Posted by linnemeyerhere View Post
Yes, those are the ones i was looking for...but They do not ship around! Totally out of stock within EU!


Attached Thumbnails
Show Us Your Rig [5]-capture.png  
My System SpecsSystem Spec
14 Jun 2013   #725
essenbe

Windows 7 Enterprise X64/Windows 10 Enterprise X64/Windows 10 Pro X64/Linux Mint
 
 

Try here and see if some of these places have it.
Europe Archives | LamptronLamptron
My System SpecsSystem Spec
14 Jun 2013   #726
NoN

Windows 7 Professional SP1 - x64 [Non-UEFI Boot]
 
 

Quote   Quote: Originally Posted by essenbe View Post
Try here and see if some of these places have it.
Europe Archives | LamptronLamptron
Thanks, i'm used on some sites there in EU...guess i did a search back when i first build my Desktop Pc.

Might try again!
My System SpecsSystem Spec
23 Jun 2013   #727
thesouldemon

Windows 7 Home Premium 64Bit
 
 

My first build :3 As you can see, my cable management skills are expert.





The first picture is when I was building it. I now have the SSD duct taped to the case because I don't have a bracket yet haha.

CPU - Intel 3570k @ 4.2GHz
Motherboard - ASRock z77 Extreme4
Memory - 16GB G.Skill Ripjaws Series 1600 MHz DDR3
Graphics Card - AMD Radeon HD 7950 Windforce Edition
Monitor - Asus VH238H (23")
Hard Drives -SSD: 120GB Samsung 840 Series(boot), HDD: WD Cavier Black 1TB
PSU - CORSAIR Builder Series CX600
Case - CM Storm Scout
Cooling - Cooler Master Hyper 212 EVO
Keyboard - Logitech G110
Mouse - Razer Abyssus
Headphones - Audiotechnica ATHM50

Not as good as others peoples, but again, it was my first build :P
My System SpecsSystem Spec
23 Jun 2013   #728
linnemeyerhere

Microsoft Community Contributor Award Recipient

Windows 7 Ultimate 64
 
 

Soul,
Nice rig and yes your cable management is exemplary ! Try velcro dots for the SSD rather than duct tape unless your going for that whole MacGyver thing.
My System SpecsSystem Spec
23 Jun 2013   #729
Dude

Windows 10 Pro X64
 
 

thesouldemon,

That is a nice rig, you solved the rubix cube so cable management will come to you.
My System SpecsSystem Spec
23 Jun 2013   #730
essenbe

Windows 7 Enterprise X64/Windows 10 Enterprise X64/Windows 10 Pro X64/Linux Mint
 
 

thesouldemon, Nice rig. Cable management is an art, not a science. I didn't Major in Art, so it looks OK to me.
My System SpecsSystem Spec
Closed Thread

 Show Us Your Rig [5]




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Show Us Your Rig [8]
Spring is on and is beautifully sunny, flowered trees are green and diffuse their scents...:) My desk is lightened by...
PC Custom Builds and Overclocking
Subfolders does not show in OWA, but show in Outlook.
Hi! Running server 2008 with exchange server. The user is using both OWA webmail and local Outlook. User got multiple inbox's to access, 1 personal and 2 for the company. The personal one got subfolders which shows in OWA, but the problem is the other folders. They are only needed by this 1...
Microsoft Office
HDDs Show in BIOS, But Do Not Show in Disk Management
Hello, A newbie here that just completed a first-time new Win7 PC build. Successful installation of Win7 Pro on WD 600GB 10000 system drive. Went back and installed 4 additional HDD. (2) WD Caviar Black 1TB 7200 RPM and (2) WD Caviar 7200 500GB HDD from XP system that were used for storage. ...
Hardware & Devices
Show us your Wig
:haha:
Chillout Room
backup files will only show up if i click show hidden files and folder
Hey Guys, I cannot find a soultion to this problem. I was using my desktop like normal then an error came up saying that there was a hdd failure, and that i needed to scan for errors. all my files disappeared and only this error would come up. There would be hundreds of the same msg spamed on my...
Backup and Restore
show hidden folders show file extensions thru registry
I am trying to setup a default user or machine setup for how win7 handles folder view options. I want show hidden folders to be set to on for all users and the hide extensions for know file types to be unchecked or turned off ffor all users (so extensions show) I have located them in the registry...
General Discussion


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 03:38.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App