Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: New prossesor won't work, PC lights and fans turn on.

25 Dec 2013   #1
dukethedj

Windows 8.1 Pro x86 (Temporary)
 
 
New prossesor won't work, PC lights and fans turn on.

Hi and happy holidays! I recently got my new (slightly used ) AMD Phenom II X4 840 Edition Deneb 3.2 GHz 4x512 KB L2 Cache Socket AM3 95W Quad-Core Processor - Retail HDX840WFGMBOX (Black) from amazon. I installed the processor with no trouble and go to make a test boot and....... WHAT THE! The lights and fans turn on but NOTHING I repeat: NOTHING goes on the screen. It just goes to sleep! (I had the side of the PC case off, for good measure.) Here are some screen-shots from CPU-Z for my current processor info and motherboard:








My System SpecsSystem Spec
.
25 Dec 2013   #2
DocBrown

Win7 Enterprise, Win7 x86 (Ult 7600), Win7 x64 Ult 7600, TechNet RTM on AMD x64 (2.8Ghz)
 
 

Did you get the notch on the one corner of the CPU in the correct position with the socket notch ?

How to install AMD AM2, AM2+, AM3 and AM3+ CPU + Cooler! - YouTube
My System SpecsSystem Spec
25 Dec 2013   #3
dukethedj

Windows 8.1 Pro x86 (Temporary)
 
 

Quote   Quote: Originally Posted by DocBrown View Post
Did you get the notch on the one corner of the CPU in the correct position with the socket notch ?

How to install AMD AM2, AM2+, AM3 and AM3+ CPU + Cooler! - YouTube
Yes, I did. (It is a triangle )
My System SpecsSystem Spec
.

25 Dec 2013   #4
dukethedj

Windows 8.1 Pro x86 (Temporary)
 
 

When the processor got in, some of the pins on the edge were slightly bent. So I straightened them with a gift card. Does that have something to do with it?
My System SpecsSystem Spec
25 Dec 2013   #5
DocBrown

Win7 Enterprise, Win7 x86 (Ult 7600), Win7 x64 Ult 7600, TechNet RTM on AMD x64 (2.8Ghz)
 
 

If any pins got bent just enough not to fit in their respective holes, that would most likely cause a problem.
My System SpecsSystem Spec
25 Dec 2013   #6
Solarstarshines

Windows 10 Home Premium 64bit sp1
 
 

I don't think it is that, that happens to people on occasion

Have you checked all your connections all the hardware make sure everything is plugged in
My System SpecsSystem Spec
25 Dec 2013   #7
dukethedj

Windows 8.1 Pro x86 (Temporary)
 
 

Quote   Quote: Originally Posted by DocBrown View Post
If any pins got bent just enough not to fit in their respective holes, that would most likely cause a problem.
The pins did go in fine.
My System SpecsSystem Spec
25 Dec 2013   #8
dukethedj

Windows 8.1 Pro x86 (Temporary)
 
 

Quote   Quote: Originally Posted by Solarstarshines View Post
I don't think it is that, that happens to people on occasion

Have you checked all your connections all the hardware make sure everything is plugged in

I know al the connections are fine. I am using the same PC with my Sempron installed.





Could it be a wattage problem?




This also happened when I installed new RAM. It is fixed now, though.
My System SpecsSystem Spec
25 Dec 2013   #9
dukethedj

Windows 8.1 Pro x86 (Temporary)
 
 

Oh, and the fan that came with the Phenom is SMALLER than the one from the Sempron. Is that a problem?
My System SpecsSystem Spec
25 Dec 2013   #10
Solarstarshines

Windows 10 Home Premium 64bit sp1
 
 

could it be the wrong socket for that cpu is it AM2 OR AM2+ AM2 is not backwards compatible

AM2+ is it will work with AM3 and AM3+ Chips not FX though
My System SpecsSystem Spec
Reply

 New prossesor won't work, PC lights and fans turn on.




Thread Tools




Similar help and support threads
Thread Forum
Any BIOS updates for the Pegatron Corp NARRA5 to support AM3 prossesor
I ordered an AMD Phenom ll x 4 (AM3) for my PC with a Pegatron Corp NARRA5 Motherboard (AM2+) and I've heard that you need specific BIOS updates to support AM3. Since I've never updated the BIOS for the motherboard that is in a PC from April 2010 and Pegatron is probably dead, can you find any BIOS...
Hardware & Devices
PC Fans Turn On Then OFF No Screen Display.
This is on my old PC and im trying to fix it but im not sure if the mobo is no good or the psu or what. The PC can power on as well as the fans but maybe 5-10 seconds later the fans turn off and there is no display on the screen but the PSU fan is still going. AMD Pheonom X4 9550 Quad Core...
General Discussion
PC wont boot, just get black screen, but fans etc work?
Hi, really need all your urgent help as I'm freaking out a bit as its not really my comp, and its fairly new. Okay my computer turns ON, but makes less noise than it used to when working, and just shows a black screen...doesn't even enter bios. Recent changes: Ok, I installed a new...
BSOD Help and Support
Case fans dont work?
All fans are connected this on picture and they go to potentiometer, also as you can see on first picture there is a molex cable which one goes also on potentiometer on second picture... I connected molex cable to PSU and it doesnt work http://img864.imageshack.us/img864/2681/dsc02443.jpg ...
Hardware & Devices
Turn off lights.
Does anyone know how to turn off the lights of my notebook..? I mean the Caps. Lock/Num Lock/Charger/Network lights. I'm on Vista btw.
Hardware & Devices
How Do I View My Video Card Memory and Prossesor Speed
How Do I View My Video Cards Memory And Prosessor Speed.
Graphic Cards


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 13:47.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App