Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: my 8gb ram all used help.


02 Feb 2014   #1
key4you

windows 7 ultimate
 
 
my 8gb ram all used help.

i have hp dv 6 with 2gb graphic and 8 gig of ram. but facing very slow start up. and after some use all ram used. need help.




Attached Thumbnails
-capture.png  
My System SpecsSystem Spec
.

02 Feb 2014   #2
Ztruker

Windows 8 Core X64
 
 

Click on Resource Monitor and see what it shows for Memory utilization. Post a screen capture.
My System SpecsSystem Spec
02 Feb 2014   #3
key4you

windows 7 ultimate
 
 

svchost.exe using 6 gb ram
My System SpecsSystem Spec
.


02 Feb 2014   #4
matts6887

Windows 7 ultimate 64-bit
 
 

Sounds like some program or background service is using quite a bit of memory; but Z is right; we need to see that resource monitor to figure whats using all the ram.
My System SpecsSystem Spec
02 Feb 2014   #5
matts6887

Windows 7 ultimate 64-bit
 
 

Quote   Quote: Originally Posted by key4you View Post
svchost.exe using 6 gb ram
yea; that is quite a bit of ram for any service to use and there really should be some sort of explanation for it.
My System SpecsSystem Spec
02 Feb 2014   #6
Ztruker

Windows 8 Core X64
 
 

You can also take a look at it with ProcessExplorer. It may provide more information.
My System SpecsSystem Spec
03 Feb 2014   #7
key4you

windows 7 ultimate
 
 

i just start laptop and within 10 minutes this happen.


Attached Thumbnails
-capture1.png   -capture2.png   -capture3.png  
My System SpecsSystem Spec
03 Feb 2014   #8
key4you

windows 7 ultimate
 
 

after 30 minutes this


Attached Thumbnails
-capture5.png  
My System SpecsSystem Spec
03 Feb 2014   #9
OldMX

Microsoft Windows 8.1 Professional
 
 

Seems like you have a video or audio codec issue, thats why the COM Surrogate was triggered.
My System SpecsSystem Spec
03 Feb 2014   #10
key4you

windows 7 ultimate
 
 

Hello, Microsoft will not help you with this problem, but I will.
I had the same problem, I solved it completelly and in 2 minutes:

The problem appears when dllhost.exe attempts to create a thumbnail of an mp4 file, but for some reason cannot complete the task, and starts reading the hard drive non stop and filling all phisical Ram, and starts using the swap file (virtual memory file wich uses hard drive space as ram memory), slowing down or freezing the computer.
The cause is probably an error in the integrated mp4 windows codecs.

Anyway, the solution is to download and install a freeware program wich generates all video files thumbnails instead of windows. It even creates thumbails of flash (flv) files!

You can download it from this link:

Codecs.com | Downloads for Media Preview 1.3.1.343

Or googleing Media Preview 1.3.1.343
After the installation is complete, simply enable all the video files thumbnail options and done.
Problem solved. You do not even need to restart the computer.

Before you install it you should kill the dllhost.exe if it is running. After the installation, just open a folder or select a file to see the thumbnails generate quickly and without any problems.

If you have the tasks monitor open, you will see the dllhost appear while the thumbnails are being generated, and then it will disappear. It will never exeed 20.000kb.

Done and done.

I hope this helps anyone with the same issue.

Regards.
My System SpecsSystem Spec
Reply

 my 8gb ram all used help.




Thread Tools



Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 12:15 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App