Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Icons in menus and folders load/display slowly

03 Sep 2010   #11

Win7 Home Premium x64

Quote   Quote: Originally Posted by cluberti View Post
I wonder if you simply have icon cache problems - have you tweaked the install at all? I know there are tools out there to rebuild the icon cache, and reg keys to increase it's size, but if it happens on every reboot that would seem to indicate perhaps icon cache problems?
Could be... I'm not sure what you mean by "tweak" the install, this is a prebuilt system that had an OEM version of Win7 already loaded out-of-the-box. I have tried to increase the icon cache size, but I have not tried to delete/rebuild the icon cache database file. Which might be worth a shot.

My System SpecsSystem Spec
07 Sep 2010   #12

Win 7 Ultimate x64
Same problem but no MSE loaded

I am having this same problem on a completely fresh install of Windows 7 Ult x64. I have been running Win7 on this machine since the beta just before the RC and have used every version up until current. This has never happened even after I have loaded eleventy billion apps.

I have Win installed on my Vertex SSD with apps separated to my WD storage drive. I haven't even gotten far enough to install anything other than the same drivers I used before my reinstall. I just can't think of what could be causing it. Everything seems responsive except for menus. I get a white page icon for about 2 seconds before the regular on loads, and they only load when I look at them. Meaning if I pull the menu up it takes a few secs to draw the icons/folders, then if I go back later to look in a folder I get same delay inside each folder. I really don't want to reinstall everything again and just hope it fixes it...
My System SpecsSystem Spec
07 Sep 2010   #13

Windows 10 Pro x64

It might be useful to run process monitor whilst reproducing the thumbnail delay to see if there's any hdd file or registry access that is causing the delay.
My System SpecsSystem Spec

15 Sep 2011   #14

Windows 10 Home 64b

I have the same darn problem, is the only thing i really hate from Windows 7 and the problem was long time before i installed MSE so could not be the problem. Every time i reboot or do a could boot and go to Start--> All Programs the icons have to reload again. I have tried the cache rebuild, but nothing helps. Is there any word from Microsoft on this matter?
My System SpecsSystem Spec

 Icons in menus and folders load/display slowly

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar help and support threads
Thread Forum
Specific web pages only load slowly on all browsers
When I log into my work's website, I can log in on the main page and navigate it fine. However, there are several pages within my company website that load extremely slowly. I mean, they take over 10 minutes to load. The pages are my company mail inbox, my schedule, and the page where I bid for...
Browsers & Mail
Google Chrome & other Browsers won't load properly/slowly
Lately, whenever i want to visit any web page, the browsers won't load it properly. On google chrome it said that sometimes "unable to connect to internet", and whenever it is loaded it loads jumbled on the first few times. After refreshing or reloading the slow page several times, it loads...
Browsers & Mail
Suddenly folders load very slowly (blank) green progress bar loads.
Windows 7 ultimate. Intel i7 PC. Suddenly after startup folders load very slowly (or not, blank) green progress bar loads. Simultaneously the (template) thumbnails in the aero theme selection window goes blank too (they do work just after login). I have noticed that when I wanted to change...
General Discussion
Icons in Explorer display slowly
I have network drives mapped on my machine (Win 7 Pro 64bit) and any time I open Explorer while not connected to my companies domain, the icons take anywhere from 15-20 seconds to fully display. As soon as I disconnect all the drives, the icons display immediately. Any ideas?
Network & Sharing
icons loading slowly
I don't know if this is normal, but everytime i connect a USB portable hard drive or flash drive and access the drive, the icons start to show slowly and then it will load quickly afterwards. But after the drive is removed and connected again (tomorrow for example) the icons shows slowly again as...
General Discussion
Possible to add Right Context menus for folders
Is it possible to add folder to the right click context menus? For folders I use often? So I can right click and move files to these folders without opening folders and cut and pasting these?

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 21:19.

Twitter Facebook Google+

Windows 7 Forums

Seven Forums Android App Seven Forums IOS App