Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Laggy performance during high usage - caused by System Interrupts


03 Oct 2010   #1

Windows 7 Ultimate X64
 
 
Laggy performance during high usage - caused by System Interrupts

After I returned from Holidays...I noticed that when I perform tasks that use considerable amount of CPU, the computer 'lags' and the sound seems to freeze. Each cycle being 1 sec long. It will continue to do so until I leave the computer and close CPU-consuming applications such as games, Media Players etc...It usually happens when I play games and watch movies though...

I initially thought that it was a virus so I scanned etc, then I thought it might be due to the CPU overheating, so I opened my machine and checked the CPU paste. It was fine no problems there. Then I checked the processes, nothing and finally arrived at System Resources where I saw that 'System Interrupts' was eating around 30 - 50% of my CPU. I have searched google and haven't come to a solution for this. I have updated my chipset drivers, graphic card drivers, sound drivers, Network card drivers, Motherboard etc. There is no effect whatsoever. It's really frustrating me as I can't even listen to music sometimes...I had used up all of my USB ports, so I tried taking some out, but there was no result...

When I restart it kind of calms down, but then it comes again. Even when I type in my password to enter Windows, the welcome sound freezes momentarily again. I have recently bought this system (custom built myself) so I'm really frustrated and cant think of a reason why this happens so suddenly

Any help will be greatly appreciated

My System SpecsSystem Spec
.

03 Oct 2010   #2

Systems 1 and 2: Windows 7 Enterprise x64, Win 8 Developer
 
 

Welcome to SF, msjamalan!

If it's a virus or malware problem, please reboot into safe mode and run your scans. Malwarebytes should be your malware scanner.

If you have a lot of applications open at one time, you may want to bump up your memory.

You can also run msconfig and see if you can uncheck startup items. Be careful with this one.

Still, I wonder why this change has occurred after you have returned from vacation. Can you think of anything different before and after holidays?
My System SpecsSystem Spec
03 Oct 2010   #3
whs
Microsoft MVP

Vista, Windows7, Mint Mate, Zorin, Windows 8
 
 

Run the latency checker ( DPC Latency Checker ). If you have any red bars, you may have a driver problem.
My System SpecsSystem Spec
.


03 Oct 2010   #4

Windows 7 Ultimate X64
 
 

I strongly doubt it's a virus. In terms of applications I don't allow applications to open on startup...only AVG and drivers...

I'm sure 4GB memory is enough for what I do...you can check my specs under my name, my graphics card has 1GB dedicated memory, so I shouldn't have a problem there...I dont do any major multitasking

As I mentioned before the root of all the performance problem is the 'System interrupts', and to my understanding of computers these occur usually when and I/O device needs to communicate with the CPU? Maybe one of my peripherals are problematic?

Nothing changed during the holidays, or when I returned. That's why it doesn't make any sense to me. Could it be a recent driver update?
My System SpecsSystem Spec
Reply

 Laggy performance during high usage - caused by System Interrupts




Thread Tools



Similar help and support threads for2: Laggy performance during high usage - caused by System Interrupts
Thread Forum
System Interrupts high CPU usage windows 7 64 bit... Drivers
BSOD's & High CPU System Interrupts BSOD Help and Support
System Interrupts usage 3-4% of ram Performance & Maintenance
System Interrupts high CPU when any usb device gets plugged in Performance & Maintenance
system interrupts causing 60-80% CPU usage Performance & Maintenance
100% CPU Usage System Interrupts on Acer Timeline Hardware & Devices
85% cpu usage due to system interrupts, Help?! BSOD Help and Support

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 09:04 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33