Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: 2 minute hang at "welcome" screen, only on admin account.

01 Nov 2010   #1

Windows 7 64bit
2 minute hang at "welcome" screen, only on admin account.


I am running windows 7 x64. I have a password for my main account, which is an admin account. When I enter the password and hit enter, the "Welcome" screen stares at me for about 2 minutes before going to the desktop.

I can not figure out why this happens. I have tried the "don't use a solid color background" fix.

I have tried unplugging all unnecessary USB devices.

I have unchecked ALL of the items in startup services.

I created a new user account that is not an admin account, and has no password. When I select this account at startup, the "welcome" screen only appears for 1-2 seconds, and then goes to the desktop.

Why would my admin account hang so long on the welcome screen, but my other use account does not?

Both accounts have the same drivers and applications installed.

Any thoughts? I've been through a hundred forums, and have tried all the usual fixes, with no positive results.

My System SpecsSystem Spec
01 Nov 2010   #2
Microsoft MVP

Vista, Windows7, Mint Mate, Zorin, Windows 8

What happens when you run your admin account without the password?
My System SpecsSystem Spec
01 Nov 2010   #3

Windows Embedded Standard 7 32 bit

The Welcome message is displayed as Windows is loading your user's profile. My best guess is that there is something slowing down loading the admin user's registry hive, but it is tough to say. I would recommend creating a new administrative user and confirming that it logs in fine. Then copy that user's profile to the administrator's profile.

I don't have a full-fledged Win 7 machine in front of me right now, just a stripped down embedded install, so I can't give you detailed instructions on how to do it. On XP it is under System Properties, Advanced, User Profiles.
My System SpecsSystem Spec

01 Nov 2010   #4

Windows 7

Have you tried this?
Fix a corrupted user profile
My System SpecsSystem Spec

 2 minute hang at "welcome" screen, only on admin account.

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar help and support threads
Thread Forum
"You are about to be logged off" "Windows will shut down in 1 minute"
I am ashamed to say I seem to have obtained some sort of malware, virus, or perhaps some some "funny" fella using a .bat or .vbs file. At seemingly random times a window will pop up: I highly doubt this is anything...
System Security
"Not Responding" error every other minute w/30sec-2min hang-up
Ello! So my title says it all, but here it is... So this laptop is almost 10yrs old ('05 or '06), I got it off Craigslist with the same stability issues and it took me 3 weeks to get it stable (I could even run WoW and DDO w/no issues). Well, long story short, I had to reinstall win7 a couple days...
BSOD Help and Support
Hang up on "Please Wait", system restored, now black screen...
So a couple of days ago, my PC started hanging up on a "Please Wait" loading screen in between the "Starting Windows" screen (where the Windows logo forms from coloured orbs) and the user account selection screen. Sometimes I'd leave it half an hour and it still wouldn't load. To start with, I...
BSOD Help and Support
Windows 7 OEM, "You're account as been disabled." Admin account
Hi all, Just installed an OEM version of Windows 7 Ultimate on a custom-made machine. It gets to the point of logging in. I type in Administrator and press enter, and I get the response, "You're account has been disabled. Please see your network administrator." As it stands, I can't log in at...
General Discussion
Getting "must be administrator" messages under admin account.
I have only one user account on my laptop (Windows 7) and naturally it is an administrator account. But when trying to install new software, more often than not, I get a message saying I need to be logged in under an administrator account to continue. Not always but far too often. For example,...
Computer hangs at "Starting Windows" screen for over one minute.
Hello, I just finished building my computer the other day and installed Windows 7 Ultimate 64 bit edition. The install went great and the computer is amazingly fast, but I am less than impressed with the boot time. I have windows installed on two Corsair Force GT 60 GB Solid State Drives in...
Installation & Setup

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 09:01.

Twitter Facebook Google+

Windows 7 Forums

Seven Forums Android App Seven Forums IOS App