Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Why did my computer lag even though my CPU and RAM usage was low?

24 Dec 2010   #1

Windows 7 Professional 32bit
 
 
Why did my computer lag even though my CPU and RAM usage was low?

Why did my computer lag even though my CPU and RAM usage was low?
CPU usage was at around 20%. RAM usages was at around 60%.
I was viewing a webpage.

Edit: I was not loading a webpage. The webpage was already loaded. I was viewing the webpage.

My System SpecsSystem Spec
.

24 Dec 2010   #2

Microsoft Community Contributor Award Recipient

Windows 7 Home Premium SP1, clean install, upgrade disc
 
 

Probably the ISP
My System SpecsSystem Spec
24 Dec 2010   #3

Windows 7 Professional 32bit
 
 

Quote   Quote: Originally Posted by richc46 View Post
Probably the ISP
I was not loading a webpage. The webpage was already loaded. I was viewing the webpage.
My System SpecsSystem Spec
.


24 Dec 2010   #4

Microsoft Community Contributor Award Recipient

Windows 7 Home Premium SP1, clean install, upgrade disc
 
 

Maybe there were still graphics etc that were loading. Even now with Windows 7, Im on a pgage and it lags or even freezes, stuff is still loading even after you can see the page.
My System SpecsSystem Spec
24 Dec 2010   #5

Windows 8 Core X64
 
 

Where are you experiencing the lag? In IE or doing other things while IE is showing a web page?

When you say you were just viewing the page, do you mean scrolling up or down in it? If so then what rich46 said may the cause.
My System SpecsSystem Spec
27 Dec 2010   #6

Windows 7 Professional 32bit
 
 

Quote   Quote: Originally Posted by richc46 View Post
Maybe there were still graphics etc that were loading. Even now with Windows 7, Im on a pgage and it lags or even freezes, stuff is still loading even after you can see the page.
Quote   Quote: Originally Posted by Ztruker View Post
Where are you experiencing the lag? In IE or doing other things while IE is showing a web page?

When you say you were just viewing the page, do you mean scrolling up or down in it? If so then what rich46 said may the cause.
I was scrolling up and down. But I wonder my graphics card would be the cause of the lag... my graphics card is one year old and was one of the newwest models one year ago. I've got about 2GB of graphics memory and it is rated by Windows at a score of 7.2... how could it and why would it be causing lags?
My System SpecsSystem Spec
27 Dec 2010   #7

Windows 7 Ultimate 64bit
 
 

give us the specs of your machine.
Sounds like an issue with a plug in on the site, maybe flash.
My System SpecsSystem Spec
27 Dec 2010   #8

Winbdows 7 ultimate x64 | Ubuntu 12.04 x64 LTS
 
 

Quote   Quote: Originally Posted by jenkins View Post
Quote   Quote: Originally Posted by richc46 View Post
Maybe there were still graphics etc that were loading. Even now with Windows 7, Im on a pgage and it lags or even freezes, stuff is still loading even after you can see the page.
Quote   Quote: Originally Posted by Ztruker View Post
Where are you experiencing the lag? In IE or doing other things while IE is showing a web page?

When you say you were just viewing the page, do you mean scrolling up or down in it? If so then what rich46 said may the cause.
I was scrolling up and down. But I wonder my graphics card would be the cause of the lag... my graphics card is one year old and was one of the newwest models one year ago. I've got about 2GB of graphics memory and it is rated by Windows at a score of 7.2... how could it and why would it be causing lags?
Try disabling hardware acceleration. Open IE>Tools>Internet options>Advanced tab>Use software rendering instead of hardware.
My System SpecsSystem Spec
Reply

 Why did my computer lag even though my CPU and RAM usage was low?




Thread Tools



Similar help and support threads for2: Why did my computer lag even though my CPU and RAM usage was low?
Thread Forum
Monitor Computer Usage Time Software
Consistent BSOD after apx. 1-2 hrs computer usage BSOD Help and Support
General state of computer usage. General Discussion
Solved computer power usage General Discussion
Restrictions on Computer Usage General Discussion
Computer Idling at 55% Ram Usage Performance & Maintenance
Computer Usage Timer Gadgets

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 07:31 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33