Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: PCI-E Sata II RAID 0 slow....driver issues?

14 Feb 2011   #1

Windows 7 Pro x64
 
 
PCI-E Sata II RAID 0 slow....driver issues?

Well, I've searched now for several days and played with every setting I can think of, but still can't coax better than average performance out of a recent install of RAID 0 using an Silicon Image 3132 based PCI-e (x1) Sata2 card (should have bought the UD3LR!). I've convinced myself it's a driver problem, but I can't find anyone having a similar problem in all of my searching. The actual card is the SYBA SD-SA2PEX-21R. Looks like a reference design.

With Raid 0 and a 64KB stripe, I'm only getting between 80MB/s - 133MB/s on HDTune with a burst speed of 145MB/s (max). I'm using two new Hitachi Deskstar 500GB drives. I've tried all the block sizes and yes, the larger block sizes produce the high end of the range, the smaller block sizes bring it down significantly.

If I connect the drives directly to my MB, the transfer rates are essentially the same +/- 10MB/s and the burst mode is much much better about 240MB/s (as expected for SATA II).

I've flashed the card, installed and uninstalled the 64bit drivers from the Silicon Image website, the vendor website, etc. Now I'm just shooting in the dark.
I've tested with every available stripe size and it always tops out at around 133MB. I switched from IDE to AHCI, trying anything, but I'm doubtful that setting affected the card or the drivers. The other drives run fine under AHCI.

Anyone? I know the difference between hard and soft RAID, but I think this performance stinks for a soft RAID 0 with SATAII drives sitting on a x1 PCI-e bus....

am I stuck? crummy card/chipset? (the only benefit has been that these hitachi drives are very quiet!)

thanks!

Gigabyte GA-EP45-UD3L
E8500 (running 4ghz)
HD5850


My System SpecsSystem Spec
.

15 Feb 2011   #2

Windows 7 Ultimate x64
 
 

Are you noticing that the performance is slow all around or just on writes?

A while back when I was setting up my RAID array (it's 5 not 0 so might not apply) I was getting decent read performance but writes were slow. I found that I needed to en able the write back cache and now my performance is quite good.

I also did a bit of digging on your MoBo and I could not exactly find the spec on the 1x PCIe lane, but the Gigabyte site specifically calls out that only the x16 slot is PCIe 2.0 compliant. So, it might be that your 1x lane is only the 1.x version and that caps your bandwidth to the card at 250MB/s. Given some overhead, I wouldn't be shocked if 133MB/s is the best you could do for throughput to your card.
My System SpecsSystem Spec
15 Feb 2011   #3

Windows 7 Ultimate x64 SP1
 
 

What you are finding is one of many reasons why RAID0 is dead...at least for spinners. The theoretical performance and actual performance were two vastly different things, and when you add in the negatives, the hype died out some time ago.

If you really want performance on a desktop system, sell the RAID card and one of the drives, then invest in an SSD.
My System SpecsSystem Spec
.


15 Feb 2011   #4

Windows 7 Pro x64
 
 

roger that, I get your point for boot drives, and while I know the cost is coming down for the larger SSDs, for TB+ storage I think Raid 0 is useful and has good price-performance, with it's associated risks, i.e. if it's stuff I really want to keep (and not just re-install), then I go with RAID 10, like the 3TB home server I just finished.

I'm sure we are in the waning days of "spinners"....(sigh...from one who remembers using cards...)

....now, about those SSDs....Fry's has the 64GB Kingston V100 in the ad this week for pretty cheap (< $90) after rebate....could be calling my name.
My System SpecsSystem Spec
15 Feb 2011   #5

Windows 7 Pro x64
 
 

Quote   Quote: Originally Posted by SailingNut View Post
Are you noticing that the performance is slow all around or just on writes?

A while back when I was setting up my RAID array (it's 5 not 0 so might not apply) I was getting decent read performance but writes were slow. I found that I needed to en able the write back cache and now my performance is quite good.

I also did a bit of digging on your MoBo and I could not exactly find the spec on the 1x PCIe lane, but the Gigabyte site specifically calls out that only the x16 slot is PCIe 2.0 compliant. So, it might be that your 1x lane is only the 1.x version and that caps your bandwidth to the card at 250MB/s. Given some overhead, I wouldn't be shocked if 133MB/s is the best you could do for throughput to your card.
thanks for checking it out. it's really just on reads....and by slow, it's not bad, it just is seemingly hitting some top-end on the transfer rate (reads), which to your point, could just be the PCI-e x1 "real world"....but I've seen other benchmarks for x1 cards that seem to move up closer to 200MB (the supposed "real world" performance for that bus).

I downloaded the Hitachi tools and booted into that utility...everything seems in order (write and read caching is enabled, power saving is off, etc), so I think it's just the card, the bus, the driver or some combination not worth figuring out!!

as the last poster mentioned SSDs, I notice they are getting pretty cheap for the smaller capacities....that could be my boot drive, then I'll keep the raid for my larger data....
My System SpecsSystem Spec
16 Feb 2011   #6

Windows 7 Ultimate x64
 
 

My point (albeit I'm no expert on PCIe) is that there are multiple versions of the PCIe spec. The 1.x spec for a 1x lane is 250 MB/s for 2.x it is 500MB/s and 3.0 it is 1 GB/s.

Here's my source: PCI Express - Wikipedia, the free encyclopedia
My System SpecsSystem Spec
16 Feb 2011   #7

Windows 7 Pro x64
 
 

Quote   Quote: Originally Posted by SailingNut View Post
My point (albeit I'm no expert on PCIe) is that there are multiple versions of the PCIe spec. The 1.x spec for a 1x lane is 250 MB/s for 2.x it is 500MB/s and 3.0 it is 1 GB/s.

Here's my source: PCI Express - Wikipedia, the free encyclopedia

gotcha...and actually I thought the benchmark I saw was for 1.x, but you are right, if it was 2.0 or higher, then all bets are off.....
My System SpecsSystem Spec
04 Feb 2012   #8

linux
 
 

Quote   Quote: Originally Posted by dlhendo View Post
Quote   Quote: Originally Posted by SailingNut View Post
....
A while back when I was setting up my RAID array (it's 5 not 0 so might not apply) I was getting decent read performance but writes were slow. I found that I needed to en able the write back cache and now my performance is quite good.
....
....
I downloaded the Hitachi tools and booted into that utility...everything seems in order (write and read caching is enabled, power saving is off, etc), so I think it's just the card, the bus, the driver or some combination not worth figuring out!!
.....
Your problem related to RAID0 performance don't have any relations to RAID5 cache settings. As You now know, problem is generated by PCIe 1x rev 1.0 speed and efficiency of implementation in controllers.

Cache in RAID5:
This array is totally different from RAID0. RAID5 needs one drive more, so smallest RAID5 consist from 3 HDD.
2 drives RAID5 = HDD0+HDD1+HDD2

One drive more is for "parity information". This allow in case of any single drive fail to reconstruct content of array. Parity info is distributed between all HDD.

Computation of parity information is key idea of relative poor write speed of RAID5.
Worst scenario - write only one cluster of data needs:
1. found cluster number where will be data written. For example cluster 500 of HDD1.
2. read clusters number 500 from all other DATA-drives in RAID array
3. computer XOR between this readed clusters and cluster prepared for write
4. data is written into cluster 500 of HDD1
4. parity info is written into cluster 500 of parity HDD

To help with parity computations, good RAID5 controllers contains 64-256 MB of cache (with battery to prevent data loss in power failure) in write back mode. This allow catch reasonable big "burst write" and gives system time to read needed clusters for parity computation.

Cache for RAID5 absolutely necessary. Without it, computation of parity info totally destroys write performance.
My System SpecsSystem Spec
Reply

 PCI-E Sata II RAID 0 slow....driver issues?




Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 07:52 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33