Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: USB performing EXTREMELY slow


30 Jun 2009   #1

Windows 7, duh
 
 
USB performing EXTREMELY slow

Since installing Windows 7 all of my USB ports are ridiculously slow, USB 1.0 speeds at best.

I did not have this problem at all with XP, so it is not hardware related.

It is affecting a variety of devices, so no single one is to blame.

I guess on the plus side, my iPhone can almost get a full charge in the ~hour it takes to sync.


My System SpecsSystem Spec
.

10 Jul 2009   #2

Windows 7, duh
 
 

Nobody? This is my only problem with Windows 7 and it just may be enough of one for me to switch back.
My System SpecsSystem Spec
10 Jul 2009   #3

Windows 7 Build 7201
 
 

I think that usb actually freezes my PC occacsionally. I use a USB sound blaster external 24bit and usb keyboard-mouse. I can be watching a movie the sound stops and then moments later complete freeze. I using build 7201 I havent bothered with any newer ones just waiting for RTM hopefully they have fixed it
My System SpecsSystem Spec
.


10 Jul 2009   #4

Windows 7 Home Premium x64 - Mac OS X 10.6.4 x64
 
 

Quote   Quote: Originally Posted by iDekz View Post
Nobody? This is my only problem with Windows 7 and it just may be enough of one for me to switch back.
Looks like you need the chipset drivers for your board
My System SpecsSystem Spec
10 Jul 2009   #5
OEM

OS3.5
 
 

Your system specs are a bit slim.

"OS- Windows 7, duh"

...doesn't help us know which version of Seven you have installed. There are many people using "leaked" versions, not everybody is using 7100rc.

Please fill out your system specs completely.

I believe Zidane2424 is on the right track. Check with your pc/motherboard manufacture for chipset drivers. Vista should work if you can't find Windows 7 specific ones.
My System SpecsSystem Spec
10 Jul 2009   #6

Windows 7, duh
 
 

Quote   Quote: Originally Posted by OEM View Post
Your system specs are a bit slim.

"OS- Windows 7, duh"

...doesn't help us know which version of Seven you have installed. There are many people using "leaked" versions, not everybody is using 7100rc.

Please fill out your system specs completely.

I believe Zidane2424 is on the right track. Check with your pc/motherboard manufacture for chipset drivers. Vista should work if you can't find Windows 7 specific ones.
OS: Windows 7 7100rc
MB: Asrock K8 Upgrade-1689
CPU: Athalon 64 3000+

I have the CD that came with the motherboard but everything I try to install from it fails with some sort of "does not work with this version of windows" error.
My System SpecsSystem Spec
10 Jul 2009   #7

XPSP3, Se7en RTM
 
 

Quote   Quote: Originally Posted by iDekz View Post
Since installing Windows 7 all of my USB ports are ridiculously slow, USB 1.0 speeds at best.

I did not have this problem at all with XP, so it is not hardware related.

It is affecting a variety of devices, so no single one is to blame.

I guess on the plus side, my iPhone can almost get a full charge in the ~hour it takes to sync.
I've been having USB problems since the first day I installed Vista and these issues have persisted in Windows 7 as well. Getting USB devices to work (properly) on Vista/Windows 7 has been a gamble for me. Sometimes it works, sometimes it doesn't. In Windows XP on the other hand, USB works perfectly fine.

I don't know what the problem is, but it's probably driver related. Since I'm running an old nForce2 motherboard, obtaining Vista/Windows 7 compatible chipset drivers is out of the question; the board is simply too old. Like it or not, I'm just going to have to live with it I guess.

Quote   Quote: Originally Posted by themouse View Post
I think that usb actually freezes my PC occacsionally. I use a USB sound blaster external 24bit and usb keyboard-mouse. I can be watching a movie the sound stops and then moments later complete freeze. I using build 7201 I havent bothered with any newer ones just waiting for RTM hopefully they have fixed it
I wouldn't count on it.
My System SpecsSystem Spec
10 Jul 2009   #8
OEM

OS3.5
 
 

Quote   Quote: Originally Posted by iDekz View Post
OS: Windows 7 7100rc
MB: Asrock K8 Upgrade-1689
CPU: Athalon 64 3000+

I have the CD that came with the motherboard but everything I try to install from it fails with some sort of "does not work with this version of windows" error.
Go to Asrock Downloads

Enter or Find Your Motherboard and there should be a download for the chipset driver.

Not sure, but it may be called "AMD all in 1 driver" as I looked at couple of download pages, but didn't see any that showed "chipset".
Check the site for more info on downloading chipset drivers and whether its a part of the "AMD all in 1" drivers download if your motherboard download page doesn't have a driver called "chipset".
My System SpecsSystem Spec
10 Jul 2009   #9

Windows 7 Ultimate, Ubuntu
 
 

Quote   Quote: Originally Posted by iDekz View Post
OS: Windows 7 7100rc
MB: Asrock K8 Upgrade-1689
CPU: Athalon 64 3000+
I'm running a very similar Athlon setup with 32 bit RC 7100. This won't help you other than to say your problem is probably solvable because my USBs are all consistently excellent, I have an external harddrive on USB with excellent transfers, better (I think) than on XP, and a variety of Flash Drives all just fine.
My System SpecsSystem Spec
10 Jul 2009   #10

Win 8 Release candidate 8400
 
 
usb prob

Quote   Quote: Originally Posted by iDekz View Post
OS: Windows 7 7100rc
MB: Asrock K8 Upgrade-1689
CPU: Athalon 64 3000+

I have the CD that came with the motherboard but everything I try to install from it fails with some sort of "does not work with this version of windows" error.
could you go into device manager and see if the usb are listed correctly or listed as unknown

Ken
My System SpecsSystem Spec
Reply

 USB performing EXTREMELY slow




Thread Tools



Similar help and support threads for2: USB performing EXTREMELY slow
Thread Forum
Solved D-Link DWA 160 extremely slow Network & Sharing
Internet is now extremely slow. Network & Sharing
Extremely slow windows 7 Performance & Maintenance
Internet Being *EXTREMELY* Slow Network & Sharing
extremely slow shutdown Performance & Maintenance
Firefox: Slow Performing Add-ons Browsers & Mail
Extremely slow dialup Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 09:01 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33