Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Troubleshooting system slow down

22 Mar 2011   #11


As I mentioned my advice is based on repeat experience here where uninstalling MucAfee solves performance problems.

I stopped reading the rankings for AV's because they seem to be stacked based on who's doing them, and have little real-world awareness of best practices for Win7 performance which is what we deal with here every day.

That said, I am almost always behind a hardware firewall so take it all in stride.

My System SpecsSystem Spec

 Troubleshooting system slow down

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar help and support threads
Thread Forum
Troubleshooting with System Update readiness Tool
Troubleshooting with System Update Readiness Tool Symptoms Sometimes while using Readiness Tool,the tool stuck or it return following errors -Readiness Tool is already installed -error 0x8024800C and other errors
Network slow to initialize on startup, slow system
Specs: Win7 64bit, 4GB ram. For the past little while now, whenever I would turn on my computer, things would start up but it would hang, in the sense that nothing *would* start up until the network was found and connected to. The network indicator icon in the taskbar would just have a frozen...
Network & Sharing
System Restore General Troubleshooting to Fix Issues
General Troubleshooting to Fix System Restore Issues If the System is not able to create System restore point try to Create the restore point manually. If you are unable to create a system restore point manually then you could try these steps 1. Make sure that System Restore is enabled 2....
Troubleshooting poor system performance
Hello, I don't know what i am doing wrong, or if my VGA is faulty, but i am getting below average results from most tests i perform. For instance, Oblivion (a 2008 game that ran fine in my GTX 295 with HD Mods) is struggling to run. Maybe struggling is an exaggeration, but its running at 30...
Hardware & Devices
Unknown icon in system tray - slow system - pic attached
Hi, I've been having some very slow system issues today and have checked that system resources seem to be at normal levels - CPU usage at around 20% and Memory usage at around 50% during normal operating. However I have noticed a new icon in my system tray which I can't identify, can't click...
Performance & Maintenance

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 08:07.

Twitter Facebook Google+

Windows 7 Forums

Seven Forums Android App Seven Forums IOS App