Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: SFC /scannow cannot repair catsrvut.dll

29 Apr 2011   #1

Windows 7 x64 Ultimate
 
 
SFC /scannow cannot repair catsrvut.dll

Howdy,

I have Win7x64Ulti -Dell OEM
I auto installed Sp1 in a moment of weakness (gave in to the pain of Windows 7).

I have problems with some programs around com+ and VSS, notably Casper, but others as well so I ran sfc /scannow.

Only one file shows up as a problem and Win says "cannot repair - source file corrupt". It is the windows\system32\catsvrut.dll, a com+ library.

Message follows:
Cannot repair member file [l:24{12}]"catsrvut.dll" of Microsoft-Windows-COM-ComPlus-Runtime-QFE-CATSRVUT-COMSVCS, Version = 6.1.7600.16385, pA = PROCESSOR_ARCHITECTURE_AMD64 (9), Culture neutral, VersionScope = 1 nonSxS, PublicKeyToken = {l:8 b:31bf3856ad364e35}, Type neutral, TypeName neutral, PublicKey neutral in the store, hash mismatch

The attempted source is the winsxs folder.
The 7600 would be pre SP1 if I read that right, so of course it cannot repair.

So - I check the last disk image I had of this disk and in fact that file size and dttm is the same in the indicated winsxs folder but different in system32. I get that system32 is a secure dir/file and I cannot just copy/paste. But how to fix this is stumping me.

Is the system32 bad, the winsxs bad, both? What's up.

Weird part - I'm having trouble finding the actual file because of how Windows 7 uses Winsxs to dynamically link these files to the OS depending upon 32 or 64 bit access. I'm guessing there is a junction or symbolic link involved, because in Win explorer the file is correct size and date, in DOS it is correct size and date but when I run superfinder it shows all files with this name and system32 has wrong size and date.

So it appears system32\catsrvut.dll has a problem, and it further appears that the source to repair is from a pre-SP1 image in this library.

Well -
I can't repair (OEM to SP1).
I can't seem to copy the dll from the backup image.

How do I get a valid copy of the dll? Or even tell if it is invalid?

My System SpecsSystem Spec
.

29 Apr 2011   #2

Windows Server 2008 R2
 
 

Most of the files in \system32 are just junctions to a particular file in WinSXS, but I believe that this one is not actually a WinSXS junction but a real file in both locations. If you can access your filesystem offline from a bootable CD, you could replace the one in \system32 with the one from the WinSXS location, and then reboot and run sfc again.
My System SpecsSystem Spec
29 Apr 2011   #3
Microsoft MVP

W 7 64-bit Ultimate
 
 

Hello virtualwatts, welcome to Seven Forums!



After you do as cluberti suggests, it may be helpful to run the sfc / scan using the method outlined in this tutorial at the link below, it runs from the Windows Recovery Environment (WinRE) which may be better as Windows won't be 'running' during the scan and be sure to post back with any further questions you may have and to keep us informed.


SFC /SCANNOW : Run in Command Prompt at Boot
My System SpecsSystem Spec
.


29 Apr 2011   #4

Windows 7 x64 Ultimate
 
 

Okay - so I almost had it. We use junctions alot in our VMware environment so that has kept me sane going from XP to Windows 7 on my personal machines. Although, when I run junction from sysinternals there are no reparse points shown for the dll, but it does indeed act like one.

I will attempt the recommended boot and scan, but consider that my DVD is OEM and my OS is SP1. That's why I haven't yet tried that approach.
My System SpecsSystem Spec
29 Apr 2011   #5
Microsoft MVP

 

If you can get your hands on a Windows 7 installer with SP1 (not slipstreamed) you can run a Repair Install
which can fix the System files that SFC cannot.

Otherwise you can uninstall SP1 to run the Repair Install with your installer. uninstall Windows 7 Service Pack 1 (SP1)
My System SpecsSystem Spec
30 Apr 2011   #6

Windows 7 x64 Ultimate
 
 

Thanks for the helpful replies.

sfc from recovery doesn't help because both the target and the source file are corrupted. Whether from recovery partition or from DVD.

Repair wouldn't work because it kept saying "repair in progress waiting for reboot". The cbs.log indicates there are file renames and moves from a repair pending but not occurring.

I have the installation media because we buy that with all of our Dell hardware. But it is OEM.

The fix was in the mix here on 7forums. Thank all of you for the helpful links that eventually lead to goodness on other pages.

- I first uninstalled SP1.
- I then extracted the DLLs (system32 & winsxs) from the installation media using the 7-zip tool and a link from this forum.
- And lastly downloaded the SP1 repair disk and created a bootable USB as a just in case - but didn't use it. Helpful links though....
- I then booted into the recovery partition and at the cmd prompt copied the extracted DLLs to the respective system32 and winsxs folders.
- Then ran sfc verify and all files checked out okay
- The pending file rename/moves went away
- Then reapplied SP1

As soon as the SP1 completes I'll re-verify.

This all started with back-to-back auto installs of SP1, .NET4 and IE9. I have now backed out all three and I'm fine. Fun.

Thanks.
My System SpecsSystem Spec
30 Apr 2011   #7

Windows 7 x64 Ultimate
 
 

And.... we're back to square 1.

After performing the Windows 7 SP1 update sfc now shows the catsrvut.dll file in system32 and the source in winsxs as corrupt. And COM+ services have errors in certain VSS calls. And side-by-side (I didn't know what that was until this thread) are also reporting events/errors.

So, I'll re-re-copy the DLL from the installation DVD extract file and call it a day.

I reallllly miss my WinXP stable no BSOD runs for weeks at a time rock solid wimpy 1x2 system right now...
My System SpecsSystem Spec
30 Apr 2011   #8
Microsoft MVP

 

Have you clean reinstalled from your installation DVD yet? This sounds like the kind of corruption that often plagues factory OEM preinstalls or in-place Upgrades.

Backup your files and a Windows 7 Backup Image first: Backup Complete Computer - Create an Image Backup

Reinstalling Windows 7
My System SpecsSystem Spec
Reply

 SFC /scannow cannot repair catsrvut.dll




Thread Tools



Similar help and support threads for2: SFC /scannow cannot repair catsrvut.dll
Thread Forum
sfc /scannow cannot repair explorer.exe Performance & Maintenance
Solved SFC /scannow can't repair autochk.exe Performance & Maintenance
SFC scannow cannot repair autochk.exe Performance & Maintenance
Sfc/Scannow cannot repair corrupt .inf and .nlp files Performance & Maintenance
sfc scannow can't repair files Performance & Maintenance
SFC Scannow - 'Cannot repair member file' Performance & Maintenance
SFC scannow cannot repair problem.. Performance & Maintenance

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 12:40 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33