Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Windows dialog event sounds not triggered

25 May 2011   #1
Soemie

Windows 7 Professional 32bit
 
 
Windows dialog event sounds not triggered

Hello all,

I have been searching the internet of a while about my problem, but unfortunately I still did not find anything related to the issues I am having. The problem is quite a strange one, I tried finding the cause and a solution by myself but I just cannot find a possible cause at all.

This problem started showing up a few months ago, but since Windows can run fine with the problem it was not on my top priority list (and still is not). But it is getting very fustrating not finding the cause and now I am very curious what is causing the problem.

This is the problem a am having: every time Windows triggers an dialog alert (like windows asterisk, windows critical error ect.) I don't hear the event sound related to it. I looked over and over the settings in the config screen: looking for currupted settings in my windows sound scheme or currupted media files in the windows media dir. But it seems that everything is simply okay, all the settings are correct and the files work well (I can hear the sound when I click test in the sound config screen). It just looks like it that the sounds do not get triggered by the event.

Does anybody know more about this problem? Maybe there is somebody else having this problem? Like a said, it is not a major problem but it is very strange. It just came out of the blue, everything worked fine and just the other day I did not hear dialog event sounds anymore.

Things I have tried:

- sfc /scannow to fix possible currupted media files (although I did not think this was the problem, since all the files work just fine). No effect.
- reset the default sound scheme of windows of a few times, even tried some other sound shemes that come preinstalled with Windows 7. No effect.
- Tried to reinstall my sound drivers (no idea why I tried that because my sound works just fine). No effect.
- Made a new user account to see if the problem was account related. No effect.

In short: What is the possible cause/solution for windows events sounds not triggered/suppressed by the dialog event itself (all settings/soud files correct)?

Thanks for your ideas and help in advance,
Soemie.


My System SpecsSystem Spec
25 May 2011   #2
Dwarf

Windows 8.1 Pro RTM x64
 
 

Hi Soemie and welcome to Windows 7 Forums

See if you get the same issue if you create a new user account.
My System SpecsSystem Spec
25 May 2011   #3
Soemie

Windows 7 Professional 32bit
 
 

Thank you Dwarf, I have to admit that I have been on sevenforums for a while reading some very interesting posts but I decided to make an account today because of this problem.

Sorry I forgot to mention that in my topic, I will edit the first post. I tried that, but unfortunately still no changes. But still, even if a new account fixed the problem this would be weard. Because this should not be account related, since there is no option at all to let windows trigger sound events except the default windows sound settings (or not that I am aware of)?
My System SpecsSystem Spec
30 Jun 2011   #4
terrabear

Windows 7 64 bit
 
 
Same problem!

Hi,
I'm having the same issue. I know how to change the sound scheme, and I have a bunch of .wav files I'm using to make a Star Trek themed sound scheme. I've done this before on my old XP. Even though the .wav files work fine, when I test them after changing the setting, they don't play. The events don't trigger the sounds...even the Windows default sounds. Oddly, sometimes the new Star Trek asterisk sound I chose will work when tested, but sometimes not. Same for the default sounds. Closing the window and re-opening it after each change doesn't do anything.
My System SpecsSystem Spec
01 Jul 2011   #5
Miranova23

Windows 7 Pro x64 SP1
 
 

Try following option 2 of this tutorial, where the sounds are altered manually from the registry, and see if you still can't get it to work properly: Sounds - Change

Does this happen, or rather not happen, for every sound, only sounds you change, or only some of the sounds you change???
My System SpecsSystem Spec
01 Jul 2011   #6
terrabear

Windows 7 64 bit
 
 

Quote   Quote: Originally Posted by Miranova23 View Post
Try following option 2 of this tutorial, where the sounds are altered manually from the registry, and see if you still can't get it to work properly: Sounds - Change

Does this happen, or rather not happen, for every sound, only sounds you change, or only some of the sounds you change???
It happens sort of randomly; the defaults tend not to work either. Basically, when I first open the window and click on a default, it will play once, then none of them play after that. Closing again then opening doesn't seem to consistently help. I will try what the tutorial says. Thanks!
My System SpecsSystem Spec
29 Mar 2012   #7
Wizdos

Windows 7 home 32bit
 
 
Sound Profile linked to mmres.dll

As I am also a start trek fan I looked into this extensively. It sounds (pardon the unintentional punn) like your registry file that deals with the sound profile itself has been changed, not corrupt, but another possibility. I will give you an example of what I have found....

Under HCU (HKEY_CURRENT USER) - AppEvents - EventLabels are the names of the "triggers" per say. Some of the keys have this value to them: @mmres.dll,-5839. This particular value is found under the Open key. mmres.dll I found is a audio resource for windows. For the longest time I could not figure out what the 4 digit number was after that. What that is is an Identifier....I believe. I changed that number with another key, (RestoreDown) and placed the one from RestoreDown into Open. When I actived the sounds they were different, meaning the sound I intended for the Open trigger, played the sound that was under RestoreDown. I am current looking for a list of triggers that are associated with window events. I will let you know if I find one.
My System SpecsSystem Spec
Reply

 Windows dialog event sounds not triggered




Thread Tools





Similar help and support threads
Thread Forum
Windows Event Sounds Do Not Play
Some of my Windows sound scheme sounds do not play. In the sound scheme settings, under Program Events ,regardless of sound scheme selected, the Sound events for Windows DO NOT play, but sound events for Windows Explorer, and every single other application, DO play. When I click Test, the sound...
Sound & Audio
Event triggered task
I'm trying to evoke a certain script once an event occurs, using the Scheduled Tasks in W7 x64 with event triggering. The script copies a certain file from the USB stick to the HDD. To be precise, the script should run upon specific USB stick is plugged in. So far i only see the...
Hardware & Devices
No Windows Sounds, but regular sounds play fine
Ok so I have a simple, but annoying problem. I have no Windows Sound Events like the login sound, the logout sound, and when the battery is low. Every other sound like playing music and running YouTube videos work fine. Even when I turn on my laptop I hear the whole computer startup sound, but I...
Sound & Audio
'Always on top' somehow triggered by ALT key
Hi folks, This is one of those weird things that's actually followed me around since the Windows 2000 days! I suspect back then the culprit was TweakUI, but since there isn't such a program for Win7 I don't know how it's returned once again. Basically, if I tap the ALT key on a focused window...
General Discussion
What Event Sounds Would You Like?
I’ve been thinking of making some sound files for customizing the audio events in Windows 7. Right now, I’m just in the planning stages. I need to formulate the number to make - or, better yet, to which events to associate. Next, what is the preferred length - 1 second or less, longer? ...
Customization
Something triggered as infected?
So I was doing a virus scan with Malwarebytes... Only one thing came up, and this is what it showed: What is that? Is that a custom Windows 7 configuration? Because it's obviously flagged as a virus and I haven't known Malwarebytes to have lots of false positives. I just want to be...
Performance & Maintenance

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 02:24.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App