Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: System performance issues

12 Aug 2011   #1

windows 7 home premium 64 bit
System performance issues


i am currently suffering from major performance issues where my pc will begin to steadily increase the amount of RAM it is using i procede to kill off any ussless proceses that i have running but still no change in the usage. I have run anti virus software multiple times and found nothing.

using the task manager and resource monitor i can see that the main item using up the RAM is svchost.exe which i have multiple processes of running at once 12 plus at the moment all with different RAM usages and all stop my pc working if i kill them off.

Along with this increased memory issue the operating system will cease to respond where nothing becomes interactable with but i can still move the mouse and gain accsses to the menu options from ctrl + alt+delete where logging off or restarting or a hard disk restart will fix the issue temporarly .

The only thing i have doen recently is updated windows items such as .net framework updates via the update manager.

Can someone please give me a rough idea of how to solve these problems.

System specs

Windows 7 Home premium 64 bit

1GB ATI Radeon HD 5850
AMD Phenom ll x6 Black edition
ASUS PCE-N13 Wirless adapter

Please ask for any more information if required.

My System SpecsSystem Spec

12 Aug 2011   #2

Win 7 Ultimate 64-bit. SP1.

Troubleshooting.... Note this is a generic post... if you have done any steps below just move on.

*Type event viewer, in search (by start button)
> Windows Application & System.
Look for red critical errors that may relate to the problem.

* Make sure that you are not over heating.

* Make sure PSU is working properly

* If overclocking, restore to original

* Try in safe mode; report back if it works properly.

Start your computer in safe mode

*Clean boot. You may discover what is causing your problem.

How to troubleshoot a problem by performing a clean boot in Windows Vista or in Windows 7

* You may be interested in these hardware tests:

CPU - Stress Test with Prime95 -

Video Card - Stress Test with Furmark -

Mem test 86+

RAM - Test with Memtest86+ -
My System SpecsSystem Spec
12 Aug 2011   #3

Microsoft Community Contributor Award Recipient

Windows 7 Ult x64 - SP1/ Windows 8 Pro x64

In addition to JMH's excellent suggestions, getting the basic health of your system is the priority, there is a known issue with AMD integrated memory controllers running with a RAM frequency above 1333MHz.



This affects all motherboards, it is due to the AMD CPU integrated memory controller.

In reference to JMH's above points.
Use Core Temp to test the '* Make sure that you are not over heating', check the CPU temps when at idle, under load and/or testing.

After you run memtest86+ and post the results, D/L CPUZ and post a snip of the CPU, Mainboard, Memory, and SPD tabs.
For posting the information , enter 'Snipping tool' in the Start button > Search box, hit enter. Select the area you want to post and save to a convenient place. Post a snip of the tabs, it is much easier for everyone to see the information.
How to Post a Screenshot in Seven Forums
My System SpecsSystem Spec

13 Aug 2011   #4

windows 7 home premium 64 bit

Thank you for your time and the suggestions but the problems have stopped i will keap this information in mind if the problems ever come back.
My System SpecsSystem Spec
13 Aug 2011   #5

Win 7 Ultimate 64-bit. SP1.

You are welcome & thanks for responding.
Safe surfing....
My System SpecsSystem Spec
14 Aug 2011   #6

Microsoft Community Contributor Award Recipient

Windows 7 Ult x64 - SP1/ Windows 8 Pro x64

Glad to hear it's running better.

Thanks for letting us know the status.
My System SpecsSystem Spec

 System performance issues

Thread Tools

Similar help and support threads
Thread Forum
Multiple performance issues
System Specs: Dell Dimension 435T i7 CPU, 920@2.67GHz 12GB RAM 1TB Hard drive Windows 7 Home Premium, 64bit BitDefender Security Package/ Installed software: Office 2010; Photoshop 6; Lightroom 5; I am experiencing multiple issues with my system. I have tried to note what actions I've...
General Discussion
DVD Burning and System Performance Issues
I do a lot of DVD burning and hence would prefer the performance of my system to be better when burning DVDs. I have noticed that when burning DVDs (in particular) that my system becomes less responsive. This appears to be the case regardless of the software I have tried which means there could...
Performance & Maintenance
Recent Performance Issues
Recently I have been having performance issues and I am getting a little stuck to what the problem could be. I have Windows 7 x64 on a dell inspiron 9400. Some time after using the laptop I start getting performance issues. The time can vary. The CPU starts going running at 40-100% despite...
Performance & Maintenance
Performance Issues with Oblivion.
So I bought the Deluxe edition on steam about two weeks ago and I've been getting abysmal fps drops. It' start at at around 100 and drop almost immediately to the 10-20 range, and it usually stay there. If tried with mods, without mods, uninstalling and reinstalling and still the issue remains. I...
Wit's End over performance issues
Ok, so I'm going to go insane over this computer. I have a year old Asus laptop that about a week or two ago started experiencing slowdowns while gaming. At first I thought it was a internet related issue, as I was on wireless and I was seeing pings of 300ish (I had these pings for a while, no...
performance issues going from x86 to x64
I have an HTPC that I use for watching Netflix and hulu and photo editing. I have been using windows 7 Pro x86 for about 3 weeks flawlessly. I have done a clean install to Pro x64 and now my video quality in Netflix has become almost unwatchable. I just did internet speed test with -...
Music, Pictures & Video

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 06:55.

Twitter Facebook Google+

Windows 7 Forums

Seven Forums Android App Seven Forums IOS App