Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Windows 7 not hibernating sometimes (hanging at black screen)


17 Sep 2011   #1

Windows 7 Home Premium 32-bit
 
 
Windows 7 not hibernating sometimes (hanging at black screen)

Hi,

For the last month or so, my home-built Windows 7 (Home Premium) PC doesn't always hibernate properly - it just hangs at the black screen and I have to hold in the power button for at least 4 seconds to 'power off' the PC.

I have no idea why this has started to happen and sometimes it works fine. Sometimes when I boot back up I get the message that Windows has recovered from an unexpected shutdown and will notify me if a solution is available, but no other details are provided.

I've checked the Windows system logs and can see no indication of what is causing the issue when shutting down. Obviously with the screen going black I cannot see any error messages either!

Can someone please help me troubleshoot and fix this annoying problem?

Spec:

Windows 7 Home Premium 32-bit
AMD Phenom II X4 955 Black 3.2GHz
Asus M4A88TD-M EVO/USB3 Motherboard
GEIL 4GB DDR3 Black Dragon Memory
ATI Radeon HD 4250

Thanks
Steven

My System SpecsSystem Spec
.

17 Sep 2011   #2
Microsoft MVP

Windows 7 Ultimate X64 SP1
 
 

Hello Steven, have a look at Option One here: Hibernate - Enable or Disable maybe you have Hybrid Sleep enabled.

If you force a shut down with the power button that usually will generate that error.
My System SpecsSystem Spec
17 Sep 2011   #3

Windows 7 Home Premium 32-bit
 
 

Quote   Quote: Originally Posted by Britton30 View Post
Hello Steven, have a look at Option One here: Hibernate - Enable or Disable maybe you have Hybrid Sleep enabled.

If you force a shut down with the power button that usually will generate that error.
Thanks for the quick reply.

Hybrid Sleep is set to Off.

I have nevertheless tried disabling and re-enabling hibernate in case something has got corrupted somewhere(?).

I'll see how it goes!

Thanks again
Steven
My System SpecsSystem Spec
.


17 Sep 2011   #4
Microsoft MVP

Windows 7 Ultimate X64 SP1
 
 

You're welcome. If the issue persists you can try SFC /SCANNOW Command - System File Checker if you are OK it will say No Integrity Violations Found. If it reports corruption found it can't fix, run two more times and reboot after all runs. This just checks your Windows file system and will do nothing to your personal data.

Also in the tutorial you can disable Hibernation with the powercfg -h off command which will delete your hibernation file. To turn it back on type powercfg -h on, it will rebuild the file when you hibernate.
My System SpecsSystem Spec
26 Sep 2011   #5

Windows 7 Home Premium 32-bit
 
 

Sorry about the massive delay in replying!

I did try disabling and re-enabling hibernation, but that didn't help.

Once when I had to hold in the power button, I let go after say 2 seconds and noticed a BSOD, but obviously it didn't stay on screen so I couldn't read it.

Just checked the system logs now and there's a few event ID 41s in there, one of which I've just checked has a BugcheckCode 159 in it - that's 9F in hex I believe.

Does this suggest a non ACPI-compliant driver, or am I really wide of the mark?!!?

Cheers
Steven
My System SpecsSystem Spec
26 Sep 2011   #6

Windows 7 Home Premium 32-bit
 
 

Quote   Quote: Originally Posted by CiaraJansonFan View Post
Sorry about the massive delay in replying!

I did try disabling and re-enabling hibernation, but that didn't help.

Once when I had to hold in the power button, I let go after say 2 seconds and noticed a BSOD, but obviously it didn't stay on screen so I couldn't read it.

Just checked the system logs now and there's a few event ID 41s in there, one of which I've just checked has a BugcheckCode 159 in it - that's 9F in hex I believe.

Does this suggest a non ACPI-compliant driver, or am I really wide of the mark?!!?

Cheers
Steven

Sorry, just noticed this too!

The computer has rebooted from a bugcheck. The bugcheck was: 0x0000009f (0x00000003, 0x88f1e030, 0x82f61ae0, 0x96390690). A dump was saved in: C:\Windows\Minidump\091811-18673-01.dmp. Report Id: 091811-18673-01.
My System SpecsSystem Spec
26 Sep 2011   #7
Microsoft MVP

Windows 7 Ultimate X64 SP1
 
 

This seems to be a different issue with the BSOD. You should start a new thread in Crashes and Debugging. Here's how: http://www.sevenforums.com/crashes-d...tml#post836073
My System SpecsSystem Spec
Reply

 Windows 7 not hibernating sometimes (hanging at black screen)




Thread Tools



Similar help and support threads for2: Windows 7 not hibernating sometimes (hanging at black screen)
Thread Forum
Black screen no cursor, hanging after log in, system restore does not Performance & Maintenance
Solved Standby Hanging On Black Screen BSOD Help and Support
BSOD (black w/white cursor) when wakeup from Hibernating sometimes BSOD Help and Support
win 7 hanging with black screen, no tdx.sys load Drivers
Solved BSOD (well black) when Hibernating sometimes BSOD Help and Support
Scandisk - Black screen/Safe Mode hanging Installation & Setup
Black screen of hanging? General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 03:03 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33