Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Triple core CPU showing ONE in task manager

01 Aug 2009   #31

XP_Pro, W7_7201, W7RC.vhd, SciLinux5.3, Fedora12, Fedora9_2x, OpenSolaris_09-06

Quote   Quote: Originally Posted by nate42nd View Post

Must be a mobo or CPU.
Did you run a Linux OS and check:
Look at /proc/cpuinfo for full details about each logical processor core detected.
(Filed under Athlon x2, but should be valid for other AMDs)
How can I tell how many processor cores are being identified by my Linux OS?

What traces/signals on the mobo would be pertinent to this?
Seems core 'enable/coordinate' should be all internal.
Can't locate Phenom_x3 pinout...

My System SpecsSystem Spec
01 Aug 2009   #32

Windows 7 Professional x64

That's a good idea. With 2 OSs already saying the same thing I didn't think it would be worth it. I just got done replacing the PSU and removing the heatsink and applying new thermal paste and cleaning everything. Maybe I could grab my "Jaunty Jackrabbit" live CD and check what Ubuntu says. It would be a REAL mystery then....

I have hope because the BIOS says I have the correct cache. It's so stripped down though.....the BIOS does not even have "PC Health Status" There are almost no options.

I am feeling defeated.

Thanks very much for the idea. I had not thought of that.

I also made the mistake of e-mailing HP just to let them know the CPU had probably failed. I told them I was dual booting. LOL I guess that was the end of any warranty. I didn't have one anyway so I thought I'd see what they said.
Thank you for contacting HP Total Care.

Nate, Hp does not support dual booting operating system. We are not much expertise we are unable to provide any solutions. As you have installed dual booting operating system the software warranty gets void.

I am providing you the tech support number; please call at this number mentioned below:


This should resolve the issue. If you need further assistance, please reply to this message and we will be happy to assist you further.

For information on keeping your HP and Compaq products up and running, please visit our Web site



HP Total Care

Our advice is strictly limited to the question(s) asked and is based on the information provided to us. HP does not assume any responsibility or liability for the advice given and shall not be liable for any direct, indirect, special, incidental or consequential damages in connection with the use of this information. Always back up your data.
For more information, including technical information updates, please visit our Web site at
HP does not require you to send any financial data in your reply to this email. As a prudent reminder, do not insert credit card details or other financial information in any e-mail replies.
BTW - the CPU is also running 10C cooler after new paste and only one core running....
My System SpecsSystem Spec
14 Aug 2009   #33

Vista 32bit, [XP32 & vista64 dead]

Im using Vista Home Premium 32bit. After I install it, i realize it was sluggish assuming it was 32bit problem coz I test b4 vista 64bit it was a lot smoother.
Soon realize Vista only detect 1 core out of 3...darn...
I ask my friend and other forums, none have the solution til I read this article that link to 1 CPU detected in dual core system. -Solution - Vista Forums
I try an error out of the method, which i have tried before earlier with the "no. of processors" checked (nothing happen after reboot). After reboot, it was the happiest moment since 3days bother by the Phenom single core problem. Yahoo.... Total of 3 cores back to pumping in against workloads. That was hell a lot smoother than stucked in single core...

The method I used:

Start>Start Search>msconfig
Boot Tab
Advanced Button
The startup number of processors was set to 1 and could not be changed
Unchecked the number of processors checkbox
Check "Detect HAL box"

Click Apply and Reboot
After reboot the number of detected cores were 3...

After success, go back to msconfig>Boot Tab>Advanced Button, check the "No.Of Processors" to 3, uncheck the HAL, apply, OK, Reboot...

Cheers, have a try...At least it work for me...
My System SpecsSystem Spec

30 Sep 2009   #34

Windows 7 Professional x64

Okay, this is amazing. After 2 months I did exactly as described above. (thank you) IT WORKED IN VISTA and Windows 7 (from within Vista)

So, I am left with a dual boot machine with Windows 7 also. In Windows 7 the "detect HAL" option is not there. At this point I don't think I had a performance hit from this issue. I have used the machine for editing video and pics for two months. I would like to figure it out though and find out why this happened.

Anybody know how to do the exact same thing in Windows 7 without the "detect HAL'" box?

Edit: This seems to work from within Vista with the "detect HAL" box but after restart it's reverting back. I suspect for the same reason it happened in the first place. If you know what the problem is.....please let me know. I can get it to show 3 cores after 1st reboot next reboot it reverts back. Thanks for any help. This may give someone smart a clue.
My System SpecsSystem Spec
05 Oct 2009   #35

Vista 32bit, [XP32 & vista64 dead]


after 1st reboot did you detect all of the 3cores???

If yes, go to MSCONFIG, under Boot>Advance Option> check "numbers of processors" box, select 3, uncheck the "DETECT HAL", apply> OK > Reboot ur PC, see will this make it permanent for ur system to detect all the 3 sweets cores.

Continue trying...

Attached Images
Triple core CPU showing ONE in task manager-phenomx3.jpg 
My System SpecsSystem Spec
05 Oct 2009   #36

Windows 7 Professional x64

I did discover that if I leave the #of cores at 3 after reboot, it will stay. I have not booted into Windows 7 yet to find out there but.......theres still a problem. You should not need to have the # of cores set to all. I have 8 (4 real and 4 virtual) on this CPU and that setting is one on this machine. (i7860)

I don't really care since it's my 3rd best system now but I would still like to know WHY this happened and how to really fix it. I believe it's hardware related. I think the CPU itself is flawed. I would love to hear an argument to the contrary.

Thanks for the help man. It is working fine it seems.
My System SpecsSystem Spec
06 Oct 2009   #37

Vista 32bit, [XP32 & vista64 dead]

yeah...duno y...maybe vista32 is detecting the cores in pair, never thought AMD would have triple cores...hahaha...

But there is once i try installing vista64, it ran fine, all 3 cores without any problem...
My System SpecsSystem Spec

 Triple core CPU showing ONE in task manager

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar help and support threads
Thread Forum
Task manager showing 20-30% cpu usage...
Hi there, .. I dont know why my task manager is show that my cou usage is that high.. Even tough I have nothing runnung, .. I check the processes and I don't see anything running there, . and the System Idle process is in 93% (for example) while the task manager is showing CPU usage: 30%... ...
Performance & Maintenance
Task Manager not showing applications
I have a Lenovo ThinkCentre running Window 7 Professional. If I bring up the Task Manager, no applications show in the window, no matter how many I have open. Processes, Services, etc. all look fine, just no apps. Of course this makes it impossible to kill a 'not responding' app. This is not...
General Discussion
Core temp showing CPU at 30 - 50% but Task Manager Shows 8%
I a couple of odd behaviors from my core i5 750 on ASUS P7P55D Pro. Core 2 is often running about 10 - 20% higher than all the others according to Core Temp even at idle. According to Windows Task Manager the CPU is only running at minimal % and no programs are showing as dominate (all under 1%...
Performance & Maintenance
Task Manager is showing weird.!
so whenever i open my task manager its open in some differently.i have running eset smart 5 antivirus.i have scanned my pc but no virus is snapshot
General Discussion
task manager is showing only one core vs two
I really hope someone has a good idea what is going on with my SSD partition of W7 Professional X64 using a Core2Duo processor. I think I may have confused HAL with my old HDD that I currently have in my DVD/CD bay via an Ultrabay Adapter on my laptop. I had the platter drive with W7 installed...
Hardware & Devices
Task Manager showing just 1 Processor
I have upgraded to Intel core 2 Duo processer ans my task manager is displaying only one processer. i have attached some pics for reference . if anybody can help it would be really appreciated. Thanks in advance
Performance & Maintenance

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 05:48.

Twitter Facebook Google+

Windows 7 Forums

Seven Forums Android App Seven Forums IOS App