Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Using AHCI, but no systray icon for ejecting devices


21 Nov 2011   #1

Windows 7 Professional SP1 32-bit
 
 
Using AHCI, but no systray icon for ejecting devices

I'm running Windows on an SSD running in AHCI mode.
Today I happened to notice that I no longer have the systray icon that lets you eject drives before disconnecting them (usually for USB sticks and the like).

Then I remembered that a few days ago, I actually installed the latest Intel iastor driver to replace the default msahci driver.
Now I'm not sure if that's when the systray icon first vanished or if it's an unrelated issue.

I have no interest in getting the icon back (it serves no purpose anyway), just wondering if iastor ignores the SATA controller's hotplugging capability and doesn't report such to Windows, therefore explaining the absence of that icon.

Does anyone know?

My System SpecsSystem Spec
.

21 Nov 2011   #2

Windows7 Pro 64bit SP-1; Windows XP Pro 32bit
 
 

Same on mine. Msahci had hot plug/eject for all internal drives. Not a good idea to me.

iastor with my Intel 320 will still hot plug to do a secure erase but the option to eject is gone on all the internal hard drives even spinners.

Of course "Devices and Printers" is still available for flash drives and external drives.

Mike
My System SpecsSystem Spec
21 Nov 2011   #3
Microsoft MVP

64-bit Windows 8.1 Enterprise
 
 

Hello Corazon,

I'm using the lastest version of the Intel iastor/chipset driver as well, but I'm still getting the Safely Remove Hardware notification icon in the system tray when I plug in say a USB flash drive.

You might check to see if you may have the icon set to be hidden, or reset the notification area icons to see if that may have it return when you plug in such a device afterwards.

If that doesn't help, and you decide that you would like to have the Safely Remove Hardware icon later, then these could help until you get this sorted.

Safely Remove Hardware Shortcut - Create

Safely Remove Hardware - Add to Desktop Context Menu

Hope this helps,
Shawn
My System SpecsSystem Spec
.


21 Nov 2011   #4

Windows 7 Professional SP1 32-bit
 
 

Perfect, thanks Mike! That's what I wanted to know.

Marked as solved.

Brink, just saw your reply - I have all notifications on, and yes I do get the eject icon when I plug in my USB stick or external HD. So no problem at all there - I was just curious whether iastor was preventing it from showing up for the internal drives. Which is definitely a plus, as Hopalong X said.

Thanks for your reply too
My System SpecsSystem Spec
Reply

 Using AHCI, but no systray icon for ejecting devices




Thread Tools



Similar help and support threads for2: Using AHCI, but no systray icon for ejecting devices
Thread Forum
How to disable Systray icon "Safely remove hardware and eject media"? General Discussion
Solved Please Identify Icon in Systray General Discussion
Power/Battery ICON Disabled in Systray General Discussion
Sound Icon in Systray will not open Sound Dialog Sound & Audio
Internet connection icon missing from systray General Discussion
Systray icon justification? General Discussion
systray icon issues General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 01:29 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33