Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: svchost problem

23 Nov 2011   #1
Yoko

Windows 7 Home Premium 64bit
 
 
svchost problem

Hello
I'v been recently having some issues with svchost taking alot of ram instantly when starting windows it takes over 100mb of ram and maybe sometimes it might go up to 140mb
is this normal?
I'v used svchost viewer to see what services it's running but all of them me seem important windows system tasks that I shouldnt remove.
Svchost also has caused my ram overall usage suddenly to spike up to 95% only when firefox has been running usually while a youtube video is running, especially if in multiple tabs.
restarting svchost usually fixes this but it takes a while to restart it loggin out and back usually is faster.
Also could this high ram usage be related to random freeze issues in certain games?


My System SpecsSystem Spec
.

23 Nov 2011   #2
logicearth

Windows 10 Pro (x64)
 
 

...Stop just stop...140 MB is nothing. NOTHING!
My System SpecsSystem Spec
23 Nov 2011   #3
whs
Microsoft MVP

Vista, Windows7, Mint Mate, Zorin, Windows 8
 
 

There is no problem. That is peanuts.
My System SpecsSystem Spec
.


Reply

 svchost problem




Thread Tools





Similar help and support threads
Thread Forum
svchost.exe(netsvcs) problem cpu load high
Hello, I have a problem. In the task manager -> system resources, I see that a process called svchost.exe(netsvcs) (if I'm correct) is using about 50% of cpu. The cpu is AMD dual core 2.81GHz. This doesn't always happen. Right now, it uses 48 %. Should I be concerned? Is it a legitimate process...
Performance & Maintenance
svchost.exe problem - not running any services
I am running 32-bit Windows 7 Professional on my laptop and everything was going smoothly up until yesterday when suddenly, the fan started to ramp up and continue blowing at startup (usually, when I press the power button, the fan will start, but then it'll die down by the time the OS boots up). ...
General Discussion
svchost.exe high cpu load problem
Hello everyone! Since this is my first post I wish you all the best and thanks for your help. I really appreciate it. My problem is the following: Since 2 days my cpu load is always at maximum load. I searched the web and found out that many people have the same problem. The funny thing...
Performance & Maintenance
svchost.exe CPU Problem
Hello; My CPU is almost always at 100% usage, and so my computer starts to run real slow. I have used procexp.exe to find out what it was being used by, and I found this svchost taking up the most (below is a picture). If more information is needed, just ask. Thanks for the help!
Performance & Maintenance
svchost.exe high CPU - sigmatel problem or other?
Hello, as this is my first post, I'll try to explain my problem as good as possible. At the moment the official windows 7 build 7100 evaluation copy is running on my system (dell inspiron 6400, dual core 1,83 GHz, 2gb RAM, intel 945 chipset). It's installed since april 2009 and didn't give me...
Performance & Maintenance

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 07:46.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App