Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: sfc /scannow problems

13 Feb 2012   #1

MS Windows 7 64-bit
 
 
sfc /scannow problems

Ok. I've read the posts, googled the internet, tried just about every tweak out there and I'm at a loss. I'm about to reinstall Windows 7 as I'm sure this will fix the problem but I thought I'd come here as a last resort. I'm running Windows 7 ultimate 64bit and I began noticing some odd behavior when trying to open a couple of programs (specifically Quickbooks 2010.) When attempting to open it would say I must turn on certain windows features in order for it to work (specifically IE.) Funny, never exhibited this behavior before, but OK, I went in to control panel/programs/windows features and it came back blank. That's where this odyssey started. Various blogs/posts etc. pointed me to run sfc /scannow which I have attempted in it's many iterations (command prompt/WIN recovery mode/OFFBOOT DIR, blah, blah, blah.) When attempting I'm always presented with the Windows Resources Protection error or the "a system repair is in progress, please restart error." I've followed all the advise these two problems point you to and still no help (I don't have a pending.xml file to rename!) I've even attempted to do an in-place upgrade and I'm presented with the "Windows needs to be restarted so necessary changes to system files can be made before continuing" error and when restarted, same thing. So here I am, about to do a complete re-install unless someone can come up with a better idea. Before I step into the abyss, thanks in advance.

My System SpecsSystem Spec
.

14 Feb 2012   #2

Windows 7 Pro with SP1 32bit
 
 

Did you run System File Checker with an elevated Command Prompt? Detailed instructions on how to run the System File Checker are at How to use the System File Checker tool to troubleshoot missing or corrupted system files on Windows Vista or on Windows 7
My System SpecsSystem Spec
14 Feb 2012   #3

MS Windows 7 64-bit
 
 

Did this already. Returns a Windows Resource Protection error. Have confirmed that Windows Modules Installer is set to manual also.
My System SpecsSystem Spec
.


14 Feb 2012   #4

Microsoft Community Contributor Award Recipient

Win 7 Pro 64-bit
 
 

Windows Resource Protection (WRP) prevents the replacement of essential system files, folders, and registry keys that are installed as part of the operating system. If SFC finds a damaged or corrupt system file, the WRP might prevent SFC from changing or replacing that file.

About Windows Resource Protection

You may have received a prompt to open a CBS.log and search for specific file errors. See this previous thread (especially post # 6) for additional info.

http://www.sevenforums.com/crashes-d...e-cbs-log.html
My System SpecsSystem Spec
14 Feb 2012   #5

MS Windows 7 64-bit
 
 

Sorry, but I thought the purpose of sfc was to check the integrity of system files and replace corrupted files with non-corrupted. What's the point of interrupting the scan at the outset. Sfc doesn't get to the point where it produces a CBS.log to inspect. The related link, About Windows Resource Protection, seems to point to applications that are attempting to make changes to OS system files. Sfc, as I understand it, is meant to correct corruptions, either accidental or otherwise, that may have occurred to OS system files. I would love to be able to run it and find out what is corrupted but can't get to the point where it will run, hence my post.
My System SpecsSystem Spec
14 Feb 2012   #6

Microsoft Community Contributor Award Recipient

Win 7 Pro 64-bit
 
 

I agree that SFC is supposed to do exactly what you said. This problem goes back to Vista when WRP replaced Windows File Protection (WFP). Unfortunately, I'm not an expert in anything so I don't have a definitive answer for you.

Error message "Windows Resource Protection could not perform the - Microsoft Answers

Windows 7 Ultimate 32 Bit: Windows Resource Protection could not perform the requested operation.

It seems that some folks who got a WRP error had bad sectors on the hard drive (run check disk) while others had to ultimately resort to a repair install.

Disk Check

Repair Install
My System SpecsSystem Spec
14 Feb 2012   #7

MS Windows 7 64-bit
 
 

Thanks for the reply. I've already done everything contained in the links you've posted. No errors are found during dskchk, sfc /scannow always returns an unable to start due to a Windows Resource Protection issue. When attempting a repair install, at the conclusion of copying windows files the installation stops and I'm prompted to shut down and restart due to a pending windows update, and yes I've checked, I have no pending.xml file in the winsxs folder. I've also run an AV scan, malware scan, etc. in both regular and safe mode, finding nothing. Like I've said, I'm at a loss as to where to go other than a clean reinstall.
My System SpecsSystem Spec
Reply

 sfc /scannow problems




Thread Tools



Similar help and support threads for2: sfc /scannow problems
Thread Forum
Does sfc /scannow really help? Performance & Maintenance
SFC /scannow Performance & Maintenance
problems starting up (sfc /scannow) BSOD Help and Support
SFC/SCANNOW found problems Performance & Maintenance
Solved sfc /scannow can't fix Performance & Maintenance
SFC /scannow problems BSOD Help and Support
SFC/scannow General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 07:14 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33