Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: System process eating up the CPU


30 Mar 2012   #1

Windows 7 Ultimate x64
 
 
System process eating up the CPU

My home computer is a 3yo machine running Windows 7 Ultimate x64. A couple days ago, the SYSTEM process started running at 100%.

After playing all the usual games (disabling services, updating drivers & antivirus, rolling back, safe-mode, etc etc), I finally said "screw this", reformatted and reinstalled.

But the problem persisted. Let me be clear: a week ago, the system was fine. Now, even after a clean install, with no updates or new drivers or anything, the problem is there.

So I tried Windows Server 2008 R2 x64, Windows 8 x64, Windows Vista Ultimate x64... even Knoppix linux. No other OS has any issues.

But under Windows 7, even on a completely clean and fresh install, the SYSTEM process is gobbling up 100% cpu time.

And it's just about to drive me insane.

At this point, I figure it has to be some driver interacting with hardware in an odd way. But which one?

Does anyone know how to drill down inside the SYSTEM process and see what's going on? (Without installing Visual Studio and bunch of debug files and all that.)

Thanks


My System SpecsSystem Spec
.

30 Mar 2012   #2
Microsoft MVP

Windows 7 Ultimate 32bit SP1
 
 

Try Process Explorer ... Process Explorer
My System SpecsSystem Spec
30 Mar 2012   #3

Windows 7 Ultimate x64
 
 

I tried Process Explorer, but unfortunately it doesn't let you drill down inside SYSTEM. It gives you the Interrupts thread and one other thing.. and that's it.
My System SpecsSystem Spec
.


31 Mar 2012   #4

Windows 7 Ultimate x64
 
 

I figured it out. Ended up having to install the Windows SDK and use xperf and Windows Performance Analyser to track down the offending driver....

... Apparently Windows 7 no longer likes my USB 2.0 controller. Disabling the "enhanced" controller idled my CPU back down to 0%.

Which is no big deal since I don't often use USB drives. It is certainly odd, though.
My System SpecsSystem Spec
Reply

 System process eating up the CPU




Thread Tools



Similar help and support threads for2: System process eating up the CPU
Thread Forum
Solved sppsvc.exe is eating lot of process Performance & Maintenance
nvscpaisvr.exe process eating ram Graphic Cards
Support dock process is eating up my resources, please help! Performance & Maintenance
connection by the system process and killed process Network & Sharing
System process always using 25% of processor Performance & Maintenance
java.exe process eating bandwidth General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 03:27 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33