Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: sfc: "Cannot verify component files for" ... "manifest is damaged"


03 Jun 2012   #1

Windows 7 Home Premium 64 bit
 
 
sfc: "Cannot verify component files for" ... "manifest is damaged"

Thanks to other helpful threads on these forums, I have worked through some maintenance that seems to have resolved the constant BSODs I was having, in large part via sfc /scannow.

I believe I only have one issue remaining as far as sfc is concerned:
Code:
Cannot verify component files for Microsoft-Windows-RPC-HTTP.Resources, Version = 6.1.7601.17514, pA = PROCESSOR_ARCHITECTURE_AMD64 (9), Culture = [l:10{5}]"en-US", VersionScope = 1 nonSxS, PublicKeyToken = {l:8 b:31bf3856ad364e35}, Type neutral, TypeName neutral, PublicKey neutral, manifest is damaged (TRUE)
If I understand what I've read in other posts correctly, sfc is telling me that it cannot verify "C:\Windows\winsxs\amd64_microsoft-windows-rpc-http.resources_31bf3856ad364e35_6.1.7601.17514_en-us_b143921936942d2a\rpchttp.dll.mui" because manifest is damaged.

I think this is the manifest: "C:\Windows\winsxs\Manifests\amd64_microsoft-windows-rpc-http.resources_31bf3856ad364e35_6.1.7601.17514_en-us_b143921936942d2a.manifest" and the file is zero length, so it makes sense that sfc cannot use it to verify the file.

In the interest of completeness, there really is a corresponding system file installed at "C:\Windows\SysWOW64\en-US\rpchttp.dll.mui".

It doesn't seem like doing a repair install is worth it for this one file - I'm not having BSODs anymore, but it would be nice if sfc could complete a clean run, so I have tried to pursue the approach of finding the original source file and manifest. Even though it appears to be a SP1 file based on the info, the first thing I checked was my install disc (by exploring the appropriate .wim file), but rpchttp.dll.mui doesn't seem to be present. Then I downloaded the .iso for Windows 7 SP1 and it does not include "rpchttp.dll.mui" (to check this I mounted the .iso, extracted the X64 content with -x on the exe, opened the cab in 7zip). Since I couldn't find it there, I searched on technet to try to find if "rpchttp.dll.mui" came via Windows Update, but I couldn't find this file listed in any of the "affected files" lists there, either.

So now I am wondering where it came from? Anyone have any ideas on how figure this out and get it resolved, short of doing a repair install? Thanks for reading!

My System SpecsSystem Spec
.

24 Sep 2012   #2

Windows 7 Ultimate x64
 
 

Were you able to fix your issue without a repair install?
My System SpecsSystem Spec
24 Sep 2012   #3

Windows 7 Pro. 64/SP-1
 
 

My System SpecsSystem Spec
.


Reply

 sfc: "Cannot verify component files for" ... "manifest is damaged"




Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 03:35 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33