Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Gets slow on battery power

22 Jun 2012   #1
shawns

Win 7 Home Premium 32bit
 
 
Gets slow on battery power

Ive got a packard bell sj51

The problem is :

When the laptop is plugged in (charging) it runs fine and processor load never increases above 82% while browsing webpages and everything works smoothly. However when i use it on battery power , even with the High Performance battery plan task manager shows 100% usage of processor while streaming youtube , loading forum threads etc. Even if i have a youtube video playing in the background while im browsing something else the sound starts to lag and the laptop gets really slow and non responsive.

I am not even sure if i have the correct drivers for my laptop but i can't find any drivers for Packard Bell SJ_51 , especially not for Windows 7 64-bit.


My System SpecsSystem Spec
.
30 Aug 2012   #2
SkorpioMilo

Windows 7 Ultimate x64
 
 

Hey man! I had this same issue on my HP laptop. I noticed that after plugging to the power again, everything would work fine again after few minutes. So I decided to check the advanced options of the power plans, and noticed that cooling policy was set to passive when using battery. That was overheating the processor, what makes it run really crappy. I just set the cooling to Active again and now i can work normally using battery. I hope it solves your problem.

Power Plan Settings - Change
My System SpecsSystem Spec
30 Aug 2012   #3
karlsnooks

MS Windows 7 Ultimate SP1 64-bit
 
 

Besides the excellent advice from Skorpio,

Control Panel | Power Options | Change Plan Settings |
Change Advanced Power Settings |
now look at this shot and make sure that you are set to 100%.

Name:  powr settings.PNG
Views: 6
Size:  28.4 KB

Be sure to click on any OK, Save buttons (which sometimes are at the very bottom-bless those young, wet-behind-the-ears programmers at Microsoft.


My System SpecsSystem Spec
.

Reply

 Gets slow on battery power




Thread Tools




Similar help and support threads
Thread Forum
Unable to boot from battery power
I'm suddenly experiencing this problem. I'm unable to boot my laptop from my battery. But if I connect the power chord, I'm able to start it. There is no problem with restart, hibernate and other options on battery though. I've also installed batterycare to check the battery condition. It shows no...
General Discussion
Broken AC power jack, no battery power, help
Hi. Im new on this forum, but I have a problem with my Inspiron 1545 laptop from Dell pre-loaded Windows 7 Home Premium 64-bit (although I did re-install several times with OEM OS restore disc). Money is tight for us now, so my AC power jack on the side of my laptop (or the end which connects to...
Hardware & Devices
BSOD while running on battery power
I would really like some help resolving my BSOD problem. I have experienced it several times now while running on battery but today it occurred while I was connected to power. I run blue screen viewer and it identified the broadcom driver as the main cause. Have tried reinstalling it twice now but...
BSOD Help and Support
Run Script on Battery/Critical Power
Hi all, In XP, we had the option of executing a script when the computer switched from AC to battery power, and also when the battery reached a critical level. This was extremely useful because I had a special script run to send an email that the power had gone out and then hibernate the...
Performance & Maintenance
Internet slows down on battery power.
hi there, my internet slows when i unplug my power chord? and regains speed as soon as i plug the chord again. it happens in all the browsers. thanks in advance. with best regards.
Hardware & Devices
What Is Wrong With My Power/Battery/Charger?
I said "Power/Battery/Charger" because I am not sure exactly which one of those is messed up. Heres the thing. A little before February 20th I began experiencing problems with my computer. I would have my computer plugged in to a socket at home, and the charger wasn't recognized. I also had an...
Hardware & Devices


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 17:37.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App