Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Windows 7 - Working fine and slowed down....

01 Jul 2012   #1
Ravindu

Windows 7 Ultimate x64
 
 
Windows 7 - Working fine and slowed down....

Hello,
I am experiencing some performance issues on my PC. First of all, here are the specs:
1. Operating system - Windows 7 Ultimate x64 bit.
2. RAM - 6.00 GB (2.00 + 4.00).
3. Graphics card - AMD ATI Radeon HD 5450.
4. Processor - Intel Dual Core (3.00 GHz).

So here's the problem:
Last week I installed the new 4.00 GB RAM to my PC to make it 6.00 GB. The computer was working fine and everything was all right. Yesterday however, I turned my PC on and inserted my pen drive and transferred a .midi file which I played on my Yamaha PSR-S910 to the computer. When I was doing this I noticed that my PC was usually slow.

Next I quickly scanned my computer with the antivirus (I have Trend Micro Titanium) and I downloaded IOBIT advanced system care and did a full fix.

Now, the computer is a very little bit faster but it gives a lot of problems. Please tell me how I can get my old PC speed back...

IOBIT Smart RAM says the CPU usage is 100%! This is very bad (I think).


My System SpecsSystem Spec
.

01 Jul 2012   #2
gregrocker

 

My System SpecsSystem Spec
02 Jul 2012   #3
MarkoIvanov

Windows 7 Ultimate x86
 
 

Ok well firstly I would try to remove that 2 GB on ram that you've put on your system. That may be slowing down the computer because as I see you don't have a high end CPU.
Second remove TrendMicro and install a real antivirus like Kaspersky or ESET and do a full scan.
Open up TaskManager and check what programs are running and check CPU usage.
If nothing works do a system restore to a previous saved point.
If problem still occurs then your hardware is to blame.
My System SpecsSystem Spec
.


Reply

 Windows 7 - Working fine and slowed down....




Thread Tools





Similar help and support threads
Thread Forum
Windows 7 stuck in reboot loop and hard drive working fine in other pc
Hello friends... I am new member here and this is my first post. I am a newbie in pc stuff but I am in bad condition that's why I need your help in any kind. .. it will be well appreciated... Here it goes One day my 2tb wd caviar green got corrupted (maybe) and on boot it states that hard disk...
Installation & Setup
Windows 7 unidentified Network Issue but internet is working fine.
Pls help me out with the following Windows 7 unidentified Network Issue but internet is working fine. Unable to create hotspot. What to do now ? IPv4 and IPv6 shows no internet connectivity C:\Users\HOME>ipconfig /all Windows IP Configuration
Network & Sharing
Cannot connect on Windows 7, Vista working fine
Hi guys I have had the same internet for several years now, and it has always been working fine on both my windows 7 PC and vista laptop. However, I now have a problem connecting on Windows 7, sometimes it says the pass phrase is incorrect (even though its not) and other times it just says there...
Network & Sharing
Computer working fine until Windows Update
I have a HP Pavillion a1640n with Windows 7 Home 32 bit edition installed. I went to use it and it was on, and it had installed updates (even when I specified for it not to, as I had a bad experience before). And it restarted. When it restarted it then was in a Start up recovery loop. When I...
General Discussion
Internet not working, windows update, ping, DNS, etc. working fine
Hello, I've got a Dell laptop here that isn't functioning properly. I can't get this to work for the life of me! I am currently using this laptop with a different hard drive, it's the install on the SSD that doesn't work. I know that the quick fix would be to simply reload windows, but I don't...
Network & Sharing
Image CD software doesn't work in Windows 7 was working fine in XP
i upgraded my os from xp to win 7 there some programs on my image files which are not running fine on Win 7 like counter strike condition zero please help
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 02:49.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App