Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Windows 7 x64 - Strange problem

27 Jul 2012   #1
ccouto

Windows 7 Enterprise x64
 
 
Windows 7 x64 - Strange problem

Hello everyone

I am having a very strange problem with Windows 7 x64.

I need to use a sort of mathematical software that was developed in Fortran and it is 32 bits. The program runs okay and gives good results. But after some time, the program works normally but instead of the previous results it starts to give me just 0 (zeros) even if i perform the same calculation than before.

The fortran program uses an input file for data and produces an output file for results.

1) If the program keeps running for a long period (for example 2 days in a row), everything works okay and results are okay.
2) The problem only appears after the program not being run for some period of time.
3) The only way to make the program work as before is a) by performing a System Restore to a previous state b) by applying Windows Updates and restarting. The problem mention in 2) still happens after 3) and the problem mention in 2) still happens after 1) also.

As an ending notes:
note1): just restarting the machine doesn't solve the problem
note2): This problem apparently doesn't happen if Windows 7 is running in Safe Mode.
note3): I have disabled all the services/startup programs to match those that are enabled in Safe Mode and the problem still happens.

I have been working with this same program for almost 2 years in Windows 7 x86 without any problem of this sort.

Any ideas? Many thanks.

Regards
Carlos Couto


My System SpecsSystem Spec
.

27 Jul 2012   #2
Golden
Microsoft MVP

Windows 7 Ult. x64
 
 

Welcome,

Have you tried to run the program in compatibility mode? I recommend trying Windows XP (Service Pack 3) mode.

Compatibility Mode

Regards,
Golden
My System SpecsSystem Spec
27 Jul 2012   #3
ccouto

Windows 7 Enterprise x64
 
 

Hello

Thank you. Yes i have tried that already and it didn't work. Also running in XP Mode is not an option due to performance issues.

Regards
Carlos
My System SpecsSystem Spec
.


27 Jul 2012   #4
Golden
Microsoft MVP

Windows 7 Ult. x64
 
 

Hi,

Based on that, I would say the issue is with the program running under x64, since it runs fine under x86, and not Windows. Is it possible to recompile it under x64?

Regards,
Golden
My System SpecsSystem Spec
27 Jul 2012   #5
oxymoron02

Windows 7 Ultimate 64-bit
 
 

I'd have to agree with the dancing penguin (that GIF is simply hypnotising...). It seems that although a vast amount of 32-bit executables can run under 64-bit operating systems without issue, this is not one of them. Is it an independently, or non-mainstream application? If so, and I'll sound incredibly negative saying this, you just may not have any luck getting it to run successfully under 7-64.

You might try running a 32-bit virtual machine but even this may not give you a guaranteed result.
My System SpecsSystem Spec
27 Jul 2012   #6
ccouto

Windows 7 Enterprise x64
 
 

Thank you both for your replies.

In fact I am able to run the software in windows 7 64 bits without "any" problem, but something is happening that is causing the program to stop working and I need to do a system restore in order to get it work again (or a windows udpate will solve the problem too).

However, I have noticed that the program stops working after a period where i am away from the computer (for exemple during the night, or during the lunch). I have tried deactivating antivirus but it didn't solve my problem.

At this moment, I have also disabled all the "energy saving" options like turning off the harddrive and i am hoping that this is the source of the problem. If it works, I guess there is a very strange explanation on this subject.

By the way, that dancing penguim is hilarious!

Regards
Carlos
My System SpecsSystem Spec
28 Jul 2012   #7
ccouto

Windows 7 Enterprise x64
 
 

It didn't work...
Still not able to solve the problem...

Regards
Carlos
My System SpecsSystem Spec
28 Jul 2012   #8
Golden
Microsoft MVP

Windows 7 Ult. x64
 
 

Hi,

I'd say the issue lies with the program, not the OS. What is the name of the software? Is it commercial?

Regards,
Golden
My System SpecsSystem Spec
Reply

 Windows 7 x64 - Strange problem




Thread Tools





Similar help and support threads
Thread Forum
Strange problem with explorer windows
Ok, so this one is kinda hard to describe (at that is why I'm including a screenshot)... My windows 7 machine at work keeps "losing" access to both local and virtual drives on my computer. Or rather, the explorer windows do. It works fine for a couple of hours, but then when I open a new window,...
General Discussion
Windows Seven strange start-up Problem
Hey Guys just a couple of days ago i started to encounter a problem with my machine. Its strange because it doesn't do it all the time, I will to elaborate a bit so that you guys can better understand my problem. Ok Here goes The Problem: Black Screen after Windows Splash start-up Screen ...
General Discussion
Strange 64bit Windows 7 problem
System Spec Windows 7 64bit Home Premium Toshiba Netbook T130 3GB RAM 150GB HDD Ok so i'll try and explain my problem the best way I can so please bear with me. I started to get a very odd problem that i was unable to launch Internet Explorer, i would just get the hour glass circle and it...
General Discussion
Strange overheating problem in windows 7
Hi! Recently after installing windows 7, my acer 5715z laptop has been randomly overheating. I've cleaned the heatsink and everything, but the problem seems to be driver- or settings related. Every now and then, the laptop fan stops spinning, causing the cpu temperature to rise until it...
Performance & Maintenance
installing windows 7 gives strange problem
Hello everybody. This Dutchy is going crazy. My problem is the following: I try to install windows 7 64bit on my pc. It starts installing fine, but when im at the finishing mode of installing(i think its the end). I get the following message. ( i didnt get to selecting area, time and filling out...
Installation & Setup
Strange Windows 7 Problem
This happened on another computer, so I thought it might've just been the computer itself, but now it's doing it on a brand new computer. What's the problem? Well, here's what happens. Whenever I turn my computer on, and it didn't do this for a long time, it just started doing it recently, I go...
Performance & Maintenance

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 23:30.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App