Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: "My Computer" slow load problem

10 Aug 2012   #1
verylunatic

 
 
"My Computer" slow load problem

When I try to access My Computer (start, win + e key, windows explorer sidebar, up one directory from C drive, etc) it will take a long time to open (around 1min). The explorer window will open up but will freeze before it displays the drives.

It doesn't happen all the time, but will definitely occur sooner or later (not fixed timing though, sometimes after 6hours, sometimes just 10mins after a fresh boot). Can get it to stop occurring after a fresh reboot but it will come back eventually.

Other folders works fine, only My Computer has this delay/freezing issue.

Have tried removing any mapped network drive.
CPU usage does not spike during the freeze.
Will freeze regardless of any removable storage/media devices being plugged in.

Only thing I noticed is that under Event Viewer > Windows Logs > System, Windows Error Reporting Service will start whenever My Computer freezes and will stop just before it unfreezes. There's no other error logs shown in Event Viewer during the timing whenever it freeze though.

Running Win7 Pro 64bit & Microsoft Security Essentials with no other A/V.

Thanks for any help in advance!


My System SpecsSystem Spec
.
10 Aug 2012   #2
DustSailor

Microsoft Windows 8.1 Pro 64-bit
 
 

Mate, welcome to Sevenforums!

What you might try first is scan with your updated antivirus program for any malware. Consider a full can with malwarebytes in addition: Malwarebytes Anti-Malware - CNET Download.com

You can look through these tutorials by Brink to see if you can make windows faster without any downloads, and fix system file problems:
Optimize Windows 7
SFC /SCANNOW Command - System File Checker
My System SpecsSystem Spec
13 Aug 2012   #3
verylunatic

 
 

Noticed in device manager I had an N drive with an exclamation mark, uninstalled it cause I have no idea what it was, most likely from a previous USB over network emulator uninstall.

After which I ran the SFC /SCANNOW Command -as you suggested just to be safe and that did the trick.

Thanks for your help!
My System SpecsSystem Spec
.

13 Aug 2012   #4
DustSailor

Microsoft Windows 8.1 Pro 64-bit
 
 

Cool, very glad it is working now.

Take care!
My System SpecsSystem Spec
Reply

 "My Computer" slow load problem




Thread Tools




Similar help and support threads
Thread Forum
"My Computer"/"Computer" slow load problem
Sometimes when I try to open the Computer window (either by clicking the start button and then Computer or hitting Windows key + E) it will take a long time to open (upwards of 90 seconds). It doesn't happen all of the time, but starts happening seemingly at random. I can open other folders, but as...
Performance & Maintenance
"Windows is not genuine" error, computer extremely slow and freezes
Hello, I could really use some help. Yesterday, I booted up my computer just like any other day, and it took forever to boot up (got stuck at the welcome screen and then at the desktop before the icons and start menu showed up). Within 5 minutes, the computer froze and was completely...
Windows Updates & Activation
Computer does not load at "Starting Windows", no safe mode or restore
I have recently been having this problem with my Compaq Presario Cq56 laptop. It used to be working fine for years and this problem suddenly came up a few weeks ago. Whenever I turn on my computer it would seem to load but then when it frayed the starting windows screen nothing else happens. The...
General Discussion
Another "My Computer is slow" thread
I know you guys must see a thousand of these every day, but bear with me. I have an HP EliteBook 8530p running the latest Windows 7 Professional. Here are my hardware specs: My Hardware 4 gigs of RAM (replaced a year ago) Intel Core2 Duo (2.9 ghz) ATI Mobility Radeon HD 3650 Hard drive...
Performance & Maintenance
"Return computer to factory condition" or "Use A System Image Crea..."
Which one should I do? I originally wanted to just do "Return computer to factory condition" but Theog just suggested "Use A System Image Created Earlier." I have no idea what to do. So confusing! :confused:
Backup and Restore
Computer won't load pass the screen "checking file system on C:"
Hi, So on my computer, every time i start up my computer, it goes to the the starting windows screen, but then it sends me to the "checking file system on C: the type of the file system is NTFS. One of your disks needs to be checked for consistency. you may cancel the disk check, but it is...
General Discussion


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 22:44.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App