Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: DPC Latency Checker shows problem but I can't find it

22 Aug 2012   #1

Windows 7/10 64 bit
DPC Latency Checker shows problem but I can't find it

I was getting some clicks in my recording studio system and ran the DPC Latency checker. It shows a problem, which I can't find (if it really is a problem). However, the clicks in my recording program went away after I changed the buffer size for my USB connected recording device (a Roland Octa-Capture) and I'm not getting any other audio pops/clicks which could be a latency problem.

I've set "diagnostic startup" in the System Configuration panel, rebooted and ran the DPC latency checker program and the spikes are still there. I've disabled all the devices I could in the Device Manager and the spikes are still there. I disabled core parking on my i7 3770 in case that was causing anything and it didn't change anything. I've looked at other system tools and didn't see anything, that I could recognize, as a problem, but I'll admit I'm not sure what I'm looking at on some of those panels.

The DPC Latency Checker will not run in Safe Mode so I can't test there.

I'm stumped on this one.

Attached Images
DPC Latency Checker shows problem but I can't find it-dpc.jpg 
My System SpecsSystem Spec
22 Aug 2012   #2

Windows 7/10 64 bit

Update, from info on the DPC web site this could be caused by a kernal mode driver. If this is the case, how do I go about isolating/determining what is it?

From their web site, which shows a display similar to what I'm getting:

At a period of 3 seconds a kernel-mode driver in the system is stalling the CPU for about 3.5 milliseconds. So, every 3 seconds DPC latency is exceptional large and drop-outs in real-time data streams will typically occur
My System SpecsSystem Spec
22 Aug 2012   #3

Windows 7/10 64 bit

Problem solved by Jim Rosebury, who builds custom recording system PC's, on the Sonar forum. The problem was "Easy Tune" that I installed from the Gigabyte installation disc when I first installed. I had removed most of the garbage that the Gigabyte disc installed but I missed the Easy Tune.

Latency is back to average 100 microsec's.

My System SpecsSystem Spec

13 Apr 2016   #4

Windows 7 Ultimate 64bit

good find - how did he spot it, any ideas?

(found this while looking up core parking, as I've never seen my core's not 50% parked, and have no reason to put any faith in the MS OS!)
My System SpecsSystem Spec
13 Apr 2016   #5

Windows 7/10 64 bit

The guy builds and configures PC's for recording studios. He is up on problems such as what I had.

BTW, I am now on Win 10 and no latency problems, as reported by the Resplendence Latency Mon program (the DPC Latency Checker is invalid for Win 8/8.1/10). I'm not doing anything special in Win 10 other than using the "High Performance" power plan (what I used in other OS'). With the i7 3770 CPU I haven't had any CPU issues with my recording studio DAW (Sonar Platinum).
My System SpecsSystem Spec

 DPC Latency Checker shows problem but I can't find it

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar help and support threads
Thread Forum
Problem with System File Checker Tool Results
Hi, I'm new to this forum. I saw a few threads regarding the System File Checker Tool. As my computer has crashed recently, I decided to use the System File Checker Tool to fix corrupted windows files. The results stated that there are corrupted files but it can't fix some of them. I went to...
Performance & Maintenance
System File Checker Problem
When I run the System File Checker (sfc /scannow) it hangs up at 31% and displays the message "Windows Resource Protection could not perform the requested operation." MS instruction's say to rerun sfc in safemode after verifying that %WinDiv%\WinSxS\Temp directory contains the PendingRenames and...
Performance & Maintenance
Audio latency problem
Hi guys... I am having a issue here that I dont know how to solve it... I have checked my pc with LatencyMon to solve the clicks and drops problem (witch is not that big but annoying) and the program told me that the problem it s coming from the SCSI Port Driver (10.035618ms on the highest...
Sound & Audio
Can't find my Memory-clock latency
My memory: MXD3C13334GS :: Memory :: Products :: Mach Xtreme Technology There is no note on the stick upon the memory sticks; Right now the CL is 9-9-9-24 (auto in bios) Is there anyway to find out whats the true CL ? I know that bad voltage settings may cause a bad mem test and BSODS....
Hardware & Devices
Live Mail Spell-Checker problem
I just found out I've got a problem with the spell-checker that embed in the Windows Live Mail. When I writing in one language, and this lang set as default in the settings - everything's good. The problem is when the language set as default is English, for instance, and I'm writing in Hebrew. The...
Browsers & Mail
Audio Latency Problem
Something is causing high latency and it's distorting the sound. I don't have this problem in XP. I've tried disabling drivers one by one and checking but no luck. A clean install did not fix the problem. Updating my audio drivers also did not work. Downloading will make the latency spike to...
Sound & Audio

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 02:08.

Twitter Facebook Google+

Windows 7 Forums

Seven Forums Android App Seven Forums IOS App