Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Windows 7 Sluggish

15 Sep 2009   #1
dmoseder

Windows 7 Ultimate
 
 
Windows 7 Sluggish

I have windows 7 on two computers and both of them experiece big slow downs especially multitasking. I came from windows vista and also it was a fresh install. More so when installing a program or game or copying files also.

Both computers have Windows 7 Ultimate 32bit.

I have updated chipset drivers.

My specs are:

Core 2 Dou E6400 2.13ghz
Geforce 8800 GTS 320mb
2gb of ddr2 ram
biostar 945p-a7a motherboard.

I'm not sure what other information you guys would need. On my laptop if im downloading big files and the download is at 99 percent and it has to save the file to the harddisk or do whatever it does the whole computer slows down. Firefox, anything its like explorer.exe freezes for a little untill its down.

Samething with my desktop.

I used windows vista, and i could multitask ALOTTT better than when i had windows 7. I mean i could be burning a disk, surfing the web, downloading a large file and streaming to my ps3. So i have no idea whats going on, ive read some posts about people have slowdowns copying files and whatnot but no one has a solution on those forums that i saw. Thanks for the help.


My System SpecsSystem Spec
.
15 Sep 2009   #2
RudeBoySes

Windows 8.1 (x64)
 
 

I have Windows 7 Ultimate x64Bit on an old Laptop and my performance is absolutely amazing !

My processor is outdated..
My chipset is outdated..


I recommend you do a clean install ..
sounds to me you messed up the installation somewhere ..

Also.. i recommend you read this post on how to improve performance:
How to increase Windows' Performance safely
My System SpecsSystem Spec
15 Sep 2009   #3
TGSoldier

 
 

Where did you acquire this copy?
My System SpecsSystem Spec
.

15 Sep 2009   #4
RudeBoySes

Windows 8.1 (x64)
 
 

Quote   Quote: Originally Posted by TGSoldier View Post
Where did you acquire this copy?

My father works for Microsoft and he leaked me the Final OEM release DVD


My System SpecsSystem Spec
15 Sep 2009   #5
dmoseder

Windows 7 Ultimate
 
 

I got it on the web, its supposed to be an OEM RTM copy. It says its 7600.16385.

It sounds like you guys are saying its the copy i got? I will try and download another and test it, i dont know what else it could be if you guys arent having the same problem. Windows Professional Edition is on my MSDNAA website, ill have to look and see the difference between that and ultimate.
My System SpecsSystem Spec
15 Sep 2009   #6
RudeBoySes

Windows 8.1 (x64)
 
 

Quote   Quote: Originally Posted by dmoseder View Post
I got it on the web, its supposed to be an OEM RTM copy. It says its 7600.16385.

It sounds like you guys are saying its the copy i got? I will try and download another and test it, i dont know what else it could be if you guys arent having the same problem. Windows Professional Edition is on my MSDNAA website, ill have to look and see the difference between that and ultimate.
- Right click "My Computer"
- Select "Properties"
- On the bottom of the left hand pane.. click on "Performance Information and Tools"
- Select "Advanced Tools" on next screen
- Select "View advanced system details in System Information"
- Scroll down to "Hardware Abstraction Layer"

What is the number there? is it "6.1.7600.16385" ?
If it is.. then you have the final version.


P.S.
You may want to take a look here:
How to increase Windows' Performance safely
My System SpecsSystem Spec
16 Sep 2009   #7
dmoseder

Windows 7 Ultimate
 
 

yes that is the version i have. I downloaded another version of windows to test, from MSDN and the problem isnt there but after i start installing stuff it is there. I am currently uninstalling stuff to see if anything will fix it, because i do not know what was installed that caused the problem.

The only thing i can think of is one of my games install something that messes up my system? I'm not sure
My System SpecsSystem Spec
Reply

 Windows 7 Sluggish




Thread Tools




Similar help and support threads
Thread Forum
Windows super sluggish right after start-up, no idea why
Okay so I've only had this issue the last few days, when my computer first boots up it boots up fine but after getting into windows it just goes INCREDIBLY SLOW. I have Resource Monitor (from Advanced System Care) up and it shows almost no RAM or CPU Usage. When I'm finally able to open up task...
Performance & Maintenance
Windows 7 32-bit running sluggish
I was hoping to get some opinions of some programs to run to diagnose what is causing my father-in-law's Windows 7 32-bit Dell system from running so slowly. It's been a few years since I've had to work on his older system and I'm not sure of some good diagnostic programs to run other than...
General Discussion
Sluggish performance in new gaming rig (Windows 7 64-bit), please help
Hello there I hope this post is in the right sub-forum. I recently built my own gaming rig and have noticed its performance is slow, much slower than it should be, given the components. My old rig seems to outperform it in every way! When I say slow, I mean basic navigation through Windows...
Performance & Maintenance
Windows very sluggish, even after format, memtest, hdd test
.....
Performance & Maintenance
Mouse pointer sluggish in Windows 7 64 bit
Hello I am using Windows 7 Home Premium, 64 bit. HP m9500f computer. Ever since installing Windows 7 my mouse cursor gets slow when surfing the net at times. That is, to get the cursor across the screen I sometimes have to sweep the mouse two or three times in that direction because the cursor...
General Discussion
Windows 7 Sluggish
Hey all, I am trying to find out why my computer is running soooo sluggish. I have Microsoft security Essentials installed and ran a scan the other day and it found nothing. I also ran AVG, Ad-aware and Search and Destroy. All 3 found no virus or adware or trojans. My system just seems to...
Performance & Maintenance


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 05:40.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App