Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Windows 7 slowed down tremendously and explorer hangs up all the time!

19 Nov 2012   #11

Win 7 Pro 64-bit 7601

I'd personally run some good antivirus or antimalware rescue disk, like say Avira's or kaspersky's

If for some reason what gregrocket said fails and what I told above fails as well you can use any good linux live-cd (like say Ubuntu) to replace explorer.exe from one you pilfered from a working Win7 installation on another machine with that same disk and a usb pendrive. Practice using it a bit on less-critical files, as the interface and commands may not be exactly the same as windows 7.

My System SpecsSystem Spec


 Windows 7 slowed down tremendously and explorer hangs up all the time!

Thread Tools

Similar help and support threads
Thread Forum
Time for Windows to be fully functional has slowed
I've read a good majority of threads here about slow boot times and slow startup times. Not really sure how to describe what I'm wanting to address other than to describe what's happening. When restarting I'm pretty satisfied with the time it takes for get through the Welcome screen. It's when...
General Discussion
Windows Explorer has slowed markedly
In the past couple of months my win 7 Windows Explorer now takes up to 20 seconds of searching to finally land on the folder selected. This is much slower than it used to be. I guess I'm not at all knowledgeable on what the search process is when one loads Windows Explorer so I don't know where to...
Performance & Maintenance
SSD boot time slowed, Error ID 109 in EventViewer. Please Help?
Hello all, I seem to have quite an annoying issue here. My samsung 830 ssd (256 gb) was working excellently and last night for some reason it decided to no longer boot at the nice speed at which it did before. Now I believe it is still performing up to par in the OS environment due to my AS SSD...
General Discussion
Internet Explorer slowed down after Chrome installation
The other day I installed Google Chrome from the link that appears in the Google home page(you have should seen it). And for my surprise, instead of download a setup file, it's like it has installed from the browser, of course it should had downloaded some temporary files. The point is that after...
Browsers & Mail
boot up time slowed
I have a Vaio E series Core i5 2.40 ghz, 4gb RAM, ATI, Win 7 Home Premium 64-bit, 500 gb HDD, Norton 2010. Months ago, it's boot up time was normal around 50-60 sec. But now, it started to slow,I went to msconfig>startup> and only synaptics pointing device driver, microsoft windows operating...
Performance & Maintenance
Windows 7 slowing down tremendously
I have this funny situation. Got a new Zotac G41 Value motherboard. Put in 1GB of 667MHz RAM and a Dual Core E2180 processor, 2.0GHz, 800MHz FSB with 1MB cache. Installed Windows 7 Ultimate. Ran fine. Then I upgraded to a E7500 processor, 2.93 GHz, 1066MHz FSB with 3MB cache. Still with 1GB of...
Performance & Maintenance

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 18:18.

Twitter Facebook Google+

Windows 7 Forums

Seven Forums Android App Seven Forums IOS App