Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: System Interrupts high CPU when any usb device gets plugged in


22 Nov 2012   #1

Windows 7 Home Premium 64bit
 
 
System Interrupts high CPU when any usb device gets plugged in

Whenever a USB device is plugged into my laptop (any of the USB ports), the CPU usage goes way up. It stays up even when the device is then unplugged, and the only way to bring it back down is to either reboot, or to go into "sleep" (when Windows resumes the problem is gone).

The Windows 7 resource monitor indicates that the problem is System Interrupts - Deferred Procedure Calls and Interrupt Service Routines. .

I have updated my drivers for each thing, and that has not helped. Not has lots of Google searches on this problem.

Running Windows 7 Home Professional 64 bit, on a Toshiba Portege R705-P41.

Any ideas? Thanks in advance.

My System SpecsSystem Spec
.

22 Nov 2012   #2
whs
Microsoft MVP

Vista, Windows7, Mint Mate, Zorin, Windows 8
 
 

A lot of DPCs usually point to a driver problem. Run this program (when the problem occurs) and see whether it gives you any clues. http://www.thesycon.de/eng/latency_check.shtml
My System SpecsSystem Spec
26 Nov 2012   #3

Windows 7 Home Premium 64bit
 
 

Thanks. I've now done that. However the latency readings are no different whether the problem is occurring or not. I.e. it is mostly in the green (sub-500us), with a single spike to 3000-4000us every 30 seconds.
Any other thoughts?
My System SpecsSystem Spec
.


26 Nov 2012   #4
whs
Microsoft MVP

Vista, Windows7, Mint Mate, Zorin, Windows 8
 
 

Any idea what process could become active every 30 seconds.
My System SpecsSystem Spec
27 Nov 2012   #5

Windows 7 Home Premium 64bit
 
 

I watched the DPC latency checker as I disabled items in device manager. The FIRST thing I disabled led to no more spikes. It was:
Intel(R) 82577LC Gigabit Network Connection, under Network adapters.
I only use wireless as apposed to an ethernet cable, so will just leave it disabled.
My System SpecsSystem Spec
27 Nov 2012   #6

Windows 7 Home Premium 64bit
 
 

This driver seems to be the source of my other (bigger) problem too. I will update the driver, and if that doesn't work, will leave it disabled.
Many thanks whs!!
My System SpecsSystem Spec
27 Nov 2012   #7
whs
Microsoft MVP

Vista, Windows7, Mint Mate, Zorin, Windows 8
 
 

I am glad you are making progress. Is there anything else I can do for you ??
My System SpecsSystem Spec
27 Nov 2012   #8

Windows 7 Home Premium 64bit
 
 

No, but I'll come back if I have further issues.
Cheers.
My System SpecsSystem Spec
Reply

 System Interrupts high CPU when any usb device gets plugged in




Thread Tools



Similar help and support threads for2: System Interrupts high CPU when any usb device gets plugged in
Thread Forum
System Interrupts high CPU usage windows 7 64 bit... Drivers
BSOD's & High CPU System Interrupts BSOD Help and Support
System Interrupts Performance & Maintenance
System interrupts and CPU Sound & Audio
my entire system crashed every time I plugged in a device Hardware & Devices
Laggy performance during high usage - caused by System Interrupts Performance & Maintenance
System Interrupts..Causing high cpu& net cutoff BSOD Help and Support

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 02:16 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33