Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Can't use mouse at all


01 Oct 2009   #1

CUOMO
 
 
Can't use mouse at all

Sorry if this is in the wrong thread, but I don't have much choice since I am navigating by keyboard.

Basically I can't use my mouse, and I am on the verge of installing Kubuntu and wiping Win 7 off. I really don't want to do that though (two programs on Windows I need).

How it started? No clue. Last program I installed was yesterday (Final Draft), and it was working fine for hours this morning. I tried using another mouse, but that didn't work. Also my keyboard stopped working too, after my mouse, but now it's working.

Win 7 7100 64-bit

My System SpecsSystem Spec
.

01 Oct 2009   #2

Win7 Build 7600 x86
 
 

Quote   Quote: Originally Posted by CupofDice View Post
Sorry if this is in the wrong thread, but I don't have much choice since I am navigating by keyboard.

Basically I can't use my mouse, and I am on the verge of installing Kubuntu and wiping Win 7 off. I really don't want to do that though (two programs on Windows I need).

How it started? No clue. Last program I installed was yesterday (Final Draft), and it was working fine for hours this morning. I tried using another mouse, but that didn't work. Also my keyboard stopped working too, after my mouse, but now it's working.

Win 7 7100 64-bit
Hi and welcome,


A few questions,

USB or PS2 mouse?

Is there a hub connected to USB?

Greetings.
My System SpecsSystem Spec
01 Oct 2009   #3

CUOMO
 
 

Thanks for replying. PS2 mouse.
My System SpecsSystem Spec
.


01 Oct 2009   #4

Win7 Build 7600 x86
 
 

Quote   Quote: Originally Posted by CupofDice View Post
Thanks for replying. PS2 mouse.
Since you already tried another mouse, it might be a broken ps2 port.

Try an USB i would say.

Greetings
My System SpecsSystem Spec
01 Oct 2009   #5

CUOMO
 
 

Hmm, possible. Also I should mention that I was in safe mode, now I am back in regular mode. And my mouse can now move, but really slow. Not sluggishly slow, but 5 seconds after I move it slow.

Anyway I will get a usb mouse, and see how that works out.
My System SpecsSystem Spec
01 Oct 2009   #6

CUOMO
 
 

I guess it was the mouse after all. Used linux live cd to see if my mouse would work in it (it didn't), but on a whim I tried the other mouse (and it did). Will still get a usb mouse though, since I got 4,5 ports for that, and I vaguely remember having mouse troubles with this comp before that were solved with a bit of wiggling.

Thanks for the help.
My System SpecsSystem Spec
01 Oct 2009   #7

Win7 Build 7600 x86
 
 

Good plan,

Probably lose contact of one of the pins in the PS2 port.

Good luck
My System SpecsSystem Spec
01 Oct 2009   #8

Windows 7 Ultimate 32bit
 
 

Check if there are any bent pins on the mouse cable. I reccomend a usb mouse for windows 7.
Marc
My System SpecsSystem Spec
Reply

 Can't use mouse at all




Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 01:26 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33