Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: General Win7 memory leak and Unknown memory usage?

26 Apr 2013   #1
Mesohamster

win7 64 bit home premium
 
 
General Win7 memory leak and Unknown memory usage?

So I've had this problem for a few months with my thinkpad x220, win7 home premium 64 bit. I used ccleaner, run memtest86 multiple times, chkdsk multiple times, sfc scan multiple times, none that helped. Sfc always detects errors but always cannot fix some of them. I have mse, avast, and malwarebytes and scanned them with absolutely no results. I've run rootkit scanners with no results.

Basically after a few hours the memory use rises up to ~95% out of my 8gb, with absolutely no intensive processes running. I'll attach rammap and processexplorer screenshots. I know this is not "normal" behavior because once my ram goes over 85% the system slows down to where I can't end tasks, open new programs, even things like deleting a file take minutes. Once it reaches 90 or 95, my screen starts flashing black(kind of like if you blink fast). I have to hard restart every time this happens. This is not normal, I've had "experts" on other forums tell me its win7 using the ram to its greatest. Its not, As soon as I restart and open my usual programs(browser, steam, openoffice, winamp, utorrent) my ram is at around 30 or 40 percent. If I leave the same programs open, and just leave it on for ~4 hours the ram gets to 90% and my screen starts flashing and I have to reboot.

If you look at the rammap and process explorer shots, the most ram intensive programs are chrome and firefox, but they only use ~500mb each. Everything else is only 50-100mb and do not add up to the 7.50gb my computer uses after only a few hours. The thing I noticed is that the "page table" is using 3gb of my ram, don't know what it is though.

I tested my hdd using crystaldiskinfo and hdtune and found nothing. Although I did replace the factor hdd with a larger 500gb one and imaged my previous hdd. But I don't think this is the problem since I've had the new hdd for a year and the problems started in the last few months.

My ram is 8gb, 4gb factory and 4gb corsair select I bought afterwards. I tested my computer with memtest86 and manually rebooted with each stick and the same thing happened only faster because of the less ram, it must be a software issue.

Ram Use(Note, both these show the screenshots when my computer was at ~91%, like gb ram is unaccounted for??)

Ram Use - Imgur


My System SpecsSystem Spec
.
26 Apr 2013   #2
VistaKing

Windows 7 Ultimate 32-Bit & Windows 7 Ultimate 64-Bit
 
 

Hi mesohamster welcome to SevenForums

First I recommend uninstalling Avast then we could go from there . Using Revo Uninstaller

download

Click on the app inside RevoUnistaller and choose uninstall
Click on Yes to agree you want to uninstall
If you get the builtin Uninstaller for the app use that and once you're done click Finish
Back inside RevoUninstaller click on Next
Let RevoUninstaller scan for left over registry keys . Click on Select All and choose Delete .
Once done click on Next.
Let the left over files and folders be locates then Click on Select All then click Delete then Next and you should be done .

Restart PC
My System SpecsSystem Spec
26 Apr 2013   #3
Mesohamster

win7 64 bit home premium
 
 

Avast was one of the first things I installed. How would it effect memory? It only uses a couple mb
My System SpecsSystem Spec
.

27 Apr 2013   #4
VistaKing

Windows 7 Ultimate 32-Bit & Windows 7 Ultimate 64-Bit
 
 

Avast causes a lot of issues .
My System SpecsSystem Spec
27 Apr 2013   #5
Mesohamster

win7 64 bit home premium
 
 

Uninstalling avast and mse didn't help. I just want to find out which process it is, but its not showing up on processexplorer or anything
My System SpecsSystem Spec
27 Apr 2013   #6
LMiller7

Windows 7 Home Premium 32 bit
 
 

Post a screenshot of RAMMap. Without more information it is all just guesswork.
Adding up the memory usage of individual processes rarely provides meaningful information. There are major users of memory that are not processes.
My System SpecsSystem Spec
28 Apr 2013   #7
Mesohamster

win7 64 bit home premium
 
 

What screen of rammap should I post? I already posted the top ram using processes and use counts.
My System SpecsSystem Spec
29 Apr 2013   #8
Mesohamster

win7 64 bit home premium
 
 

Also I noticed that my hdd might be failing. Sometimes everything hangs for a few seconds, and the hdd light goes off. Everything returns to normal once the hdd starts running.
My System SpecsSystem Spec
Reply

 General Win7 memory leak and Unknown memory usage?




Thread Tools




Similar help and support threads
Thread Forum
chkdsk high memory usage / memory leak
Has anyone else noticed that chkdsk uses all available physical memory (if you let it run long enough)? I find that if I run chkdsk and watch the memory usage in task manager it jumps by about 50MB every 2 seconds or so until it either finishes or hits around 3.2GB at which point my physical...
Performance & Maintenance
Troubleshooting Excessive Memory Use (Memory Leak?) after playing vid.
HI; I am having a problem with my memory getting tied up / used up and not being able to access it again until I reboot. Machine: Dell xps studio 8100 OS: Win 7, Processor: i7 2.8 RAM: 16GB (max it will take) Video: ATI Radeon 5700 (running 3 monitors) Versions: As far as I know I am...
Performance & Maintenance
[Help]Memory Leak. All memory drained and used
Today, my computer decided for some reason to start hogging all the memory. The memory slowly goes up after around 3:30 minutes of being open. CPU usage is at regular. I have tried many things to fiqure out the problem. Not even safe mode works. Also it's very weird because i have 6gb of...
BSOD Help and Support
CPU Usage Flaw or Memory Leak
Hello, I am experiencing a strange memory leak or CPU flaw where my CPU usage randomly shoots up to 90-100% even when no applications or programs are open. This can happen anytime from immediately after a fresh restart or after several hours of the computer running. I have read some threads...
Performance & Maintenance
Win7 x64 explorer.exe GROWING memory usage!
When I start the computer, explorer.exe takes about 100MB of memory and it starts eating more memory right away (even if no programs open and I don't use the computer). About 200KB in every 2 seconds! When my computer had been open for about 6 hours, the explorer.exe was eating memory almost 1GB! ...
Performance & Maintenance
2 Things :P ( searchindexer memory leak & win7 upgrade)
1.)okay so i use the start menu search box to run cmd commands all the time... then suddenly pc starts to lag/slow down I open taskmanger(barely) and see that searchindexer.exe consumes like 300mb RAM O>O? has anyone noticed that? Discuss Lol! 2.) well just wanna upgrade my build 7100 to 7127...
General Discussion


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 11:08.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App