Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Trying to move Users and ProgramData to a different drive

04 Aug 2013   #1
skylos

Windows 7 Ultimate x64
 
 
Trying to move Users and ProgramData to a different drive

I'm trying to move Users and ProgramData to a different drive.

I searched the Net and tried this and that with no luck, whatsoever..

They suggest I move the folders to a different drive and create links on C (with mklink) pointing to the new locations, but I can't do it.

I can't move Users, for I am logged in as one. And I can't move ProgramData for Windows won't allow it.

Trully, I hope I'll get to like my new operating system at some point because we have started on the wrong foot. I can't do things I need to do. I have sweat quite a lot only to achive... nothing.



My System SpecsSystem Spec
.

04 Aug 2013   #2
VistaKing

Windows 7 Ultimate 32-Bit & Windows 7 Ultimate 64-Bit
 
 

My System SpecsSystem Spec
04 Aug 2013   #3
skylos

Windows 7 Ultimate x64
 
 

thnx..

That's for a fresh installation, though..

Any solution for a system installed already?

(In the meanwhile I did move user folders, one by one, and created linx to them..)
My System SpecsSystem Spec
.


04 Aug 2013   #4
VistaKing

Windows 7 Ultimate 32-Bit & Windows 7 Ultimate 64-Bit
 
 

My System SpecsSystem Spec
05 Aug 2013   #5
skylos

Windows 7 Ultimate x64
 
 

Eventually, I reinstalled Windows 7 following the suggested instructions (audit mode, xml etc.) and I managed to have these two folders in a different drive!

It is a bit of a fuss but very well explained.

thanx!
My System SpecsSystem Spec
05 Aug 2013   #6
VistaKing

Windows 7 Ultimate 32-Bit & Windows 7 Ultimate 64-Bit
 
 

Glad you have it the way you wanted .
My System SpecsSystem Spec
Reply

 Trying to move Users and ProgramData to a different drive




Thread Tools





Similar help and support threads
Thread Forum
Did you move Users to a different drive with a SSD?
When you installed w7 on a SSD did you relocate your data, Videos, Documents, Pictures, etc to a separate physical drive? Yes I did on two rigs.:) EDIT: For my purpose I mean Data and Users to mean the same, I.e., personal data.
Hardware & Devices
Need help deciding whether to move Users folder or not
Hello everyone, I have been scouring the net on how to move the Users folder in an SSD/HDD setup from the SSD (C:\) to the HDD (D:\) but I remain confused on whether it is truly needed or even which approach to take. I found essentially 3 distinct approaches (and several variations on them)...
General Discussion
How do i move USERS folder to another drive
Hello, I want to know if there is a way to create a new user which Users directory won't be in C:/. The idea is , i have a 60G SSD and a second hdd. When i install games ( ex Sims ) even if i install in D:/(second drive which is a normal hdd) he still writes some files to C:/ where i need to put...
Performance & Maintenance
how do i move the users directory from C: to another drive?
Hi all, I have a computer with a 60 gb SSD and 1 tb HDD and the users folder is stuck on the ssd. I want to move it to the HDD where there is more room for files. I already tried to to this but it didn't work. I copied the users folder to the HDD and made a link to it on the ssd. But this did...
Performance & Maintenance
How to move C:\Users on a different partition
Used to be a time when I kept my the \WIndows and core apps n a C partition, and my large users files on a D partition. In that way - the C was samll, easily imaged to a second drive, etc, - all data file were on the D partition, easily backed up to another drive These days, with super large...
Customization
Move Users Folders XML sysprep FAILS HELP!
I am trying to use Kari's xml script For sysprep to move users folders during installation - something is going wrong. I'm using a Windows 7 Enterprise iso burned from MS Volume Licensing download which already has SP1 integrated. Windows 7 installs fine, and I can get into audit mode. When I...
Customization

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 01:02.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App