Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Cannot Run command as Administrator


20 Sep 2013   #1

Windows 7 Ultimate 32bit
 
 
Cannot Run command as Administrator

Hello,

I have been buried by a cascade of issues that just drove me to a dead end.

Everything started when one of the applications I use couldn't install properly. Now everytime I try to run this application it says that the folder d:\windows\assembly\gac_32\mscorlib\... is corrupted. Weirdly there is not any folder with this name there. And yes, I told Windows to show all the hidden files! Also I searched the Registry to see if it was some kind of ghost entry there, but nothing!

Anyway, now whenever I boot my system at certain point it says that File System has to be checked. If I allow it to check the system it will performs "3 stages" and then will auto-reboot. If I don't touch the computer it will keep doing it forever (check-reboot-check-reboot-check-reboot...).

OK, since I know that it won't get me anywhere the only thing to do at this time is to stroke a key to ignore the check. OK, then it will finish load Windows but the File System wasn't fixed, so my next attempt is to try to run checkdisk by myself right from the command prompt. Simple.

Hum... not really! Now I have another problem: Windows doesn't allow me to run checkdisk saying to me that I don't own enough privileges and that I have to run in "elevated mode" (I love the MS poesy!).

It's important to mention at this time that my account says that I AM the administrator. Anyway, if I right-click the "Run" option at the start menu there will NOT a "Run as administrator" option but only the "Run" one (that is unuseful for me).

I have tried several ways to enhance my privileges, including to right-click on the drive D:\ and check onto the security tab to ensure that I have full control. As far as I can see I have all the privileges I need, but the problem persists. I don't know what else I can do!

At this time I am with my hands absolutely tied and cannot fix my Windows. Therefore I cannot work because the application I need is corrupted and it's impossible to correct the issue because Windows decided that I am not the right person to do that!



I pray for the chance that a good soul can enlight my way!!!!

Thanks!

PS: Just in case someone is wondering why my Windows is in drive D:\, it's because in the drive C:\ I have Windows XP Pro 32bit.

My System SpecsSystem Spec
.

20 Sep 2013   #2

Win 7 ultimate x64 sp1
 
 

boot from a windows7 install cd.
see https://kb.wisc.edu/page.php?id=6565 for instructions.
My System SpecsSystem Spec
20 Sep 2013   #3

Windows 7 Professional x64 Sp1
 
 

Not to sound redundant, but you might want to do a Repair Install
My System SpecsSystem Spec
.


20 Sep 2013   #4

Windows 7 Ultimate 32bit
 
 

Thank you very much, fellows! The repair tool from the install disk did the magic!



I am back to business!
My System SpecsSystem Spec
Reply

 Cannot Run command as Administrator




Thread Tools



Similar help and support threads for2: Cannot Run command as Administrator
Thread Forum
Open Command Window Here as Administrator Tutorials
Run as administrator command has stopped working General Discussion
elevated command administrator password General Discussion
Command Prompt won't Disable Administrator Account General Discussion
Solved I've lost my Run As Administrator command Performance & Maintenance
Problem open command Window(administrator) Network & Sharing
Run login command as Administrator Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 11:50 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33