Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: error 0xC0150004 / win7 fixing progs don't work

26 Oct 2013   #1

linux(SuSE-64),Win7-64
 
 
error 0xC0150004 / win7 fixing progs don't work

Am having getting error 0xC0150004 -- missing smx assembly.

Trouble is any installer I've tried to run to install things like the visualC++ libs ALSO gets the error.

MS SecEssentials turn up no probs.

sfc fixes a few things, but not all of them -- unlike the old sfc, the new one never asks for sources to replace bad copies -- it just gives up... so it's not so helpful.

Most of my 64-bit progs work.. it's mainly the 32bit ones that are affected. Programs that rely on non-MS libraries (Firefox, Thunderbird, cygwin), aren't affected...

I even tried a soft-upgrade over myself -- neither version (SP1-OEM SP1-Generic) would work... they fail with errors -- that's really weird, as it comes off it's own DVD.,..

Can't get Internet Explorer to run.... (neither 32 nor 64 bit) -- and can't install it from a stand alone installer (says there is a newer version installed -- even with IE10 which I've never had running on this machine; Sigh)....

I'm running low on hope. Most apps DO work, -- even games/ video/ audio... but the ones that don't are hard to get by w/o. Depends64 will run but Depends32 won't run, so I can't even see what the problem is clearly...

Have tried a few fixes, but made things worse and resorted to sysrestore...

Gawd I hate it that MS makes a OS that can't be repaired or fixed... and just goes on
with new OS stuff that will be less stable and more broken...would be nice if more vendors emphasized getting the current stuff to work rather than constantly throwing in new features which always seem to lead to permanent beta quality programs... (thanks google for making that acceptable! *not*)...

Anyway, thats my starting point... I can supply more info if desired, ...

Thanks!
T


My System SpecsSystem Spec
.

Reply

 error 0xC0150004 / win7 fixing progs don't work




Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 08:00 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33