Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: High CPU Usage - Problem??

25 Oct 2009   #1
Squizzle

Windows 7 Home Premium
 
 
High CPU Usage - Problem??

Hey all,

After upgrading from Vista and using W7 for a few hours on my laptop I decided to go look at the cpu usage and noticed that it was and stayed well over 40%.

I remember from using Vista that it rarely went over 20-25% even when I had a number of apps open.

I was just wondering if there is something running in the background that I am not aware of and that I don't need as surely the cpu usage shouldn't be that high??

I've only got avg running ontop of the standard items running in the back ground, and I've been through the tutorial to see if I could shut anything off, but it's not made a difference to the cpu usage.

Just concerned about my laptop over heating tis all, the fan hasn't stopped spinning since I first started using W7.

I've attached a Screen Capture for your viewing pleasure, incase it helps!

Your thoughts would be appreciated folks.

Cheers

Squizzle




Attached Images
 
My System SpecsSystem Spec
.

26 Oct 2009   #2
Squizzle

Windows 7 Home Premium
 
 

Well, not sure what is causing the high usage as yet, but on first boot up this evening the CPU usage is only about 3%, so I guess I'll just keep an eye on it.

I'll have the laptop on for a couple of hours atleast this evening, so I'll see if the CPU usage goes up during that time.

Squizzle
My System SpecsSystem Spec
26 Oct 2009   #3
Squizzle

Windows 7 Home Premium
 
 

Hmmm, k, seems to be fine ... still cpu is low, nothing like yesterday, had the laptop running for a couple of hours now, been playing wow for a while too, still cpu is low.

Wonder what it could have been yesterday?

Squizzle
My System SpecsSystem Spec
.


26 Oct 2009   #4
gjb1124

Windows 7 Ultimate 64bit
 
 

I was wondering what your CPU usage is like when playing WoW?
Mine is all over the map, between 30% and 70's.
My System SpecsSystem Spec
26 Oct 2009   #5
whs
Microsoft MVP

Vista, Windows7, Mint Mate, Zorin, Windows 8
 
 

Hmm, your snipped picture shows 9% usage, 91% idle. That's pretty normal. From where do you get the high numbers?
My System SpecsSystem Spec
27 Oct 2009   #6
Squizzle

Windows 7 Home Premium
 
 

Quote   Quote: Originally Posted by whs View Post
Hmm, your snipped picture shows 9% usage, 91% idle. That's pretty normal. From where do you get the high numbers?
I've always gone by the percentage figure at the bottom of the tskmngr, it says 41% in that pic ..... I take it thats not right then!
My System SpecsSystem Spec
27 Oct 2009   #7
whs
Microsoft MVP

Vista, Windows7, Mint Mate, Zorin, Windows 8
 
 

Well, if the "System idle process" is 91%, the CPU usage cannot be 42%. I would go by the number that the performance tab shows.
My System SpecsSystem Spec
27 Oct 2009   #8
gartaud

Windows 7 Ultimate 32-bit
 
 

You should check what the Resource Manager says. Maybe it's a system interrupts issue...
My System SpecsSystem Spec
28 Oct 2009   #9
Squizzle

Windows 7 Home Premium
 
 

Well, all seems right at the moment, after installing W7 on the first day and the CPU % use being high, it hasn't done it since, so who knows what it was.

Been monitoring the resource manager and performance manager and CPU usage is rarely above 5%, and only flits upto 40-70% when a program starts, so all in all ok then!

Cheers for the comments and advice thought peepz!

Squizzle
My System SpecsSystem Spec
28 Oct 2009   #10
whs
Microsoft MVP

Vista, Windows7, Mint Mate, Zorin, Windows 8
 
 

You may want to install a CPU meter on your win7 desktop (old sidebar meter). It gives you real time information and you see immediately when something unusual happens. In those cases I launch Process Explorer to study the details.
My System SpecsSystem Spec
Reply

 High CPU Usage - Problem??




Thread Tools





Similar help and support threads
Thread Forum
Performance problem from periodic high CPU usage, please help
I've just started having a problem where my computer becomes periodically unusable for chunks of time, like 30-60 minutes. Everything is going along well and then it slows down to a crawl. In the task manager, under performance, I see a crazy amount of activity, sometimes pegged at 100%,...
Performance & Maintenance
Problem high cpu usage?
hello ,sir its my first post From some days i have been facing problem with high cpu usage leading to my computer becomes very slow after looking at the problem i found that dllhost.exe is consuming 80% of my memory and this happens when i open c:\uses\user\downloads after that dllhost .exe...
Performance & Maintenance
Very high CPU usage, causing very high laptop CPU temps (90c idle)
This problem began yesterday. I noticed my CPU was at 90C constantly with very high CPU usage (>50%). I had no major programs running. I rebooted several times and the program persisted. 1. I went into safe mode and everything was normal. So this rules out hardware issues. 2. I reformatted and...
Performance & Maintenance
High CPU Usage Problem
Laptop specs System Model: HP Pavilion Dv7 Notebook PC Processor: Intel Core i5 @ 2.53 GHz, 2 Cores, 4 Logic Processors My laptop is about 4 months old, and I began having this problem 2 months ago. My CPU power rises up to 100% and gets stuck there, and the system slows down to a crawl. I...
Performance & Maintenance
Windows Explorer high cpu usage problem!!
I love windows 7 new innovative features but I am thinking to switch back to Windows XP as I am so tired of explorer.exe 100% cpu usage problem and I can't browse my files on my hard drive because whenever I do, my Pc gets unresponsive and task manager shows 100 cpu usage by explorer.exe!!...
Performance & Maintenance
need help NEW problem high CPU usage
Well I haven't changed anything about my computer in about a month, but today my CPU and ram are being strained a lot more than they have before. I checked processes and nothings new. XFire, Sidebar... all the same, no major resources. My CPU Usage is usually about 3% and ram at about 20%. today my...
Performance & Maintenance

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 04:24.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App