Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: CBS.log excerpt

26 Mar 2014   #11
Gandalf

Microsoft Windows 7 Ultimate 64-bit 7601 Multiprocessor Free Service Pack 1
 
 

Noel - How can I view the component file? I can't resist a challenge.
I tried your Notebook ++, but it came up with unreadable characters.


My System SpecsSystem Spec
.
27 Mar 2014   #12
Gandalf

Microsoft Windows 7 Ultimate 64-bit 7601 Multiprocessor Free Service Pack 1
 
 

The uploaded file is the error entries in a copy of my CBS.log. I deleted everything else so it would be easier to identify the errors. I could be wrong, but it looks to me that all the errors refer to the same file.

I did a search on [HRESULT = 0x80070490 - ERROR_NOT_FOUND] and it took me to...
"ERROR_NOT_FOUND (0x80070490)" when trying to install - Microsoft Community
"ERROR_NOT_FOUND (0x80070490)" when trying to install SP1 in Windows7Pro (x64):

This is confusing to me especially since I have Windows7Ultimate (x64).
I scanned the Installed Updates for the installed SP1 and it took me to...
Information about Service Pack 1 for Windows 7 and for Windows Server 2008 R2
Information about Service Pack 1 for Windows 7
From what I'm reading from this page for the Service Pack 1, Microsoft does not distinguish between Win7Pro and Win7Ult.

The question is, where do I go from there. Should I try to uninstall SP1, then reinstall it?
Would that eliminate these error messages in the CBS.log?
My System SpecsSystem Spec
27 Mar 2014   #13
NoelDP

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10
 
 

All the errors refer to the same file - not too surprising, as the system will attempt to search for the same file every time it boots, or for other reasons.

I've got a few minutes now, so maybe I can have a hunt and see what I can find in your COMPONENTS file.

The file is the registry hive for HKLM\COMPONENTS - which is loaded only when the system needs access for Windows Update, or other Windows changes.
You can usually read most of its content in REGEDIT, but you have to force it to load first, using the command

REG LOAD HKLM\COMPONENTS C:\Windows\System32\config\COMPONENTS

You can also open it in a Hex Editor - HxD is the one I use - which can be useful in cases where corruption has occurred, since Regedit can't cope with much in the way of bitflips, and will barf on many of them.

Back soon.
My System SpecsSystem Spec
.

27 Mar 2014   #14
NoelDP

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10
 
 

Hah! I've been looking in the wrong place

I need to see your SOFTWARE hive - or rather part of it.

Please open Regedit
Navigate to the HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\Component Based Servicing branch and highlight the entry.
Right-click on it, and select Export.

in the popup, change the export type to 'Registry Hive Files'
in the File name box, call it 'GandalfSW'
Make sure that it's pointing to a reasonable place to save the file
Click Save

Now find the saved file, and compress it - upload the result to either your reply (if less than 8MB), or to Jumpshare and post a link.
My System SpecsSystem Spec
27 Mar 2014   #15
Gandalf

Microsoft Windows 7 Ultimate 64-bit 7601 Multiprocessor Free Service Pack 1
 
 

I have no Component Based Servicing branch.
My System SpecsSystem Spec
27 Mar 2014   #16
NoelDP

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10
 
 

Duh!
My fault.

Here's the proper path...
HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Component Based Servicing
My System SpecsSystem Spec
27 Mar 2014   #17
Gandalf

Microsoft Windows 7 Ultimate 64-bit 7601 Multiprocessor Free Service Pack 1
 
 

See attached.

I installed HxD
However, I can't get it to work with the components file.
The HxD open doesn't see it.
Going from the file to open it in HxD, I get this.


Attached Images
CBS.log excerpt-hxd-error.png 
Attached Files
File Type: zip GandalfSW.zip (838.9 KB, 2 views)
My System SpecsSystem Spec
27 Mar 2014   #18
Gandalf

Microsoft Windows 7 Ultimate 64-bit 7601 Multiprocessor Free Service Pack 1
 
 

Noel - I don't remember what caused those errors in post 4.
I did a new Windows Update and a new sfc /scannow and neither produced any errors in the cbs.log.

Have we somehow fixed the cause of the errors?
My System SpecsSystem Spec
28 Mar 2014   #19
Gandalf

Microsoft Windows 7 Ultimate 64-bit 7601 Multiprocessor Free Service Pack 1
 
 

Quote   Quote: Originally Posted by Gandalf View Post
See attached.

I installed HxD
However, I can't get it to work with the components file.
The HxD open doesn't see it.
Going from the file to open it in HxD, I get this...
I figured it out. You need to make a copy of the file, then open it with HxD.
Sneaky.

However, I don't see how you can make heads or tails out of the presentation.
My System SpecsSystem Spec
28 Mar 2014   #20
Gandalf

Microsoft Windows 7 Ultimate 64-bit 7601 Multiprocessor Free Service Pack 1
 
 

The errors are back with the Windows Update...

Code:
2014-03-28 12:11:51, Info                  CBS    EvaluateApplicability, package: Microsoft-Windows-EmbeddedSDP-wrapper~31bf3856ad364e35~amd64~~6.1.7601.17514, Package applicability: Absent.
2014-03-28 12:11:51, Info                  CBS    Appl: Partial install Status testing, package: Package_for_KB976933~31bf3856ad364e35~amd64~~6.1.7601.17514, partially installed (true/false), 0
2014-03-28 12:11:51, Info                  CBS    Failed to find package from aggreated XML string, package: Package_for_KB976933~31bf3856ad364e35~amd64~fr-FR~6.1.7601.17514 [HRESULT = 0x80070490 - ERROR_NOT_FOUND]
2014-03-28 12:11:51, Info                  CBS    Failed to find package from deployment update [HRESULT = 0x80070490 - ERROR_NOT_FOUND]
2014-03-28 12:11:51, Error                 CBS    Failed to check whether package is partially installed, package: Windows7SP1-KB976933~31bf3856ad364e35~amd64~~6.1.1.17514 [HRESULT = 0x80070490 - ERROR_NOT_FOUND]
2014-03-28 12:11:51, Info                  CBS    Failed to evaluate external applicability for package update: 976933-0_neutral_PACKAGE [HRESULT = 0x80070490 - ERROR_NOT_FOUND]
2014-03-28 12:11:51, Error                 CBS    Failed to call external evaluate applicability on package: Package_for_KB976932~31bf3856ad364e35~amd64~~6.1.1.17514, Update: 976933-0_neutral_PACKAGE [HRESULT = 0x80070490 - ERROR_NOT_FOUND]
My System SpecsSystem Spec
Reply

 CBS.log excerpt




Thread Tools Search this Thread
Search this Thread:

Advanced Search



Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 09:15.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App