Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: System interupts causing high CPU usage, possibly from ataport.sys

07 May 2014   #11
whs
Microsoft MVP

Vista, Windows7, Mint Mate, Zorin, Windows 8
 
 

Hmm, unfortunately in your case the latency checker was not very clear as to the causes. I am afraid you will have to follow the advice and eliminate one after the other driver by disabling it in the device manager. But it definitely seems to point to a driver problem.


My System SpecsSystem Spec
.
07 May 2014   #12
ktm583

Windows 7 Home Premium 64bit
 
 

I have tried that, however, I could not isolate the cause. Here is what I noticed about the problem ( system interrupts using a high percentage of my processor):

1st) If I restart my computer I will not have any problems with system interrupts using a large percentage of my processor for 6-12 hours. After that it starts causing problems.

2nd) It only occurs when I open a program or there is a program actively running, if the program is idle there are no problems. Example when I run CCleanner, CC well use about 4 percent of my total processor and system interrupt wills use 100% of one core. When CC is done cleaning its processor usage drops below 1% and so does the processor usage of system interrupts.

It leads me to believe there is a driver or hardware problem with my hard drive, motherboard, memory, processor or something like that; these are all things that I cannot disable from device manager. Would that theory make sense?

I have ran a Chkdsk, memory diagnostics, updated my hard drive firmware. I can't update my BIOS because it is fully updated already.
My System SpecsSystem Spec
11 May 2014   #13
ktm583

Windows 7 Home Premium 64bit
 
 


It has been 36 hours since the problem has occurred so I think it is fixed.

First off my problem (high CPU usage from System interrupts) occurred only when there was a high amount of disc usage, such as when copying files, opening a program or running a program that accesses the disk a lot when running, like a virus scan.

Here is what I did, though I am not sure exactly which fixed the problem.

I downloaded and ran Auslogics Registry cleaner, Auslogics Disk defragmenter, and Auslogics Registry Defragmenter. When running the Disk defragmenter, I selected the option to move system files to the front of the disc and ran the defrag and optimizer, as opposed to solely the defrag.

Then I ran Chkdsk using the following Administrator command prompt command: Chkdsk /f /r :C

After words, I downloaded Seatools from Seagate, and ran the Fix All long option on my hard drive.
My System SpecsSystem Spec
.

Reply

 System interupts causing high CPU usage, possibly from ataport.sys




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
one of the svchost.exe causing my system to have high cpu usage
i saw this process in task manager svchost.exe causing my system to have 50% cpu load at idle, after i end task it the windows gui desktop turns to classic and returns back to normal. how to fix this btw i have windows xp but i know you encounter or read some of this problems please help me fix...
Hardware & Devices
Very high CPU usage, causing very high laptop CPU temps (90c idle)
This problem began yesterday. I noticed my CPU was at 90C constantly with very high CPU usage (>50%). I had no major programs running. I rebooted several times and the program persisted. 1. I went into safe mode and everything was normal. So this rules out hardware issues. 2. I reformatted and...
Performance & Maintenance
wermgr.exe causing high cpu usage
I am not shore if this is wright place for this thread, I apologise if it is not. My CPU usage is mostly normal (3-10%), but sometimes it goes up to 80-93%, it last for 10-15 minutes and than go back to normal work. I checked computer for viruses with AVG 2012, Emsisoft Anti-malware, and Mbam(...
Software
Help please high cpu usage "System Interupts"
Google is giving me a million different answers and I heard this is the place to get real help, anyways. So I did a clean install a few days ago. Not a ton of apps installed. No anti virus or anything like that. I noticed that my cpu idles between 15 and 20%. Its one core steady at...
Performance & Maintenance
Network Traffic Causing High CPU Usage
Hello. For the last week or so, my network traffic has seemed to be related to some pretty sever spikes in my CPU usage. These spikes are causing extreme stuttering in my music playback, freezing of my cursor, and other symptoms of a really laggy computer. This pretty much occurs whenever I use the...
General Discussion
svchost.exe + NTDLL.DLL Causing high CPU Usage
Computer stats Windows 7 Pro 64 Bit Gigabyte Socket 775 Mobo Intel Core 2 Duo 3.0 CPU Nvidia 8800GT 4 GB DDR2 Ram MSI TV Anywhere PCI TV Tuner Soundblaster Audigy 2 ZS I have recently beginning with last Thursday been experiencing after a good 4-7 hours of the computer being on a massive...
General Discussion


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 17:07.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App