Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: System interupts causing high CPU usage, possibly from ataport.sys

05 May 2014   #1
ktm583

Windows 7 Home Premium 64bit
 
 
System interupts causing high CPU usage, possibly from ataport.sys

I been working on this for a month now and have had no luck looking in other posts. System interrupts uses one core of my computer 100%. I ran windows performance analyzer and it seems to be caused by ataport.sys . The problem happens periodically and will last for a couple of hours then go away. I have ran an AVG full scan and Malwarebytes full scan. I've tried to update all my drivers. I'm not sure what else to do.

I will attach some links to trace files if anyone would be willing to look at them.

This is a trace file with system interrupts using low to no processor.


https://onedrive.live.com/redir?resid=59359A7BEC936972!6165&authkey=!AEYzozwVA-uWqII&ithint=file%2c.zip


This is a trace file when system interrupts is using a high percentage of the processor.


https://onedrive.live.com/redir?resid=59359A7BEC936972!6231&authkey=!APKjDL-HQmvXTxU&ithint=file%2c.zip


This is the trace file when system interrupts is using a high percentage of the processer after uninstalling Garmin Express.


https://onedrive.live.com/redir?resid=59359A7BEC936972!6264&authkey=!AC457vuCo8tBXr4&ithint=file%2c.zip

Thanks in advance


My System SpecsSystem Spec
.
05 May 2014   #2
whs
Microsoft MVP

Vista, Windows7, Mint Mate, Zorin, Windows 8
 
 

This may be a driver problem Run this latency checker, it may give you a clue. Red bars mean that there is a problem.
My System SpecsSystem Spec
05 May 2014   #3
ktm583

Windows 7 Home Premium 64bit
 
 

I have tried this procedure with latencyMon and I was unable to isolate which driver was causing the large amount of system interrupts. There is a large amount DPC. I was hoping that the trace files I attached would help someone figure out what maybe causing the problem. Would you be able to ,or maybe know someone who you could refer to this thread?

Thanks.
My System SpecsSystem Spec
.

05 May 2014   #4
whs
Microsoft MVP

Vista, Windows7, Mint Mate, Zorin, Windows 8
 
 

TThe latency checker I linked usually tells you on the bottom where the culprit is. Was there no such message.
My System SpecsSystem Spec
05 May 2014   #5
ktm583

Windows 7 Home Premium 64bit
 
 

I did not know that that one would tell me the culprit. I will try it the next time system interrupts is using a high percentage of my processor, it does it intermittently for several hours at a time.

Thanks.
My System SpecsSystem Spec
05 May 2014   #6
carwiz

Windows 7 Pro-x64
 
 

I don't see anything but a blank screen. Could you please Attach the files/images to your message. The small paperclip in the message header is used to attach files.
My System SpecsSystem Spec
05 May 2014   #7
ktm583

Windows 7 Home Premium 64bit
 
 

I can not attach the files as they are 8MB a piece, too large to attach to a post. I was able to download them from onedrive, on a public computer, using the links I provided, and without signing into my account. Maybe you could try again, if it does not work thanks for at least trying to help.
My System SpecsSystem Spec
05 May 2014   #8
carwiz

Windows 7 Pro-x64
 
 

No thanks. I'll unsubscribe.
My System SpecsSystem Spec
05 May 2014   #9
whs
Microsoft MVP

Vista, Windows7, Mint Mate, Zorin, Windows 8
 
 

Quote   Quote: Originally Posted by carwiz View Post
No thanks. I'll unsubscribe.
Makes sense.
My System SpecsSystem Spec
06 May 2014   #10
ktm583

Windows 7 Home Premium 64bit
 
 

Ok, so I ran the latency checker you suggested and here is what I got. When I First started running it CCleaner was also running, the DPC was through the roof, and the system interrupts percent processor usuage was high. After CCleaner stopped running, the DPC dropped and so did the system interrupts processor usage. Here are screen shots of both cases.

I seems like programs that have a lot of disc usage ( AVG, MSE, CCleaner) are causing the high amount of interrupts. What would cause that?


Attached Thumbnails
System interupts causing high CPU usage, possibly from ataport.sys-dpc-latency-checker-cc-running.png   System interupts causing high CPU usage, possibly from ataport.sys-dpc-latency-checker-cc-not-running.png  
My System SpecsSystem Spec
Reply

 System interupts causing high CPU usage, possibly from ataport.sys




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
one of the svchost.exe causing my system to have high cpu usage
i saw this process in task manager svchost.exe causing my system to have 50% cpu load at idle, after i end task it the windows gui desktop turns to classic and returns back to normal. how to fix this btw i have windows xp but i know you encounter or read some of this problems please help me fix...
Hardware & Devices
Very high CPU usage, causing very high laptop CPU temps (90c idle)
This problem began yesterday. I noticed my CPU was at 90C constantly with very high CPU usage (>50%). I had no major programs running. I rebooted several times and the program persisted. 1. I went into safe mode and everything was normal. So this rules out hardware issues. 2. I reformatted and...
Performance & Maintenance
wermgr.exe causing high cpu usage
I am not shore if this is wright place for this thread, I apologise if it is not. My CPU usage is mostly normal (3-10%), but sometimes it goes up to 80-93%, it last for 10-15 minutes and than go back to normal work. I checked computer for viruses with AVG 2012, Emsisoft Anti-malware, and Mbam(...
Software
Help please high cpu usage "System Interupts"
Google is giving me a million different answers and I heard this is the place to get real help, anyways. So I did a clean install a few days ago. Not a ton of apps installed. No anti virus or anything like that. I noticed that my cpu idles between 15 and 20%. Its one core steady at...
Performance & Maintenance
Network Traffic Causing High CPU Usage
Hello. For the last week or so, my network traffic has seemed to be related to some pretty sever spikes in my CPU usage. These spikes are causing extreme stuttering in my music playback, freezing of my cursor, and other symptoms of a really laggy computer. This pretty much occurs whenever I use the...
General Discussion
svchost.exe + NTDLL.DLL Causing high CPU Usage
Computer stats Windows 7 Pro 64 Bit Gigabyte Socket 775 Mobo Intel Core 2 Duo 3.0 CPU Nvidia 8800GT 4 GB DDR2 Ram MSI TV Anywhere PCI TV Tuner Soundblaster Audigy 2 ZS I have recently beginning with last Thursday been experiencing after a good 4-7 hours of the computer being on a massive...
General Discussion


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 03:34.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App