Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Set "Adjust for best performance" for all users

16 Jun 2014   #1
rxd

Windows 7 Ultimate 32 bit, Windows 7 Home Premium 64 bit
 
 
Set "Adjust for best performance" for all users

Is it possible to make Windows 7 use the "Adjust for best performance" option under Visual Effects for every user that has a logon to a pc?

Thanks


My System SpecsSystem Spec
.
17 Jun 2014   #2
gregrocker

 

I would not go that far as Aero overhead is not that high and it really makes the beauty of the OS. And if you don't have or use Aero then Basic is still better than the file cabinet grey Win2000 theme you get if you uncheck "Use Visual Syles on Windows and Buttons." You lose all style, go plug ugly.

On lower resource (>4gb RAM and/or weaker CPU) hardware I uncheck fading, sliding, animation, selection rectangle, and dragging intact which are not noticeable anyway (Why would you care if the words stay intact in a box while you're dragging it? )

If that isn't enough upgrade your RAM, CPU, or buy a new PC to really enjoy the once-in-a-lifetime beauty and instantaneous performance of native Win7.

Then make these changes for each User. Someone may know how to do it in Group Policy if you have higher than Home Premium version.
My System SpecsSystem Spec
17 Jun 2014   #3
logicearth

Windows 10 Pro (x64)
 
 

Actually, the overhead of Aero is nil, compared to Aero Basic or Classic. Aero unlike the other two runs completely on the GPU. The other two are solely CPU bound. If your computer can run Aero you should use it, it offers the best performance.

The perceived slowness of Aero is not actually Aero being slow rather its the animations that add a delay. Turn those off and everything is instant.

Without Aero, my dinky underpowered Atom netbook would be awful.
My System SpecsSystem Spec
.

17 Jun 2014   #4
andrew129260

Windows 10 Pro
 
 

Quote   Quote: Originally Posted by rxd View Post
Is it possible to make Windows 7 use the "Adjust for best performance" option under Visual Effects for every user that has a logon to a pc?

Thanks
Simple answer no. These are user profile specific. Just like default programs.
My System SpecsSystem Spec
17 Jun 2014   #5
LMiller7

Windows 7 Pro 64 bit
 
 

This is an interesting article concerning these settings:
"Adjust visual effects for best performance" should really be called "Adjust visual effects for crappiest appearance" - The Old New Thing - Site Home - MSDN Blogs

The blog is by Raymond Chen, a developer with Microsoft since 1992.

Read the article, then decide if you still want to do this.
My System SpecsSystem Spec
17 Jun 2014   #6
rxd

Windows 7 Ultimate 32 bit, Windows 7 Home Premium 64 bit
 
 

Yes, I want to do this. Believe me we have our reasons....
My System SpecsSystem Spec
17 Jun 2014   #7
andrew129260

Windows 10 Pro
 
 

Quote   Quote: Originally Posted by rxd View Post
Yes, I want to do this. Believe me we have our reasons....

Could you explain what those reasons are?

warning   Warning
The following will lower performance, not increase it!

OK fine, I will give you the dirty way of doing it...but I do not like it....


If you change the themes service to manual startup and restart, it will disable all eye candy and everything. The themes service will not run, so changing themes under personalization will still be possible as the service can then start itself. Nothing at all that involves visual effects will run. If you disable it, the themes service cannot be started in any way shape or form. But it may cause system instability.
My System SpecsSystem Spec
17 Jun 2014   #8
gregrocker

 

Then why suggest it?

What are the exact reasons? We need to know and there would be no reason not to say if its legit.
My System SpecsSystem Spec
17 Jun 2014   #9
rxd

Windows 7 Ultimate 32 bit, Windows 7 Home Premium 64 bit
 
 

I don't know what the big deal is as to the why of this. Ok, if you really want to know, we are experiencing issues with our pc's that performance is becoming terrible. Going into task manager and looking under performance I am seeing 50% cpu usage even with nothing running. Don't bother saying virus because we are not even connected to the internet or anything. I can see right away that Desktop Composition is one of the chief culprits. Disabling this usually completely fixes the problem, but not always. Sometimes the cpu usage will drop from 50% to around 20%, most of the time it will drop from 50% to 1%. What always works is setting setting the Adjust for Best Performance option. This always drops cpu usage down to 1%. I suspect it was a windows update that has caused this but I really am not sure and I don't have either the time or desire to try to experiment uninstalling and re-installing a ton of windows updates in the hope of finding the culprit, if that even is the problem. Especially when setting adjust for best performance always fixes the issue.
My System SpecsSystem Spec
17 Jun 2014   #10
andrew129260

Windows 10 Pro
 
 

Quote   Quote: Originally Posted by rxd View Post
I don't know what the big deal is as to the why of this. Ok, if you really want to know, we are experiencing issues with our pc's that performance is becoming terrible. Going into task manager and looking under performance I am seeing 50% cpu usage even with nothing running. Don't bother saying virus because we are not even connected to the internet or anything. I can see right away that Desktop Composition is one of the chief culprits. Disabling this usually completely fixes the problem, but not always. Sometimes the cpu usage will drop from 50% to around 20%, most of the time it will drop from 50% to 1%. What always works is setting setting the Adjust for Best Performance option. This always drops cpu usage down to 1%. I suspect it was a windows update that has caused this but I really am not sure and I don't have either the time or desire to try to experiment uninstalling and re-installing a ton of windows updates in the hope of finding the culprit, if that even is the problem. Especially when setting adjust for best performance always fixes the issue.
No need to get angry here.

I do not see how that would happen unless you have:

-a really crappy processor pentium 4 or lower
-very little ram
-tons of startup programs
-A beefy antivirus
-Just because you're not connected to the internet does not mean you are safe from malware.
-old drivers
-broken updated glitchy drivers

If you gave more details on what the hardware is, we could help.
My System SpecsSystem Spec
Reply

 Set "Adjust for best performance" for all users




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Account "Roger" appears as "c:\users\user"
Hi all, I recently created a new user account on a win 7 home premium machine before I'd had much experience with win 7 (but years with 2000 and xp). Instead of users\Roger\ it created users\user which I now realise is not correct. (I didn't call my account "user", either, before you ask. :) )...
General Discussion
Need to add "TASKBARS" (MSese for "Launchpads", "Docks" NOT "Toolbars"
My office just upgraded, and I can no longer use Windows XP. On this system, I was able to add a separate taskbar to facilitate quick access to commonly-browsed folder locations on our vast network, and another one expedited the launching of useful programs and lists. Each task on each taskbar...
General Discussion
System performance "slow" warning in any game, but running just fine
I'm very tired of seeing this message booting me to desktop just to ask me if I want to change the color scheme because it perceives my computer is running slow. Load up Batman AC? 10 minutes in focus changes from said full-screen app to this completely unnecessary 'warning'. Battlefield 3? ...
Performance & Maintenance
Need To Add "Authenticated Users" Every Directory Within "Music"
First off this is my work laptop. I have my standard Music library, which is a directory directly off the C drive. When I download or move into that "Music" directory the directory I moved has a lock icon on it. In order to get rid of the icon, I need to add "Authenticated Users" to the...
General Discussion
ROBOCOPY and not existing folder "c:\Users\"MyUser"\Doc
Hello Fellow 7 users, I have just switched OS to Windows 7, and i am impressed so far. I want to backup my data on an external harddrive. I would like to use the function ROBOCOPY in the command windows because then i don't have to third party program running all the time. But the copying...
General Discussion
How can I adjust the "robustness" of my VMs?
I've running Windows 7 x64 Quad-core laptop (4GB) along with 2 VMs running W2K3 (1GB, 800MB respectively). The amount of time I spend in the VM waiting for the cursor to catch up to my typing is really getting annoying. Half the time I don't see "as I type" and then after a sec. pause, it all...
Virtualization


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 09:11.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App