Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Very slow system

28 Aug 2014   #21
Mayank Parmar

Windows 10 Tech Preview
 
 

you can remove the above detected items


My System SpecsSystem Spec
.
05 Sep 2014   #22
Mhensien

Windows 7 64 bit
 
 

I checked the device manager and there was nothing that is yellow or red. The system is running better, however there is still a frequent lag - almost like a process is running. When I look at the Task Manager I don't see any unusual process, but many times I will see the process that is lagging listed as unresponsive - but it doesn't stay that way for long - just long enough to be frustrating. Any ideas?
My System SpecsSystem Spec
Reply

 Very slow system




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Network slow to initialize on startup, slow system
Specs: Win7 64bit, 4GB ram. For the past little while now, whenever I would turn on my computer, things would start up but it would hang, in the sense that nothing *would* start up until the network was found and connected to. The network indicator icon in the taskbar would just have a frozen...
Network & Sharing
Seriously slow system...
Hey, I have followed the tutorial for a clean install however my machine is unbelievably show and almost unusable. It's been installing Windows essentials for almost 40 minutes now and there seems a good 3 second delay between clicking and responding. The only driver I installed myself...
Performance & Maintenance
System gone really slow.
My computer has suddenly gone really slow, for some reason, it can't handle more than one task at once or is very slow and choppy. For example, I can't transfer files without it being slow. I have 8GB of Ram, but can only use 4GB as for some reason I can't get 64 Bit. - ATI Radeon 6770...
Performance & Maintenance
Unknown icon in system tray - slow system - pic attached
Hi, I've been having some very slow system issues today and have checked that system resources seem to be at normal levels - CPU usage at around 20% and Memory usage at around 50% during normal operating. However I have noticed a new icon in my system tray which I can't identify, can't click...
Performance & Maintenance
system slow down
HI.. i jus bought new sony vaio-E series with 2 GB ram,,, it was fine working for 3 weeks,, i installed sql server n visual studio,,, my lap gettin slow in booting,,,and in performance,,, i m using windows 7 os 64 bit,, is dre any way to increase its speed and performance,,, any one ....plz...
Performance & Maintenance
Slow system
For the past few days, my Windows 7 x64 Ultimate desktop PC has bee sluggish. I click on anything, whether in a browser or to open any other window, and it just takes a few seconds to respond. I've checked task manager to see if anything new is running, and nothing. I show 0% CPU usage and 9%...
Performance & Maintenance


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 22:55.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App