Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: optimising ram usage

30 Sep 2014   #21
Tranquil Hegemo

Windows 7 64bit
 
 

Quote   Quote: Originally Posted by timeless View Post
.... in addition a good gmail notifier as well because l had to downgrade due to the gmail manager not working on the newer versions that supports multiple gmail accounts..
Try Gmail Watcher - https://sites.google.com/site/sonthakit/gmailwatcher - not available via the Firefox add ons page for some reason since version 1.5x IIRC but the developer is still working on it. Definitely works for multiple accounts as I am using it for that purpose.


My System SpecsSystem Spec
.
30 Sep 2014   #22
PWRwindows

Windows 7 Ultimate x64
 
 

Quote   Quote: Originally Posted by timeless View Post
tbh things seem to be fine now, tho firefox does seem to hog more ram than it used to but l can live with that as l dont browse the net all the time.

the only issue l have atm is when turning off one specific external for some reason l hear a disconnection sound of a device then a reconnection one despite things been turned off by that time. however that said when l used the safely disconnect device thing it didnt do it, it only happens with one external (the only one l have that has its own switch on the other one is fine along with my usb flash drive) but lve no other annoyances other than that at the moment.

regardless l have taken a screen cap of the disabled services, to my knowledge with regards to the screen cap the only services l have personally disabled are:

Gigabyte
Windows media player ones
Tablet PC input
parental controls
google ones
Adobe
Offline files
Windows Indexing (l have usually turned this one off and have never had issues doing so)

lve not touched ANYTHING else, just those services if l remember correctly.
How many external devices do you have connected? My next door neighbor had like 2 external drives and one that did continuous IMAGE updates in realtime happening and sometimes his PC would freeze up. If you have external drives and only use them occasionally disconnect them and only plug them in when you need to write to them or read ( get some data) from them. USB can use alot of your PSU also and it does consume RAM to have all those running all the time.

(just a side note: I don't watch or use my dvd drive often so I don't even have it plugged into my SATA or PSU unless I actuall need to use it) *every volt your PSU doesn't have to use is another day of life it has.

Same for RAM and having to many devices that your ram has to load and then they aren't even used often.
My System SpecsSystem Spec
30 Sep 2014   #23
matts6887

Windows 7 ultimate 64-bit
 
 

I would maybe try expanding the amount of ram you currently have if at all possible. And pwr above is right. Any external devices may be consuming large amounts of ram depending on the device etc.
My System SpecsSystem Spec
.

30 Sep 2014   #24
PWRwindows

Windows 7 Ultimate x64
 
 

Quote:
l hear a disconnection sound of a device then a reconnection one despite things been turned off by that time
that gives me pause.. you can disconnect a device then it reconnects auto? ... can you tell me which device does that..

That might be your problem right there.

I think this has been pin pointed with what you posted right there.
My System SpecsSystem Spec
30 Sep 2014   #25
timeless

Windows 7 Professional (64bit)
 
 

lve set the .nets to manual that were disabled (both services l had not touched as l knew they were integral parts of the system).

as for the device that causes the issue lve linked to it here if memory serves the drive l put in it is a Seagate drive (3TB), as for connected devices the ones that are connected and turned on are my keyboard/mouse and wireless adapter, while l do have another usb cable connected the device isnt turned on as l only connect externals as and when needed, but when l used the safely disconnect yesterday (as l mentioned) l didnt get the disconnect reconnect sound.
My System SpecsSystem Spec
04 Nov 2014   #26
timeless

Windows 7 Professional (64bit)
 
 

been noticing that svchost has started to eat my ram again, one of the services was eating nearly a gig of my ram on its own..

then l remembered process explorer it seems the svchost processes eating my ram are all labelled as being under the explorer process so l looked under the threads tab on the properties of the service to notice the largest of the svchost processes seems to have many instances of "ntdll.dll!RtlValidateHeap+0x170" within it, the other did as well but not as many, lm wondering if thats what has started eating my ram.

have uploaded memory dump from my windows directory, last one l removed was over 700meg this one is around 600meg (tho lve compressed this one) wondering if it will help locating the reason why svchost under the explorer process seems to starts to eat my ram as before my upgrade l never had problems with ram and the only thing that used allot was my browser but ld always go back to under 30% usage where as now it just grows and grows.

heres the link to the 600meg memory dump from my windows dir, lve compressed it down to 110meg:

https://www.sendspace.com/file/8qnhrj


Attached Thumbnails
optimising ram usage-untitled.jpg  
My System SpecsSystem Spec
Reply

 optimising ram usage




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Have high CPU usage and Memory usage
Hi. I was using my laptop a few days ago. I left to go out and came back about an hour later. I notice my CPU usage was running @ 100% & the memory @ 80%.My laptop just stopped. I went into safe mode and that is where I am currently . I have deleted almost everything I don't use(didn't...
Performance & Maintenance
Frequent unresponsiveness, 100% hardware disk usage, 0% software usage
Every 10-40 minutes, the application I'm currently working in becomes unresponsive, and after a minute or two, the window turns white, notifying me that it's not responding. This unresponsiveness quickly spreads to other open processes, rendering them frozen as well. I can still use the mouse, and...
Performance & Maintenance
optimising windows 7
http://www.sevenforums.com/tutorials/11728-optimize-windows-7-a.html so ive completed everything on this list, and my computer is like lightning... theres one thing on the list i need help with though, and thats: 2. Install the Latest BIOS and Device Drivers i dont know where to begin...
Performance & Maintenance
System Restore - Current usage exceeds Max Usage
In system protection, the current usage is at 405GB while max usage is defined at 279GB (30%). 1) How this can happen ? ,and 2) How can I set the Max Usage to be kept?
Backup and Restore
Windows 7 random CPU usage and high physical memory usage!!!
Ok, I am literally KILLING myself over this! I installed Windows 7 64Bit over XP around a month ago and it was so good that I recommended it to my brother who was previously on XP too. We got him a copy of the 32bit version as he has only 2gb of memory, and he installed it on his machine....
Performance & Maintenance
Ram usage
Here are my Process.Why svchost is repeating ? (newbie here ) http://img690.imageshack.us/img690/8830/sss1.png http://img222.imageshack.us/img222/7315/sss2s.png Also It takes 2 min to complete boot, as I've oracle installed.I terminate the process after login but after every boot it...
Performance & Maintenance


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 19:35.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App