Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: PC running really slow when browsing

27 Nov 2014   #1
peterposh

64
 
 
PC running really slow when browsing

It runs call of duty fine with no issues .,It's only when I start browsing that the pages take 10 -20 seconds to load and sometimes shows the "not responding" , It happens on chrome and firefox, it's even lagging when I'm typing here . when I check on the performance it's using %23 on CPU and %40 ram , I can't understand what's causing the delay , my internet connection when using a test site states 30 mb


My System SpecsSystem Spec
.
27 Nov 2014   #2
PirateX20

Windows 7 Sp1 x64
 
 

Quote   Quote: Originally Posted by peterposh View Post
It runs call of duty fine with no issues .,It's only when I start browsing that the pages take 10 -20 seconds to load and sometimes shows the "not responding" , It happens on chrome and firefox, it's even lagging when I'm typing here . when I check on the performance it's using %23 on CPU and %40 ram , I can't understand what's causing the delay , my internet connection when using a test site states 30 mb

try this:

Go to: start, hit "run", type in: gpedit.msc

then go to --- Computer configuration/administrative templates/network/QoS Packet scheduler

the go to the right panel and dubble click on limit resevable bandwith, and click on enable and changed it to 0 (default is 20)

hopefully this fix some delay
My System SpecsSystem Spec
Reply

 PC running really slow when browsing




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Running real slow / shut down slow
Hi i have a Eee Pc Asus laptop that is running real slow could someone help me please thank you i ran a farbar scan if that might help Scan result of Farbar Recovery Scan Tool (FRST) (x86) Version: 19-07-2013 Ran by Ma (administrator) on 21-07-2013 16:25:23 Running from E:\ Microsoft...
Performance & Maintenance
Slow Internet Browsing
My machine is presario cq62, with an intel i5 processor. i do experiencing an extraordinary slowness in both browsing and downloading. I Tried re-installing OS several times, and was not successful. I'm using avg antivirus package. I'm using Google crome as current browser. Cooling fan is also...
Browsers & Mail
Slow browsing.
Hey guys. Had my new machine 4 or 5 months now, running great. Very high spec. Just yesterday, I was using Google Chrome and it just suddenly... wouldn't load ANY pages. My internet is working fine. So I used Firefox instead, as that seemed to be working fine. But today, that's being really...
Browsers & Mail
Slow browsing after Win 7 Pro 64 install
After my initial install, everything went fine for about a week and then the bottom fell out and was unable to effectively browse the internet, due to very slow to almost no ability to browse... my system would just hang up... read a lot of threads about this issue... Microsoft has not addressed it...
Browsers & Mail
Windows 7 Browsing slow
I have been trying to fix this problem for 4 days now, and I am pulling out my hair. I need help. I have installed both IE8 and Firefox, both have the same problem. Google loads super fast...no problem there. But other web pages, load very slow, some times more than 5 minutes. In my head I...
Browsers & Mail


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 09:28.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App