Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Two explorer.exe, One taking all of my RAM's Memory

10 Dec 2014   #51
Callender

Microsoft Windows 7 Home Premium 64-bit 7601 Multiprocessor Free Service Pack 1
 
 
iTunes & MS XML Core Services

I'd suggest the following:

Try downloading this patch from Microsoft:

Download MSXML 4.0 Service Pack 3 (Microsoft XML Core Services) from Official Microsoft Download Center

Get the msxml.msi download and save to your desktop then run it. Hopefully that should fix it.

As for iTunes - it's up to you. Try updating it or if you don't need it and won't lose any paid for music - uninstall it. Like I said before I know nothing about iTunes as I've always used alternatives!


My System SpecsSystem Spec
.
10 Dec 2014   #52
AfrimS

Windows 7 Home Premium 64bit
 
 

So after downloading that patch that you gave me and uninstalling iTunes since I have no use for it I did another scan with secunia and here is what is now shown - Screenshot by Lightshot -. Also when I look into Geek Uninstaller there is 3 MSXML's shown in there two of the SP2's and one of them SP3 - Screenshot by Lightshot -.
My System SpecsSystem Spec
11 Dec 2014   #53
Callender

Microsoft Windows 7 Home Premium 64-bit 7601 Multiprocessor Free Service Pack 1
 
 
Microsoft MSXML issues

That didn't go too well then. I'd assumed that installing it (MSXML 4)would take care of the update. Further research shows that MSXML 4 has been superceeded by MSXML 6 so on that basis I'd suggest uninstalling MSXML 4 then try updating MSXML 3 and MSXML 6. Sorry about that!

Also looking at your logs once more I've noticed that you have utorrent installed. Many utorrent users seem to be reporting issues with an additional memory hogging explorer process being created get after opening the containing folder in utorrent. Have you been using utorrent when you've seen the two explorer.exe problem appear?

It might be helpful if you could run another "scan and create log" with UVK when only one explorer.exe is shown in task manager. Then it might be possible to compare the two logs.
My System SpecsSystem Spec
.

11 Dec 2014   #54
AfrimS

Windows 7 Home Premium 64bit
 
 

How should i do a scan and create log with only one explorer.exe shown? Usualy after ending the process it comes back like 3-5 seconds later but I could try booting into safe-mode or something else?
Also should i unstall all three MSXML 4.0 and just install MSXML 6.0? not to sure what to do here and as for uTorrent and explorer.exe problem the explorer.exe problem happens no matter what, even if i just boot the pc and dont do anything else

EDIT:
Also what settings should I use for the scan and create log? these settings or something else - Screenshot by Lightshot -
My System SpecsSystem Spec
11 Dec 2014   #55
Callender

Microsoft Windows 7 Home Premium 64-bit 7601 Multiprocessor Free Service Pack 1
 
 
UVK scan settings

Okay so if the explorer.exe issue always happens then you can't get a scan with only one explorer.exe running.

As far as MSXML 4.0 is concerned I'd suggest removing all three that show up in the scan but leave MSXML 3 & MSXML 6 installed and try updating those.

You can run another UVK scan anyway with the following settings applied:

Two explorer.exe, One taking all of my RAM's Memory-uvk-scan-settings-2.jpg


My System SpecsSystem Spec
11 Dec 2014   #56
Callender

Microsoft Windows 7 Home Premium 64-bit 7601 Multiprocessor Free Service Pack 1
 
 
7-Zip?

Since you've removed 7-zip and the issue remains - you could reinstall it but you could also consider other alternatives. Currently I use the 64bit version of Peazip. Link if you're interested:

PeaZip 64 bit | Open and extract RAR 7Z TAR ZIP ZIPX files
My System SpecsSystem Spec
11 Dec 2014   #57
AfrimS

Windows 7 Home Premium 64bit
 
 

Okay so 7Zip was removed a while ago and now just uninstalled winrar, I did install the peazip thing you suggested to me.
I have removed all three MSXML 4.0 and updated the new versions of MSXML 3.0 and 6.0
Here is the UVK scan as requested - https://www.dropbox.com/s/0h7v39v526...11-14.txt?dl=0 -.
My System SpecsSystem Spec
11 Dec 2014   #58
Callender

Microsoft Windows 7 Home Premium 64-bit 7601 Multiprocessor Free Service Pack 1
 
 
UVK Scan

Thanks for the log. Winrar still shows up. The log seems to be missing lots of stuff.

It shows:

Scan mode: Hide all Microsoft files, Verify file signatures.
Scan options: Scan all users, Include MD5 hash, Include recent folders.

Would you mind doing the scan again but in the UVK scan options screen choose "None" and all the checkboxes will be cleared. Then apply the ones shown in the screenshot in this post:

Two explorer.exe, One taking all of my RAM's Memory

Ignore the "All" checkbox - just select "None" and apply the other settings. At that point don't worry if a tick appears in "All" - just run the scan. Thanks!
My System SpecsSystem Spec
11 Dec 2014   #59
Callender

Microsoft Windows 7 Home Premium 64-bit 7601 Multiprocessor Free Service Pack 1
 
 
Next steps

I'll look at your log tomorrow once you've uploaded it and report if I see any problems.

The next steps will involve some troubleshooting by doing a clean boot as shown in this tutorial:

Troubleshoot Application Conflicts by Performing a Clean Startup

Don't try this yet. Just have a read through it!
My System SpecsSystem Spec
11 Dec 2014   #60
AfrimS

Windows 7 Home Premium 64bit
 
 

I remember doing this before actuary that someone else suggested to me but I had forgotten what the outcome of it was so i will try tomorrow, I need to sleep for now.
My System SpecsSystem Spec
Reply

 Two explorer.exe, One taking all of my RAM's Memory




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Two explorer.exe, one taking up to 3 gigs system memory
So the other thread was no help, so I started this one. When I start up my computer and after its loaded (in normal and clean boot) an explorer.exe shows up and starts rapidly ballooning up over the 2 million bits mark, making my computer really slow. I've cleaned with Comodo, Malwarebytes...
Performance & Maintenance
MsMpEng.exe taking up too much memory
MsMpEng.exe(windows defender) has taken up lots of my computer's ram and cpu usage and is making my computer really slow But when I try to open windows defender it says that windows defender has been disabled even though MsMpEng is running. Trying to turn on windows defender in order to disable it...
System Security
Internet explorer taking up a lot of memory, also disable screensaver
Does this happen to someone else also? I usually have about half dozen IE windows opened at anytime. I might start a few more and then close a couples. But eventually I notice one or two if the IE processes start to use up several hundred MB ram up to eventually 1GB ram. When one of the IE...
Browsers & Mail
Why is IE taking up so much memory?
I took a look at my TaskMan because my Core 0 was at 100%, and I just exited a flash game. I had 4 IE windows open, and a total of 4 tabs. One iexplore.exe was using over 400,000K. I clicked on the Applications tab, right clicked on each App, and selected Go To Process. None took me to the...
General Discussion
Svchost taking too much memory
my svhost process is taking too much Memory... making my computer lag..it havent happened any time before... http://www.pikipimp.com/pp/pimped_photo/s/image/52/806/368/Capture.PNG?ts=1264555978397:shock::shock::shock: please suggest a solution..
Performance & Maintenance
Graphics taking more memory
Hi, recently i brought a DELL Inspiron 15 laptop, which has 4GB RAM and integrated Graphics+Core i5 Processor.But when i check my system properties it shows Available Memory : 4GB (Usable 2.93GB). when i made some tests regarding the 1 GB missing RAM, i found that intergrated Graphics current...
Graphic Cards


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 23:30.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App