Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Slow Copy Speeds 10 MB/s w/Teracopy and system Freezes!

31 Dec 2014   #1
PlatypusKnight

Dual Boot Win 8.1 x64; Win 7 SP1 x64
 
 
Slow Copy Speeds 10 MB/s w/Teracopy and system Freezes!

First off, Happy New Year all. And thanks in advance to contributors.

I have looked at every thread on this issue and there doesn't seem to be definitive solution.

I've googled this on and off over the last two years and I don't have a solution.
I'd like to know if this is what is supposed to happen or are my speeds slow and capable of improvement.

I copied 90gb this morning to my PC from a WD 500 GB external drive. That took 2 hrs 44 mins. Admittedly there were numerous pauses in between.

I noticed that if I paused the copying process the system issues would go away. When I restarted, the system issues would start again. I also noted that Teracopy would report a 10-11mbs copy speed during prolonged copying, but after pausing and restarting would rocket up to between 66-78 MB/s and stay there for two file copies but never more. After that it would progressively slow until it got back to 11 MB/s.

I had three Firefox instances open while I was copying, two Word documents, and initially the system was unusable. After a bit the system was extremely slow but usable. Alt+Tabbing would cause a loading "This app is not responding" error. Eventually the app would load.

I noticed that RAM usage climbed all the way up to total 8 gigs usage.
After disabling MSE the system was still extremely slow, copying speed did not increase, but at least the system was now usable. RAM usage settled back at about 5 gigs.

I also noted that running any program that required UAC authorization would halt the system for about 3 mins. By halt I mean, music stopped playing, screen darkened, and mouse and keyboard unresponsive.

Is this expected/normal operation?


My System SpecsSystem Spec
.
31 Dec 2014   #2
mdd1963

Windows 7 Home Premium 64 bit
 
 

What sort of speeds/indications do you get doing normal copy/paste operations?

(I'm generally distrustful of most applications that promise to 'speed up' normal Windows operations that are, in fact, hardware limited by hardware design such as conventional hard drives and/or USB/USB2 connection limits.)

I'd just uninstall the app and be done with it.
My System SpecsSystem Spec
31 Dec 2014   #3
mdd1963

Windows 7 Home Premium 64 bit
 
 

Merely by looking at Teracopy's website, my firewall is having to block a drive-by application download, even though I've clicked on nothing. I'd be leery of anything they offer just based on that.
My System SpecsSystem Spec
.

31 Dec 2014   #4
PlatypusKnight

Dual Boot Win 8.1 x64; Win 7 SP1 x64
 
 

Quote   Quote: Originally Posted by mdd1963 View Post
Merely by looking at Teracopy's website, my firewall is having to block a drive-by application download, even though I've clicked on nothing. I'd be leery of anything they offer just based on that.
Really? Teracopy has been a trusted piece of Win7 software for almost a decade.
My System SpecsSystem Spec
03 Jan 2015   #5
PlatypusKnight

Dual Boot Win 8.1 x64; Win 7 SP1 x64
 
 

For any interested, I eventually uninstalled TeraCopy.

After some Googling on improving copy speeds in Win 7 I came across this page:
https://www.raymond.cc/blog/12-file-...ransfer-speed/

Turns out TeraCopy is not the fastest copier.

I'm currently testing FastCopy and ExtremeCopy.
Fast Copy gives me speeds of 60 MB/s and doesn't bring my machine to a screeching halt, or start siphoning RAM. So if I can satisfactorily have it integrate into the shell I'll probably settle here.
I do wish I could have learned how to increase copy speeds, maybe there are some tweaks I can make to my system, but this will have to do for now.

Either way, goodbye TeraCopy.
My System SpecsSystem Spec
Reply

 Slow Copy Speeds 10 MB/s w/Teracopy and system Freezes!




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Slow download speeds, Fast upload speeds. Other devices are fine.
My computer has extremely slow download speeds, upload speeds are fine. Ping is always at ~10-20ms. (to Google) The problem has nothing to do with, my ISP, my router, my type of connection. I know this for a fact. http://www.speedtest.net/result/3745496488.png I've tried multiple network...
Network & Sharing
I can't integrate portable TeraCopy as default copy program
I want to install TeraCopy in portable format and during installation i choose Portable Version, but after this in the Preferences window it doesn't allow me to select Use TeraCopy as default copy handler. http://img850.imageshack.us/img850/6886/7lki.jpg Can someone tell me how to integrate...
Software
Slow Wireless Speeds - Laptop is fine, Desktop is SLOW
Hello all, First off, I have been searching these forums for several days and have seen a number of people reporting slow wireless connections in Windows 7. Which was comforting, knowing I was not alone - but unfortunately I've yet to find the answer in any of the older posts, so I am hoping...
Network & Sharing
USB Sticks slow transfer speeds, system takes forever to load drivers
Hi-have been struggling with my system taking 2-3 minutes to find drivers for any memory stick I plug in to any of 3 USB ports on my Acer 1810T. When the process finally completes, the transfer speeds are about 1MB/s or less. Another (possibly related?) problem is when I insert any SD card in...
Hardware & Devices
System freezes/runs really slow
I ran a program called WinASO Registry Optimizer and it corrupted my software somehow. My system wouldn't startup. I tried using startup repair and system restore with no avail. After repeatedly trying to get it to start up, it finally creeped and here I am. Things seem to run fine, just in...
BSOD Help and Support
Ridiculously slow copy and read speeds on my Asus Dvd drive..Help!
Hey guys, It seems this problem has been annoying me for quite some time now but I have never really bothered to fix it simply because I really don't use the drive to install my games and stuff. But NOW the time has come for me to install a game from a disc (GTAIV) it's taking FOREVER! I mean...
Hardware & Devices


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 03:14.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App