Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Sluggish UI & High CPU usage

06 Nov 2009   #1
SailingNut

Windows 7 Ultimate x64
 
 
Sluggish UI & High CPU usage

I've noticed quite a bit of "hesitation" in the Windows 7 UI compared to Vista. I've been looking at my CPU usage and it also seems high.

I've been looking at task manager to see what processes seem to be using a lot of CPU and I can't quite pin it down to a single process that seems to be hogging the CPU when things are sluggish.

Any good suggestions foe next steps on troubleshooting this?

I've given some thought to it being my Nvidia drivers. Anyone else out there running the 191.07 drivers and seeing similar problems? (FYI I'm running an Nvidia 8800 GTS card)

TIA!


My System SpecsSystem Spec
.
06 Nov 2009   #2
Jonathan_King

Windows 7 Professional x64
 
 

Often times anti-virus software can use a lot of resources. Can you post a screenshot of the task manager?
My System SpecsSystem Spec
06 Nov 2009   #3
SailingNut

Windows 7 Ultimate x64
 
 

Here's a shot of my task manager attached


Attached Thumbnails
-task-manager.jpg  
My System SpecsSystem Spec
.

06 Nov 2009   #4
Jonathan_King

Windows 7 Professional x64
 
 

What security software do you use?
My System SpecsSystem Spec
06 Nov 2009   #5
SailingNut

Windows 7 Ultimate x64
 
 

Using Kaspersky antivirus.

I have been watching things more closely and I see that when I browse to a new page in IE8 it's CPU jumps to 30-50% In Outlook when I switch folders in my e-mail it uses 50% or more of the CPU. Also starting a game from the games folder causes explorer to jump to around 50%

I've never really watched my CPU so closely so those number could be normal, but they seem awfully high to me.
My System SpecsSystem Spec
06 Nov 2009   #6
logicearth

Windows 10 Pro (x64)
 
 

The CPU jumping to 50% is normal when an application is doing something. What matters is how long it is at 50%. Since you have a dual-core processor, 50% means one thread is executing on one core. 100% would be two threads are using both cores.

Try disabling or uninstalling your antivirus for the time being, and/or download any updated drivers you can find.
My System SpecsSystem Spec
06 Nov 2009   #7
SailingNut

Windows 7 Ultimate x64
 
 

I also have a "dual core" CPU monitor gadget running and it shows both cores jumping up quite high from time to time, but since it doesn't show processes I can't correlate it with any particular one.

I just did a check and when I open a new tab in IE both cores jump to 100% at a point and they are both over 75% for 2-3 seconds before the new tab finally opens. I also see the same thing happen when opening a game from the games folder.

Any ideas what i can do to dig in farther to see what might be causing this to happen? (It seems quite excessive to take several seconds to open a new tab or a game.)
My System SpecsSystem Spec
06 Nov 2009   #8
logicearth

Windows 10 Pro (x64)
 
 

Don't worry about the jump in CPU usage. The CPU usage is going to jump like that because well...you have to use the CPU to do anything. Did you try disabling your antivirus? Cause you know a lot of them want to scan everything that you click on.
My System SpecsSystem Spec
06 Nov 2009   #9
SailingNut

Windows 7 Ultimate x64
 
 

Understood that the CPU does have to do the work.

I disabled my AV and the sypmtoms are still there. (I didn't have this sort of problem under Vista even with AV enabled)

I timed it out and when opening solitaire from the games folder and the CPU is over 75% for about 11 seconds. It hits 100% just as the UI is drawn for the game and stays there for a second or two after the UI us drawn. It then hovers in the 95% range for a few seconds.
My System SpecsSystem Spec
06 Nov 2009   #10
Jonathan_King

Windows 7 Professional x64
 
 

You seem to have a lot of processes running. The sheer number of tasks it has running can also contribute.
My System SpecsSystem Spec
Reply

 Sluggish UI & High CPU usage




Thread Tools




Similar help and support threads
Thread Forum
Attempted RAM Upgrade - CPU Usage spikes to 100% - Now Sluggish
Hi all, I could really use an assist as I am on a tight deadline and suddenly my CPU isn't working as it should. I just attempted to add 8 GB of DDR4 Ram to my new Dell Precision Workstation Tower 5810, to bring my total installed to 16GB. So I got two 4 GB Crucial sticks from Amazon, and was...
Hardware & Devices
Sluggish Performance/Memory Usage
My computer has been running very sluggishly lately. It seems that becomes bogged down even when I leave it alone and it's idle. I have a pretty decent amount of RAM (12gb) and it doesn't run any smoother when I close programs. I've attached some screenshots from Task Manager. I've cleared...
Performance & Maintenance
Have high CPU usage and Memory usage
Hi. I was using my laptop a few days ago. I left to go out and came back about an hour later. I notice my CPU usage was running @ 100% & the memory @ 80%.My laptop just stopped. I went into safe mode and that is where I am currently . I have deleted almost everything I don't use(didn't...
Performance & Maintenance
Very high CPU usage, causing very high laptop CPU temps (90c idle)
This problem began yesterday. I noticed my CPU was at 90C constantly with very high CPU usage (>50%). I had no major programs running. I rebooted several times and the program persisted. 1. I went into safe mode and everything was normal. So this rules out hardware issues. 2. I reformatted and...
Performance & Maintenance
High CPU usage, low fps, high latency.
Since Jan-Feb of this year I have encountered the following issue while trying to play games on my laptop. Abnormally High CPU Usage Extremely low FPS - After 5-20 Mins of play. Extremely High latency to servers - from 300 - 900 after 5 - 20 mins of play. The thing is all of these started 1...
Performance & Maintenance
Windows 7 random CPU usage and high physical memory usage!!!
Ok, I am literally KILLING myself over this! I installed Windows 7 64Bit over XP around a month ago and it was so good that I recommended it to my brother who was previously on XP too. We got him a copy of the 32bit version as he has only 2gb of memory, and he installed it on his machine....
Performance & Maintenance


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 20:59.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App