Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Windows 7 SP-1 is running very slow ..........

18 Mar 2015   #11
saikoushik123

windows 7 home premium 64 bit
 
 

Thanks for reply sir , Don Bradman cricket is now working well at 1024*768 screen resolutions and Suggest me some tweet to speed up my system and increase my windows experience index value without buying external hardware for the time being.
In my company we are going have a game shows where I need to play Need for speed most wanted along Don Beadman cricket, Don Bradman is now fixed but Need for speed still lags it is already running in small resolution and other problem it lags too much and takes in time for processing when I go for LAN play particularly. NFS carbon goes with my system but this old version NFS doesn't


My System SpecsSystem Spec
.
18 Mar 2015   #12
Layback Bear

Windows 7 Pro. 64/SP-1
 
 

You need to fill in your system specs completely.
Take your time and complete this tutorial exactly like it states.

System Info - See Your System Specs
My System SpecsSystem Spec
20 Mar 2015   #13
mike009

w7 ultimate 64-bit sp1
 
 

Hi, have a look at the bellow website:

system requirements for your games:
Don Bradman Cricket 14 system requirements | Can I Run Don Bradman Cricket 14
GPU comparison:
PassMark - Video Card Performance Comparison[]=2&cmp[]=1279&cmp[]=1425

I think you have Intel HD 4000 graphics which is about the same as Geforce GT 520 (minimum required for cricket game) but it is also 40% less of what is required for NFS (Geforce 8800GT)

Unfortunately the problems you have are not software related they are graphics card related. The one you have is not powerful enough


Attached Thumbnails
Windows 7 SP-1 is running very slow ..........-gpu.png  
Attached Images
Windows 7 SP-1 is running very slow ..........-nfs.png Windows 7 SP-1 is running very slow ..........-cricket.png 
My System SpecsSystem Spec
.

Reply

 Windows 7 SP-1 is running very slow ..........




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Windows 7 x64 5GB RAM still running Dayz slow
drivers updated Figured id ask here instead of on the dayz forums because people here know a lot more If you need to know more about my computer just click on my name and click on system spec
Performance & Maintenance
Windows 7 is running way too slow, please help!
I just got a new Dell Inspiron ONE 2320 with Windows 7 and it is unbelievably slow! I has XP on my old computer and never had these issues. Google Chrome takes forever, IE9 is much worse and just getting into My Documents takes a long time as well. I checked for performance issues in the...
Performance & Maintenance
Windows 7 Running Slow and Freezing
Alright, so here's the story. I have a Sony Vaio laptop that uses Windows 7 64-bit. A few days ago I was working on a paper and after finishing, as opposed to turning the laptop off, saved the paper and let my laptop go into sleep mode. I've done this before and it's never hurt anything, but the...
BSOD Help and Support
Laptop running windows 7 is too slow
I made a thread about this about a month ago, but I did everything I was told to do and nothing changed. This laptop is way too slow. The audio is just a big mess from the login screen and onward(really laggy and static-y). I ran some malware stuff and registry repair as suggested, in safe mode...
General Discussion
Reformatted windows 7 32 bit running very slow
Hi guys it's me again. My laptop ran fine when I reinstalled windows 7 but now i have another problem I reformatted my laptop again and reinstalled windows 7 now when I use it, it's running very very slow like I click my computer and it takes 10 mins to load. Please help me. Thanks Nudzore
Installation & Setup
Reformatted windows 7 32 now it's running really slow
Hi guys it's me again. My laptop ran fine when I reinstalled windows 7 but now i have another problem I reformatted my laptop again and reinstalled windows 7 now when I use it, it's running very very slow like I click my computer and it takes 10 mins to load. Please help me. Thanks Nudzore
Performance & Maintenance


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 01:23.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App